Jump to content

How to CLONE osx86 and boot from it


16 posts in this topic

Recommended Posts

Over the last month, I have seen a lot of people on irc and these boards they have wanted to clone their OSx86 drives and boot from them. It takes a lot of HARD DEDICATED work in some cases to get OSx86 perfect. It sucks when things go wrong. And it sucks to have to do it over again.


From personal experiences I have found that cloning this guy can be QUITE tricky. I started off with a 400gb SATAII 8mb cache seagate. It is a VERY loud drive in my case. Every read and write was annoying me. So I bought a Western Digital 500gb 16mb cache to clone to. I've done this 5 times. It gets easier each time, but there are a lot of steps involved, and missing one can mess you up.


The following tutorial assumes you're using SATA but it may also work for IDE.


Step 1 - Swap the drives (optional).

Take your master drive with osx86 and set it as the slave. Take your new drive and set it as the master. This will help keep things less confusing for later steps that involve activating your partition.

Step 2 - Boot of the cd and use Disk Utility to format.

There are a few things involved with this step that one can miss. I have done it a few times and it results in a blinking cursor and the Darwin Loader not loading after a clone. So put your cd in and boot off of it. Go do some sit ups or drink a beer, it takes a while. Once loaded launch Disk Utility. If the top left never turns to Disk Utility, close it and re-open it. My cd likes to try to load things the first time but never completely does until I relaunch it. Once inside Disk Utility you're going to select your drive you want to clone to. DO NOT SELECT THE PARTITION ON THE LEFT SIDE. Make sure you SELECT THE ACTUALY DRIVE. The partition is the disk tabbed in and under the main drive. You should see something like "465.8 GB Maxtor 7H500". Fill in your details there. Once you have it selected click the Partition tab on the right side. This is where a lot of people get confused. Before formatting it, click options in the bottom. From the options menu click "GUID Partition Table". This is needed in order to boot an x86 mac computer. I would start off with 1 partition for now and add one later. Name it if you want and click Partition.


Step 3 - Verify the format

Once formatting and partitioning has completed you want to verify your format. With your drive selected click the info button on the top. Make sure your Partition Scheme is FDisk_partition_scheme. If it isn't you may want to reformat your drive in step 2.


Step 4 - Reboot into osx86 and clone

Many people have suggested SuperDuper! and CCC. I had trouble with both of these and found that Apple's own Restore works the best. Once you are back into your normal osx86 install launch /Applications/Utilities/Disk Utility.Once you are in click the Restore tab. Drag your original OSx86 partition (not drive) onto the Source text field. Then drag your new drive partition onto Destination. Click Restore. Do some more pushups and situps or go run. Or solve for pi.


Step 5 - Disable old drive and boot up

Soon as restoring has finished you want to Shut Down and unplug the original OSx86 installation completely. This will make for solving your new OSx86 booting problems easier. 9 times out of 10 the Partition Scheme is wrong and the drive can't boot. Most choose the wrong type.


Step 6 - Cross your fingers

If all went perfect you will get 1 of 3 results.

A) It booted into OSx86

:( You received an error "b0 error"

C) You are staring at a blinking cursor and that is it


If A) happened... good job, all is done.

If B) happened... we can solve that with the next step

If C) happened... you may have missed a step on partitioning your drive correctly, try again


Step 7 - Solve that nasty b0 error

A b0 error usually means Darwing Loader can't find the active partition to load. In order to solve this you must make your newly partition active! Rammjet wrote a cool little tutorial on how to do it. I suggest you follow his steps:


By Rammjet


There is a built-in Unix utility in MacOSX that can be used to set your partition "Active". It is called Fdisk



Setting Your Partition "Active" Using Fdisk


Words in bold below are things you must type (followed by Enter).


1. Boot your Mac OS X install dvd

2. Once the installer is running, go to the Utilities menu and open Terminal


3. Determine which disk your MacOSX partition is on

diskutil list


Verify which disk number holds your partition (disk
, disk
, etc.)


4. Start using Fdisk

Assuming the MacOSX disk is the first disk ("disk0"), then

fdisk -e /dev/rdisk0
<== use "rdisk" with your disk number here !!


Ignore the error "fdisk: could not open MBR file ..."


5. Determine which partition for MacOSX needs to be set "Active"



Verify which partition is for MacOSX (1, 2, 3, etc.)


6. Set the partition "Active"

Assuming it is partition 1, then

f 1
<== use your partition number here !!


7. Save and exit



(yes you are sure)


(to quit)


8. Remove the install DVD and reboot


I hope this helps anyone. Feel free to share your questions and comments. I'll update this if anyone has anything they think I should point out.

Link to comment
Share on other sites

I found a very easy to use application that is free that clones my OSX86 drive very well. In fact I use it to backup my system, before I do any sort of major changes. It is "clone tool hatchery h1" I googled it to find it....

....it is a simple point and click application

Link to comment
Share on other sites

  • 1 month later...
  • 5 months later...

Hi Emig647:


Thanks for the instructions! I followed the instructions and now I'm booting up from the External Backup Drive on my Dell Inspiron 1300.


I tried using Hatchery, but it did not work for some reason (maybe because I'm using 10.4.6).


This is great to be able to boot to External Drives!


--danyel :)

Link to comment
Share on other sites

  • 2 months later...
  • 3 months later...
  • 4 weeks later...

what about if I have on the Hard drive (SATA) 2 partitions, and one partition is with Win xp, and I want to move the Os X to the second Partition. (the osx is in another IDE HD). then I can't erase in the diskutility all the my SATA HD, beacuse I'll be erasing my win xp... all I can do is erase the empty partition...

any suggestion?



Link to comment
Share on other sites

  • 4 weeks later...

Please note, I managed to completely mess up and lose one of my hackintosh systems when playing with the Hatchery H1 tool as I don't think it supports Leopard (the pFrame file can kill your disk!!!)


see here where it says "TIGER users only, NOT FOR OSx86 LEOPARD USERS)" ... http://nicemac.com/index.php?topic=323.0


Anyhow I think there might be a nicer way to do this from a few tools on a USB pendrive and the retail disk -



Good luck folks :angel: and don't forget to post your success stories and latest clone/restore instructions ...

Link to comment
Share on other sites

  • 1 year later...

Excellent guide, Yes cloning a MacOS boot drive is just that easy with DiskUtil.

It obviates that sometimes the single partion won't have an active flag with only OSxx86 bioses would care about.


However people running Chameleon may want to also:


dd if=chamelion_boot_image of=/dev/rdisk(ID of your new harddrive)


as drive geometry changes and that boot sector may not be available in the same identical place.


Same procedure can have an extra step for those with Laptops and a single drive:



1. Boot into OS-X from DVD (Retail or Otherwise)


2. Attache a firewire/usb2.0 drive to the system


3. Create a "read-write" uncompressed, unecrypted, non password protected .DMG file of the entire drive as specified in the guide above With the target your usb or firewire drive.


3. Place chameleion boot install files on same firewire drive.


4. Replace/Swap you laptop drive with a even a differently sized alternative. (like upgrading from 250GB to 500GB or SSD)


5. Boot OSX DVD Again, use Disk Util to unpack the .DMG file back onto the new HD (yes it will use all the new space)


6. Re install the boot sector loaded for Chameleon via Utilities -> Terminal from the OSX Install DVD.

(same place you find DiskUtil)


7. Reboot and Enjoy.

Link to comment
Share on other sites

  • 3 months later...

Hi, I'm having difficulty successfully cloning my drive. The system I am on is a Dell Inspiron Mini 10V. I have already installed OS X (10.5.6) on the netbook but I'm trying to upgrade from 80GB to 160GB, which is my reason for cloning the hard drive.


I have followed the guide but instead of using a CD to boot into, I am using the current OS that is installed on the 80GB internal HDD instead, to access Disk Utility and Terminal to perform the relevant operations.


Here is what I did:


- (Step 2) Put the 160GB HDD in a USB enclosure and formatted a GUID partition for the whole HDD.


- (Step 3) Whilst having the 160GB HDD selected in Disk Utility, I clicked on 'Verify Disk', which then said that

everything was OK. I then observed that the partition scheme was correct.


- (Step 4) I then clicked on the 160GB HDD and clicked the restore tab. The source selected was the partition on the

80GB HDD in my netbook, and the destination was the newly created partition on the 160GB HDD.


At this point I removed the internal 80GB HDD, and replaced it with the 160GB HDD. I observed that it would not boot, and it was trying to perform a network boot.


With the disk unable to boot, I then decided to follow Rammjet's guide to set the partition active.


- I put the original 80GB HDD back into the netbook and booted up and opened Terminal.


- I then executed 'diskutil list' and observed that it was disk1 that contained the 160GB partition.


- I executed 'fdisk -e /dev/rdisk1'


- I typed 'p' and pressed enter.


- I observed where the partition was, which was listed as the first one, and typed 'f 1'


- I typed 'p' again and observed that partition #1 now had an asterisk next to it.


- I then executed 'write'


- I confirmed the prompt and typed 'y' and pressed enter.


- I then exited and closed Terminal.


Once I did all the above steps I observed that the network boot screen was no longer bothering me, but the grey Apple logo with the white background appeared. There was a little cog animation underneath and I heard disk activity for about a few minutes, then it went silent. The grey Apple logo and the cog animation was still present. I left it for about 15 minutes and yet still not booting to the desktop.


I would really appreciate if someone could explain what I've done wrong or provide assistance!


Also, would it matter if I used my OS X installation on the 80GB HDD instead of the boot CD?


Thanks in advance!

Link to comment
Share on other sites

  • 4 months later...

I started off with a 400gb SATAII 8mb cache seagate. It is a VERY loud drive in my case. Every read and write was annoying me. So I bought a Western Digital 500gb 16mb cache to clone to. I've done this 5 times. It gets easier each time, but there are a lot of steps involved, and missing one can mess you up.





Link to comment
Share on other sites


  • Create New...