Jump to content

Monterey 12.4, intel C612, e5-2620 v3, Asus Z10PA-U8 server mainboard on board intel I210 ethernet working! AMD R7 240 GPU no sound and freezing screen when windows are minimized.


20 posts in this topic

Recommended Posts

Hi

i have installed Monterey 12.4 to intel c612  chipset, Asus Z10PA-U8 server mainboard and cpu e5-2620 v3, my gpu is Asus AMD R7 240 4GB.

 

Status of system

1 - now ethernet is working without problem, only thing i did changed bios settings of Network stack as enabled and I used AppleIGB (https://github.com/Shaneee/AppleIGB) and set boot parameter e1000=0 and then it automatically see ethernet and gets ip from dHCP without problem.

2- AMD R7 240 4GB GPU is working as Spoofed ID, I tested several devices IDs and some of them problematic some of them less problematic.

  first of all screen resolution is working as 1080p without problem

secondly when you want to minimize safari window , it starts minimization animation and stops screen responsive and try to animate.

it think main problem is related to no hardware acceleration.

Thirdly, I do not have sound.

Finally , I don't have second monitor display, it is connected to monitor with dvi to HDMI converter but there is no any sign of display.

 

now I am sending my IOREG and EFI folder .

 

I am looking for solution to fix Metal support and hardware acceleration for AMD R7 240 GPU , sound output and dual display output.

I will upload files with different posts. because system is not letting me do.

 

 

 

ASUS_Z10PA-U8-Monterey-EFI.zip.001

these are other files.

ASUS_Z10PA-U8-Monterey-EFI.zip.002 asus-z10pa-u8.ioreg.zip

forgot to say I used NvME SSD as Hard Disk. there is no problem about that.

Link to comment
Share on other sites

I think voodoohda is not working. dpcimanager shows NO kext loaded for audio. if I use AppleALC it shows kext loaded. you may see previous screenshoots. last one.

 

any suggestion to investigate to cause?

 

in addition this, I am using other Device ids , 0x6801 is good and I noticed one thing, with this id, when I mounted EFI partition , on finder EFI partition icon is like better icon similar to server icon not sure now. but if I use others like 0x682b , I see the Icon like paper. I uploaded screenshot.

Screen Shot 2022-06-23 at 09.55.17.png

Screen Shot 2022-06-23 at 10.01.48.png

Link to comment
Share on other sites

3 hours ago, nexusblue said:

This motherboard does not have onboard audio chip. I need to use HDMI audio to get sound.

Then the sound issue is solved: No ALC audio codec = no use for AppleALC or VoodooHDA.

 

If the GPU requires spoofing to work, its ports may not be properly recognised and would require manual mapping.

Or you could try a more recent GPU, with native support in Monterey (and no spoofing).

 

Nice work!

Link to comment
Share on other sites

@etorix thank you for you comment but there are issues. 

First i am spoofing GPU as 0x6800 or other pitcarin versions to get more reliable gpu performance. but i cant get hardware acceleration and QE/CI and metal.

because of this, some animations are not working. for example,to minimize the safari window or finder window, MacOS start to do animation but it freezes the screen sometimes i cant move mouse or some device ids i can move mouse but screen icons are not responsive. because of that i am looking for solution. i believe that this card will work.

and HDMI audio also needs to work! AppleALC get loaded and show ATI6xx Driver but i cant not get audio. i changed layout id several times , suprisingly normally there is no sound but now there is noise when i am shutdown the computer.

 

@etorix how can i  manual mapping the GPUs ports?

i couldnt find right document. and how can i achieve qe/CI hardware acceleration on?

 

now i am trying to install high sierra for this hardware on another hard drive but i could not pass to virtualsmc error and pci begin end error :)

 

if you can give me , right documentation about my issues , i will be happy because i cant troubleshot this.

 

Link to comment
Share on other sites

Good and fair requests… Unfortunately I have no satisfactory answer.

For hardware acceleration, my guess is that R7 240 is just too old.

 

There is a detailed resource to map display connectors… from iGPU

https://dortania.github.io/OpenCore-Post-Install/gpu-patching/intel-patching/#terminology

For dGPUs, it is much more limited (I guess you know it already):

https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.Radeon.en.md

Quote

When and how should I use custom connectors?
In general automatic controller detection written in Apple kexts creates perfect connectors from your VBIOS. The logic of that can be found in reference.cpp. However, some GPU makers physically create different connectors but leave the VBIOS unchanged. This results in invalid connectors that are incompatible with your GPU. The proper way to fix the issues is to correct the data in VBIOS, however, just providing custom connectors can be easier.
For some GPUs (e.g. 290, 290X and probably some others) WhateverGreen incorporates automatic connector correction that can be enabled via -raddvi boot argument. For other GPUs you may specify them as a GPU device property called connectors, for example, via SSDT. You could pass your connectors in either 24-byte or 16-byte format, they will be automatically adapted to the running system. If you need to provide more or less connectors than it is detected automatically, you are to specify connector-count property as well. Please note that automatically detected connectors appear in the debug log to give you a good start.

From IOReg, the three framebuffers look normal. Do you have working output from all connectors?

 

The HDMI audio entry also looks fine: HDAU, with the added properties. The alcid parameter should not matter because it defines the physical layout for actual audio codec chips on the motherboard.

Quote

How do I get HDMI audio to work?
In general it should be enough to rely on AppleALC automatic HDAU correction. It renames the device to HDAU, and injects missing layout-id and hda-gfx (starting with onboard-1) properties. This will not work well with two or more cards of different vendors (e.g. NVIDIA and ATI/AMD), please manually inject the properties in such a case. You may also use -radnoaudio boot argument or no-audio-autofix GPU controller property to explicitly disable any audio-related property changes.
For identifiers not present in AppleHDAController and AppleHDA you have to add necessary kext patches, see AppleALC example for 290X.

But I don't know how to adapt the R9 290X patches to your R7 240.

Link to comment
Share on other sites

thank you for reply. yes i looked these documents and i couldnt find the answer correctly because there is not on board codec for my mainboard but i saw a post about there is a person who says changing alcid is helping hdmi dvi and sound output. i think it is somehow effecting about working condition. even i changed alcid like 69 , when shutingdown computer it creates noises. it thin there is a connection between AppleALC and AppleHDA , i wonder that is there any model that there is no on board audio codec but only using DGPU as main audio codec in mac models.

even if there is none mac model. there must be the way for it. because if i change the GPU , how can i be sure about to get audio work done?

for example getting AMD RX6600 XT,can it be able to get audio done? 

I may try  spoof R9 290X  device ids. but to note there, for this card, only pitcarin devices are better at performance.

but not perfect.i have still problem about freezing and no QE/CI and metal support , and it means no hardware acceleration.

Edited by nexusblue
Link to comment
Share on other sites

If you want an audio with Radeon HMDI then you have to disable both VoodooHDA and AppleHDA. 

In this case AppleGFXHDA.kext will be activated and works without additional patches and tunings except probable faking device-id to compatible one.

  • Like 1
Link to comment
Share on other sites

7 minutes ago, nexusblue said:

@Slicethank you i will try. but big problem is GPU has no hardware acceleration, if you can give any advice for it. i will be happy.

You mean R7 240? It is the problem. Look here ATI Oland family cards 
May be you should install something like HighSierra if you want this card to be working.

Link to comment
Share on other sites

47 minutes ago, nexusblue said:

OK you may help with clover, you can give information about this motherboard Clover EFI. i forgot how to do :)

if you can give your advices about kext and patches for high sierra i can try with CLover latest version.

See a success in High Sierra

 

You may repeat his result.

Link to comment
Share on other sites

I have tried clover but i couldnt see boot picker screen. only black screen.

nothing shows.

 

I tried opencore , for mojave and high sierra. i found out there is a problem about nvram and revised nvram section of opencore but in this case, installer gives error like installar couldnt copy files to target volume etc.

after this messages , i am looking to disk utility from installer. there is no internal hard drive, it seems lost.

and i reset the machine but not able to see hard drive in bios. i need to unplug hdd and plug again after that bios sees it.

 

there is only one problem, all installers mojave, high sierra, big sur, monterey have common problem. hard drive lost during installation.

even i tried for high sierra and mojave, ahciinjector.kext and Xhci_unsupported.kext , i also added one of my ahci device id to ahciinjector.kext.

both device id were set, sSata and SATA.

hard drive was on SATA port but no success, installer try to copy files and hdd is lost.

how can i log this problem i dont know.

i also installed monterey on hard drive as external drive on another mac. i put this drive, it works with GT 710 nvidia.

but it stops sometimes and i see the same problem. hard drive lost and monterey freezes.

 

Than you again all of you for your time and help. @Allan @etorix @Slice

  • Like 1
Link to comment
Share on other sites

The drives not showing actually has a very simple cause: UEFI>APFS>MinDate,MinVersion are set to 0, which actually prevents loading APFS drivers older than 2021.

Set both values to "-1" and the drives should appear.

 

Sorry that it took me sol long to realise it! 🤦‍♂️

Link to comment
Share on other sites

 Share

×
×
  • Create New...