Jump to content

macOS Monterey bcm943602cs Bluetooth not working


16 posts in this topic

Recommended Posts

14 minutes ago, Rocky12 said:

I have no idea how to make this working

 

Have you tried the BlueTool.kext? Must use without any other BlueToothInjectors in the kext Folder.

  • Like 1

Some hardware info this, a genuine Apple Card I am using in my pc with PCIe Adapter

 

thanks buddy, I will give this a try

Screenshot 2021-07-17 at 17.28.07.png

All this information I got from BS, not from Monterey Because under Monterey the Card doesn't load the Firmware

52 minutes ago, Rocky12 said:

All this information I got from BS, not from Monterey Because under Monterey the Card doesn't load the Firmware

Yea I had the same problem with the same card under Monterey but unfortunately thinking the card went bad, I messed around with it and had a slight mishap and completely destroyed it. At the moment I'm using a Fenvi T-919 (Yea I know, some people won't go near this card) but I can say I was pleasantly surprised with the performance. Recognized instantly by Monterey, plus available Drivers for Windows so an all rounder for me. Update - I ordered and received another genuine Apple Card but will keep it aside in reserve or for another build.

Edited by eSaF
  • Like 1
Posted (edited)

I really appreciate your help, you guys are really awesome thanks for the quick response

I did the method with these three kexts no luck

Bluetooth's firmware still not loaded with all these kext or only BluetoothFixup kext no luck

  • BlueToolFixup.kext
  • BrcmFirmwareData.kext
  • BrcmPatchRAM3.kext

Screenshot 2021-07-17 at 18.00.14.png

Screenshot 2021-07-17 at 23.03.04.png

35 minutes ago, MorenoAv said:

Hi @5T33Z0, do you have BrcmPatchRAM3.kext ?

Thanks

BrcmPatchRAM3.kext.zip

Edited by Rocky12
  • Thanks 1

Tried with the kexts, and it didn't work, thanks for the kext and good luck...

 

Yeah I'm in the same boat, I think we have to wait for someone to find an solution...

For the time being I removed my adapter and right now I'm using the Intel WiFi and no bluetooth... 

  • Like 1

@Rocky12 & @MorenoAv - Guys I am neither an agent or shareholder for this product but this card got me out of the spot you're experiencing, fitted and recognized immediately by Monterey both B/T and WIFI functions working instantly without injectors also drivers available for Windows if dual booting. I know it has a bad rep in some quarters but it has been reported there are some Clones of this card in the wild and the performance of these cards are somewhat flaky. This is the  unit I bought (attached) and the performance is flawless both in Windows and OS X.

Screen Shot 2021-07-19 at 09.28.33.png

Screen Shot 2021-07-19 at 09.39.30.png

  • Like 1
  • Thanks 2
Thank you so much, all of you guy's very positive response one thing what I want to ask for if you can trace the Bluetooth firmware on Monterey
  • 2 weeks later...

Hello @chris1111, I have one Azurewave4360+20702 Combo [0b05:180a] in my Asus X99 Deluxe, i use BlueToolFixup.kext together with BrcmFirmwareData.kext and BrcmPatchRAM3.kext from the latest release, it works as it should (bt works, firmware loads fine, handoff), the only issue I have is if I turn off bluetooth I can't turn it back on untill I restart the hack. This is what I see in the console when I try to turn bluetooth back on. 

 

error    19:29:39.645868+0300    BlueTool    Could not find btaddress param
fault    19:29:39.647471+0300    bluetoothd    Unknown chipset 0
error    19:29:39.647622+0300    bluetoothd    Failed to register the vendor callback with result 101
error    19:29:39.647640+0300    bluetoothd    Core Stack initialization failed!
error    19:29:39.647667+0300    bluetoothd    Stack startup failed - 110
error    19:29:39.648113+0300    BlueTool    Could not find btaddress param
error    19:29:39.651916+0300    bluetoothd    Mac Cache Migrator Received PowerStateChanged

 

Thank you for your time !
 

  • Like 1

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...