Jump to content
5 posts in this topic

Recommended Posts

Hi! Recently,  I set up a hackintosh on my Acer Aspire V3-571G, here is its config:

i5-3210M, 2.5Ghz

8GB DDR3 RAM

HD4000 + GT630M (disabled because it’s Nvidia Optimus)

BCM57785 Gigabit Ethernet card + AR9462 Wi-Fi+BT combo Mini-PCIe card

 

I installed Big Sur 11.0.1 (planning to upgrade to 11.2.3 after I get everything to work) using OpenCore Release 0.6.7 and got almost everything working, but I hve problems with both wired and wireless adapters:


For Ethernet, I tried FakePCIID.kext and FakePCIID_BCM57XX_as_BCM57765.kext (both of them added to OC/Kexts and added to config.plist), but it seems to have no effect: it doesn’t show up in DPCIManager at all. I was using such method before on this machine on 10.15.7 using Clover (installed the kexts to S/L/E and it worked), but I can’t get it to work with Big Sur using OC injection). I then tried to use BCM5772D.kext and it partially worked: I could see the card in DPCIManager and could even add a device in Settings - Network, but it can’t get the IP from my router: it just tries to obtain the IP and then states “Self-assigned IP”. I also tried manually specifying the IP, subnet mask and router, it says “Connected”, but still no Internet access.

 

As for AR9462: I tried using this one:

 

(I injected both HS80211 and AirportAtheros40 via OC), and it seemed to work, I even connected to the Internet using my 2.4ghz wifi (router is Mikrotik RB941-2nD which doesn’t support 5ghz, unfortunately), but there is another problem: if I start using the network actively (for example, download something or just actively browse the web) it drops out the connection. For the first time, it would disconnect from my wifi and I could reconnect, but the next time the wifi module seems to shut off completely as it doesn’t even look for wifi networks, and only reboot helps. I also tried ATH9KFixup in pair with AirportAtheros40, but the wifi card was not even in DPCIManager.

 

Both network cards work in Windows just fine.

 

I’ll attach my config and kext list later today. Do you have any ideas on fixing these problems? Thanks.

 

Edited by Andreyhg
2 hours ago, Slice said:

Hi, Slice! Thank you for your help. I tried the ready-to-use kext you attached, but still no success. If I set IP to be obtained using DHCP, I get "Self-assigned IP" and a yellow dot and, therefore, no Internet. If I set all the values manually, I get the green dot and "Connected" status, but executing ping 192.168.88.1 (which is my router) gives me:
 

Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3

and so on, and sometimes "No route to host" errors. I also tried applying the patch for BCM57785 in OC's config.plist -> Kernel -> Patch (while keeping FakePCIID disabled and BCM5722D enabled), but with no luck.

Here are my config (I removed all the serials and UUID on purpose for obvious security reasons) and two ioreg dumps, with manual IP set and with DHCP Auto, which gives me self assigned IP. Could you please take a look?
 

config.plist BCM57785 - manual IP.zip BCM57785 - selfassignedip.zip

Update: booted my Catalina partition from the same EFI, and Ethernet is still not working with the same set of issues. So there may be something wrong with the kext attached.

Update 2: booted Catalina with BCM5722D disabled and FakePCIID and FakePCIID_BCM57XX_as_BCM57765 enabled, and ethernet worked just fine. BCM5722D doesn't work on Catalina either. I executed 

kextstat | grep -E "FakePCIID"

in Terminal in Big Sur, and figured out that only FakePCIID.kext is loaded, while FakePCIID_BCM57XX_as_BCM57765.kext is not. I also tried adding FakePCIID_BCM57XX_as_BCM57765.kext to Kernel -> Force section of OC's config, but it didn't change anything. Any suggestions?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...