Jump to content

HELP !!! Catalina Install on HP Zbook 14u G6


112 posts in this topic

Recommended Posts

I have been trying to install Catalina on my zbook for a month now and nothing works.

Im new to hackintoshing, I have followed every guide I can find to do this install on both clover and OC but every guide I follow the install ends up with kernel panics and stops loading.

the laptop I'm trying to Hackintosh is an

HP Zbook 14u G6 with an i5-8365u processor ,

HD 620 Graphics

500gb nvme m.2 ssd 

the bios on the hp is R70 Ver. 01.06.00 08/03/2020

 

PLEASE HELP !!

My suggestion is to stick with one guide/method, and try to work through the errors or ask for help with those. Going back and forth between different methods tends to waste a lot of time and ultimately end up in frustration I've found.

 

My personal recommendation is to go through the Dortania guides and use OpenCore - but whichever guide or bootloader you use is up to you. Looking at your device, there shouldn't really be that many surprises so it should go together fairly easily.

I've followed the Dortania guide several times and for what ever reason its not working. I don't know enough about what's going on to figure out what I'm doing wrong.

also don't know what the errors are or how to " work through them". 

 

any ideas would be greatly appreciated , or if anyone els has hacked this machine and could share how they did it would be greatly helpful 

Welcome, and thanks for having explained what you want to do in your title rather than just calling for "help".

But to give any meaningful help it is necessary to know what the kernel panic is (fully readable debug messages) and what you've done (EFI folder, or at least the config.plist—with serial numbers redacted out, per forum rules).

 

As it stands, I second 1Revenger1: Work carefully through Dortania's guide for a minimal setting for your hardware. Refer to Troubleshooting to work issues out. Be methodic when trying alternative settings.

Have you set the Lapic quirk which HP reportedly requires?

Ive attached my Config.plist, and pictures of my drivers, ACPI and kexts folders . if someone could take a look at it and see if you notice a mistake I've made in regards to this laptop I would really appreciate it.

ive also attached a couple screen shots of the kernel panics.  

IMG_7028.JPG

IMG_7028.JPG

IMG_7029.JPG

config.plist

I believe you have 2 many things in your config, trim it down and slowly add one thing at a time once you're up and running.

Look for NVMEFix.kext to add it and hopefully it will work.

The KP could also be dGPU related, turn it off

you shouldn't have to fake PCI id's, that could also cause trouble.

 

I've trimmed down your config and it should boot. just add the NVMEFIX in case you get another KP.

 

 

config.plist

I added the NVMe kext that you wanted me to add then I replace the config with your new config , the picture below is what I got when I tried to boot using OC.

IMG_7036.JPG

Im so frustrated with this machine at this point that I wish I could pay someone to build me a working boot drive for this machine.  $100 to who ever builds me an entire EFI Folder specifically for this machine  that works ! 

 

That would be difficult without having the same ZBook…

You have indeed way too many things in your EFI folder. There should only be two drivers, Hfsplus.efi and OpenRuntime.efi, and four kexts, Lilu, VirtualSMC, WhateverGreen and possibly AppleALC. Use a USB mouse and try booting with a minimal EFI folder. The trackpad may come once you have succeeded to boot.

 

I use Toshiba/Kioxia XG5 or XG6 M.2 SSDs on all my hacks.

You boot with clover, on the picker screen press F4, you can confirm that it is saving the ACPI tables (DSDT and SSDT's) because it stops responding for a couple seconds.

The files will be in the EFI->ACPI->Origin

 

You will need to become a google ninja to be able to properly hackintosh your ZBook, Laptops are hard and if nobody has one, they're harder, I'll help, but you need to read and learn as much as you can also.

sorry for the late reply, I was out of town and its been a busy week.

 

 

the specs of the machine are HP Zbook 14u G6 with an I5-8356U processor with UHD620 graphics .

her are the files you asked for. ive also included the install log incase that helps. 

 

Also, thank you so very much for trying to help me. This has been driving me crazy and I cant tell you how much I appreciate the help ! 

DumpLog.txt

DSDT.aml SSDT-1-ShmTable.aml SSDT-0-NVTEC.aml RSDT.aml SSDT-2-CpuSsdt.aml SSDT-3-CtdpB.aml SSDT-4-PLT_RTD3.aml SSDT-5-UcsiAcpi.aml SSDT-6-UcsiCntr.aml SSDT-7-PtidDevc.aml SSDT-8-HP_XHC_P.aml SSDT-9-DptfTabl.aml SSDT-10-SaSsdt.aml SSDT-11-HPTBT.aml SSDT-12-HPINWWAN.aml SSDT-13-HPNBCONV.aml SSDT-14-INTTPL.aml SSDT-15-HPINNBWL.aml SSDT-16-HPCONDEV.aml SSDT-17-HPSANIMD.aml SSDT-18-HPCAHWID.aml SSDT-19-PwrCtlEv.aml SSDT-x2_0-Cpu0Ist.aml SSDT-x2_1-ApIst.aml SSDT-x2_2-Cpu0Cst.aml SSDT-x2_3-ApCst.aml SSDT-x2_4-Cpu0Hwp.aml SSDT-x2_5-ApHwp.aml SSDT-x2_6-HwpLvt.aml SSDT-x2_7-Cpu0Psd.aml SSDT-x2_8-ApPsd.aml Clover_Install_Log.txt

Also, there was a DSDT and a bunch of SSDT's in the "Patched" folder, do you want those as well ?

This EFI should get you going.

It seems you have an ELAN trackpad so I added the kext, I couldn't determine if you have another GPU, and battery patches seem to be the same as with my G5, so you may be lucky.

I'm not sure MacBookPro15,1 is the best fit, but you can try different ones.

You'll need to map your USB ports, follow the Hackintool guide.

You'll need to add your Serial/MLB/UID Numbers.

If you still get Kernel Panics at boot, it's probably your NVME drive.

 

Good luck and let us know if it works

 

 

EFI.zip

I'm confused, the EFI he gave me is in OC not clover.

Also, I loaded the refi folder onto the install drive and fired it up and this is what I got ( picture attached)  I don't recognize it / know what to do here.IMG_7054.thumb.JPG.a3391c9d1d1e15526f2b67e3d84e81aa.JPG

what about the picture I just posted ? when it boots off the usb stick there is no option to install ozx , just the options in the picture and I don't recognize any of them.

 

You need to create install media as per dortania opencore guide.

Once your install media is done, you replace the EFI folder in the install drive with the one I posted above

(With the serial number mods)

 

Right now the OpenCore bootloader from the files above can't find the install drive, so it only shows the tools, (you must have pressed escape or space)

×
×
  • Create New...