Jump to content

[BCM94360NG] Strange behaviour in macOS - Speed problems


14 posts in this topic

Recommended Posts

Hi!

I changed my BCM94352Z to BCM94360NG (from fenvi) in my Lenovo X1 Carbon 6th because it's OOB, and I wanted to put the BCM94352Z to another notebook replacing Intel WiFi. 

So everything is okay, not lagging, not crashing, but there is a very strange behaviour on macOS and I don't really know what is causing that. Speed/rate was okay with BCM94352Z.

 

The problem:

1. If I boot to macOS from a cold start, or from a normal shutdown/start, the rate is always capped at 434 Mbit/s no matter what. Also the download speed is capped at 25-30 MB/s (should be ~60 MB/s)

 

1137644367_Kpernyfot2021-01-22-11_25_34.png.b4f69432b25898c1e098a3cf3c931f8c.png 1063271302_Kpernyfot2021-01-22-11_25_23.png.cf169475cc230dbd86a4eba151f47c02.png

As you can see, the speed is slow, rate is not 866 Mbit/s

 

 

 

2. On Windows, everything is okay, the rate is 866 Mbit/s, speed is also okay (~45 MB/s, not as good as on macOS, but it's okay).

 

866win.PNG.cf14d6f4faefa1fe5588e20f0ceb0b4b.PNG

Speed/rate on Windows is okay

 

3. So here is the interesting part: If I reboot from Windows (not shutdown and start but reboot) to macOS, the rate is okay, 866 Mbit/s, and the speed is ~60 MB/s. Still good after sleep, breaks after a shutdown.

 

1061714981_Kpernyfot2021-01-22-11_30_09.png.3d45b9cadabc3a6fad045b9c1bf83636.png 1966641297_Kpernyfot2021-01-22-11_30_45.png.30c7535f89b961fe55aff18478fa7c25.png

Speed/rate are okay after restarting from Windows

 

I really don't know what is causing this.

System specs are in my signature (Notebook 1).

 

Tried things:

- With AirportBrcmFixup.kext (without 4360_injector)

- With AirportBrcmFixup.kext (without plugins)

- Without AirportBrcmFixup.kext

- With AirportBrcmFixup.kext and "brcmfx-country=HU" or "US" bootarg

- With AirportBrcmFixup.kext and "-brcmfx-alldrv" bootarg

 

All of the above tried with both OpenCore 0.6.5 and Clover v5128 = Same behaviour.

 

I don't know if it'll help or not, but the router is an ASUS RT-AC66U (AC 1750) with original fw, 5 GHz settings: mode: 80 MHz, channel: 44

I'm in the same room with the router, it's on the top of a large cabinet, the wifi is covering the whole house (the notebook is ~3 metres away).

My other devices connecting with 866 Rx /866 Tx rate

 

I collected a verbose log:

bootlog.log

 

 

Very strange...

 

Thanks in advance!

 

Edited by kushwavez

Check your Box/Wireless Router settings and try to change channel to a different range for 5GHz/80MHz like the 1xx ones. Check it out when running windows.

https://en.wikipedia.org/wiki/List_of_WLAN_channels#5_GHz_or_5.9_GHz_(802.11a/h/j/n/ac/ax)

 

Depending on the country in which you reside (Hungary?), it may not be suitable to specify a country code at all. I for one stick to ETSI locale and FR country code in France. Also, you could try without AirportBrcmFixup (which I don't believe you actually need for your card).

 

@Hervé Thanks for your reply. Unfortunately that didn't solve the problem.

I tested with my main router too (RT-AC56U) but the results are the same. 

With or without AirportBrcmFixup, doesn't matter, the results are the same.

In this case, I didn't use AirportBrcmFixup.

 

1. RT-AC66U - Original Up-to-date FW - 80 MHz/channel 36, notebook is 3 metres away

  • Boot Windows from off state: 866 mbit/s rate - ~45 MB/s speed (OK)
  • Boot macOS from off state: 434 mbit/s rate - ~30 MB/s speed (NOT OK)
  • Boot Windows, restarting from macOS: 866 mbit/s rate - ~45 MB/s speed (OK)
  • Boot macOS, restarting from Windows: 866 mbit/s rate - ~60 MB/s speed (OK, PERFECT)

 

2. RT-AC66U - FreshTomato custom FW (2020.8) - 80 MHz/channel 151, notebook 3 metres away

So in this case, the speed was ~25 MB/s either on Windows and macOS, doesn't matter if booted from off state or not. The speed is capped by the FW. I put back the original FW after seeing the results.

 

  • Boot Windows from off state: 866 mbit/s rate - ~25 MB/s speed
  • Boot macOS from off state: 434 mbit/s rate - speed ~25 MB/s
  • Boot Windows, restarting from macOS: 866 mbit/s rate - ~25 MB/s speed
  • Boot macOS, restarting from Windows: 866 mbit/s rate - speed ~25 MB/s

 

3. RT-AC56U - DD-WRT FW v3.0-r44772 std (11/11/20) - 80 MHz/channel 112, notebook 1 metres away

  • Boot Windows from off state: 702 mbit/s rate - ~45 MB/s speed (OK)
  • Boot macOS from off state: 434 mbit/s rate - ~30 MB/s speed (NOT OK)
  • Boot Windows, restarting from macOS: 702 mbit/s rate - ~45 MB/s speed (OK)
  • Boot macOS, restarting from Windows: 702 mbit/s rate - ~60 MB/s speed (OK, PERFECT)

1267329039_Kpernyfot2021-01-23-12_32_46.png.4864ffd4dd6b427db663a03ea5e0cde9.png

 

 

I don't think that the card is defected, but I don't really understand why it is working after a restart from Windows...

 

Oh and I tested with another notebook too: Lenovo ThinkPad T440. The results are same... 434 mbit/s if I boot macOS from off state.

Same with Clover and OpenCore.

 

Then I tested again with the BCM94352Z: boot macOS from off state: 866 mbit/s rate - ~50 MB/s speed (OK), same on Windows.

Edited by kushwavez

'beats me. I too have one of those Fenvi BCM94360NG (because Bluetooth works faultless) but I found its wireless performance to be a little inferior to my DW1820A so I put it aside and kept using the DW1820A cards. But I can't say I've experienced anything like what you described.

Hmm..

It's not a big deal for me to restart from Windows to get it working, but sure it's a little bit annoying. Well, I'll make a script to do that automatically and will use this card for a while... I'll also try and look into a bit deeper about what the hell is going on with that.

If that won't work out, then I'll change back to the BCM94352Z... -10 MB/s, but that's not the end of the world. The only 'major' issue is that iPhone Instant Hotspot isn't working with that card.

 

Anyway thanks @Hervé!

 

One question: My notebook have 2 antenna connectors for wifi (1 main, 1 aux). Can I install a 3 antenna type card (for ex. BCM943602BAED) and leave one connector unconnected? Or do I need to install one more antenna wire?

Edited by kushwavez
  • 1 month later...

It's installed by Windows Update.

Driver date: 2015. 07. 20.

Version: 7.35.295.2

 

Someone here on Insanelymac posted a bootcamp driver zip for BCM94360CD, that is also working with this card

 

I also reported this to the Acidanthera team, hopefully they'll add a patch for this.

https://github.com/acidanthera/bugtracker/issues/1532

 

EDIT: They closed the issue, safe to say that there won't be any patches/fixes.

Really unfortunate... I really thought this card will be awesome when I bought. Next I'll buy an original Airport BCM94360CS2 with an NGFF adapter. That is the best.

Edited by kushwavez

I've tried a Bootcamp driver an a driver from Windows update, the Windows driver is from 2016 and the speed is only 400 MBit/s. Can you please upload the driver you're using? Maybe I find a difference.

I wonder if no one else noticed this issue, or do we have faulty cards?

 

Spoiler

wifi-inf.PNG

 

 

Spoiler

wifi.PNG

 

Edited by wern apfel

@wern apfel You can download it here: https://www.catalog.update.microsoft.com/Search.aspx?q=broadcom+802.11n+network+adapter

version: 7.35.295.2

 

Others also experienced this issue: https://github.com/acidanthera/bugtracker/issues/1532

 

Looks like this card was a mistake... I'll buy an original Apple BCM94360CS2

On 3/3/2021 at 6:57 PM, kushwavez said:

Thanks, the speed goes up to 866 even after sleep. Let's se what I can find out.

On 3/3/2021 at 6:57 PM, kushwavez said:

@wern apfel Looks like this card was a mistake... I'll buy an original Apple BCM94360CS2

I own such a card, WIFI works perfect but the Bluetooth range is low.

1 hour ago, wern apfel said:

Thanks, the speed goes up to 866 even after sleep. Let's se what I can find out.

So it seems it's completely a driver issue after all... 

 

1 hour ago, wern apfel said:

I own such a card, WIFI works perfect but the Bluetooth range is low.

Yeah? Could you please give an approximate in meters for example?

 

If THAT is not working then... I have to install a 3rd antenna into my notebook and get a BCM94360CS (not CS2, CS is the one with 3 antennas), or a BCM94360BAED (but then Instant Hotspot won't work)

19 hours ago, kushwavez said:

Yeah? Could you please give an approximate in meters for example?

About 1 meter. The Computer on the floor and the Magic Mouse on a glass plate table. I'm not sure if the glass makes a difference, but had some delays when using the Mouse, with the NG card no issues anymore.

×
×
  • Create New...