Jump to content

How to get rid of fake cpuid for ASRock Rack C422 WSI/IPMI with Intel Xeon W-2191B


4 posts in this topic

Recommended Posts

Hi guys in this amazing forum, I need help to get rid of fake cpuid for W-2191B in Opencore.  Both of my Clover and Opencore can boot normally with fake cpuid 0x0506E4 in Clover and Cpuid1Data E4060500 00000000 00000000 00000000 and Cpuid1Mask FFFFFFFF 00000000 00000000 00000000 in Opencore. However once I delete them, My High Sierra (iMac Pro) can't boot and stuck at 'End Randomseed' for both Clover and Opencore. Based on this thread for getting of fake cpuid , I think at least the fake cpuid is unnecessary in Opencore.  I'm really confused that why I need the fake cpuid for Apple natively supported CPU. I attaced my config files, DSDT, and boot log to seek your help.

 
 

 

config.plist

config_with_cpuid.plist

DSDT.dsl

opencore-2020-11-21-152132.txt

Hello @yapan4, I just tried your clover EFI, but my High Sierra was still stuck at 'End Randomseed'.  By the way, the clover also have another issue that the clover menu is frozen for mins and will be restored in a few minis. I tried some versions but the issue is the same.  This issue just makes me wait mins but it doesn't affect the boot to desktop if you put the fake cpuid in config.plist.

Here is an old topic about High Sierra Hackintosh on ASUS WS C422Pro/SE

https://www.insanelymac.com/forum/topic/333229-help-installing-highsierra-on-xeon-w-2175-and-asus-ws-c422-mobo/

and here 

https://www.insanelymac.com/forum/topic/335193-help-installing-mojave-on-xeon-w-2175-and-asus-ws-c422-mobo/

newer. 

Maybe it will help you with your Asrock Motherboard. It's been a long time ago. I have already forgotten everything and do not want to confuse You.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...