Jump to content
85 posts in this topic

Recommended Posts

@dindu5678 I just tried it now but I got what I think was a kernel panic (I wasn't recording it) but well, basically opencore failed to boot into macOS, and right after the verbose text stopped, the screen went black and then the machine went straight into windows.

I also lost my opencore boot option and the usb device is no longer listed in the BIOS after that. I have macOS installed on a external SSD and my Lenovo YOGA S740 14inch laptop has a m.2 ssd with windows 10 installed.

 

I guess at this point I might just wait until @willyboyshy or @Ab2774 post their EFI folder.

PS: If you are on the fence about posting it because of the device serial number, just clean out the SMBios tab in your config.plist and tell us which SMBios you used please!!!

Hi, I'm sorry for the latency, you can use my EFI that is attached below, I tried to get everything working but sleep just can't work, @Austere.J great job you've done!! but there are still some minor issues like boot glitches, in my other laptop with Intel HD 620, the graphics can't get the full acceleration without spoofing as Skylake (ig-platform-id as 00001619 and device-id as 16190000 with lilucpu=8 boot-arg, more information here), otherwise, the graphics will be blurry and weird like these photos, the same goes here, is there's a way to get full acceleration and avoid glitches other than spoofing?

Thanks

 

 

EFI.zip

Well, I tried a couple device/platform ids, boot args and config.plist device setups for the igpu but no matter what I try I always end up with a "unsupported cd clock decimal" error...

I'm using the latest debug versions of Lilu, Opencore and whatevergreen 1.4.2 compiled from users in this thread.

 

Hi, unfortunately, there's no full acceleration without spoofing.

 

in my Kaby Lake laptop, I didn't get rid of boot glitches and annoying blurry backgrounds until I spoofed it as Skylake, it's even mentioned in WhateverGreen's FAQ ("In macOS 10.14 оn some laptops with KBL graphics one may face visual artifacts on the gradients. For a temporary solution try to fake IGPU to use SKL drivers") but spoofing doesn't work here. I tried to only spoof device-id to Coffee-Lake as 923E0000 but it didn't work, waiting for @Austere.J to find us a solution.

 

Cheers 

Can confirm that it works for me. Got my 8A56 spoofed as 8A5A, acceleration, brightness and scaled resolutions working. Fabulous work!

 

Got a few issues still:

- mouse cursor is rendered like some garbage

- laptop does not fully sleep, and display is not waking back, but it is unclear if it's related to the graphics driver at all at this point

 

Also, when first booted with the patch, the brightness has changed to minimal value. Managed to log in, and the brightness slider in the display pref pane was on normal (~70%). Moved the slider - no change. Then suddenly the brightness became normal, and now stays normal even after reboots.

 

Will look into fixing the DVMT via UefiShell or patching the framebuffer next. Thanks again.

Success!! I managed to get graphics acceleration working on my Lenovo YOGA S740 14inch with an i5 1035G1 by utilising snippets of @Ab2774 's EFI as well as resources found in: https://github.com/frozenzero123/YOGA-S740

I made a new EFI which you all can download here: https://files.catbox.moe/vodnnf.zip

PS: I'm running macOS from my portable SSD drive so if you get boot problems when trying to boot from the YOGA's m.2 drive don't quote me, I will install it there later.

PS: the login screen has broken graphics but it does not matter since everything works fine once you finish typing your password.

I just need to properly setup power management...

Thanks everyone in this thread for the patience and help!

I'll be adding this to my Hackintosh EFI archive.

IMG_3011.thumb.jpeg.ed87d0458ce0ac1ac818e6e8468e44b3.jpeg

Edited by LireMei

Apparently, I was too optimistic. Since yesterday evening, it always boots me into a blank (black) screen. The normal verbose mode messages scroll up, then, right at the point where the apple logo should appear, the screen goes blank. It seems that the rest of the boot up process goes on and I could've probably eventually login if only I saw anything) It almost looks as if the display fails to wake up..

Hi, this glitch is very common, the temporary fix for it is to restart by holding the power button, this is the only solution that works, I even downloaded Lilu and added the new Platform-ids and compile it, but the issue still exists, waiting for @Austere.J till he figures something out.

Cheers

Does anyone have a solution for the garbled graphics at the login screen? I know that it's only temporary and becomes normal after a couple seconds. But it still annoys me...

For reference, I'm still using that same EFI that I uploaded here in this thread earlier.

(My i5 1035G1 is being spoofed as a i5 1035G7).

We are still trying to solve it, but there is no progress. Sleep can only be suspected because of the graphics card! As for the garbled graphics at the login screen, there is no good way for the time being, the method of injecting edid is ineffective! But I found that when the external screen is connected to the boot, there is no problem with the screen, which behaves very much like the problem of edid!

Thanks for the tips, Frozenzero! and also thanks for sharing your EFI. 

Now, I know that your YOGA model is the one with an i7 1065G7 right? which should make it easier for you to setup the igpu.

However, I need to point out that I think there's also another difference between our models: if I'm not mistaken, I think your model comes with a 4k display right? mine comes with a 1080p one which is a 6bit + FRC panel which led me to suspect that this was the issue with garbled graphics in the login screen (the FRC causing it) but since others in this thread also had similar issues I don't think so.

 

Here's a dump of all my hardware information I took from Linux: https://files.catbox.moe/8scynn.zip

hello i got hasee kingbook x57s1 (i7 with G7 graphics).

 

i got installed catalina 10.15.6 with the help of latest weg + took some files from that EFI folder - https://github.com/Ardentwheel/OpenCore-Hasee-X57S1 (thx btw)

 

my bios is pretty poor, so i have no options to changed DVMT and so on, so i used boot-args to boot my hackintosh - -igfxcdc and -igfxdvmt. Without that boot-args i can't boot hackintosh. So it's okay, but i got straaange glitch of cursor and i saw same glitch on systems here, but i didn't find the way to fix it. Has anybody fixed that glitch? 

92286875-df1daa80-ef10-11ea-836a-e3bee3e520f4.jpg

  • Allan pinned and featured this topic
×
×
  • Create New...