Jump to content
Sign in to follow this  
Followers 0
kkdart

Intel HD 530 not being detected in Mac OS

3 posts in this topic

Recommended Posts

I would like to learn what patches I would need to do in order for the HD 530 to be properly detected by Mac OS

 

I have dell Optiplex 5040 with Catalina 10.15.6 installed.

i7 6700 (Intel HD 530)

16 GB DDR3L ram

NVME SSD

AMD RX 560

 

Boot & Kext settings:

Open Core 0.6.0

Plist Attached as well.

LILU

WEG

 

I have set 01001219 for iGPU to be in headless mode as well, to no avail.

 

BIOS settings

DVMT cannot be set in BIOS (shouldn't matter as only need Intel Quick Sync to work for Hardware Acceleration)

Intel Multi Display is enabled

Initial display is set Intel Integrated

 

 

 

 

Windows.PNG

Mac OS.jpg

config.plist

gfxutil output.png

Share this post


Link to post
Share on other sites
Advertisement

@kkdart

 

Set Primary GPU to IGFX in BIOS/UEFI

 

and look for the iGPU here to see if it's loaded, that's the only way I could get it to show in System Report

 

Spoiler

igpu.png

 

Share this post


Link to post
Share on other sites

Yep did that but still not showing up.

 

A workaround for getting hardware acceleration with an AMD GPU is to use this boot args for WEG: 

shikigva=40 + shiki-id=Mac-7BA5B2D9E42DDD94

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By aerokevv
      Hey everyone,

      I'm having some trouble with connecting my new 3rd monitor to my machine.
      First off, here is some info about my build:

      macOS High Sierra 10.13.5
      CPU: Intel i7 Coffee Lake 8700k
      GPU: NVIDIA GeForce GTX 1070
      Motherboard: Asus ROG STRIX Z370-F GAMING
      Running on Clover. (config.plist attachment below)

      Monitors:
      DELL U2718Q 4K
      iiyama ProLite XUB2792UHSU 4K
      Phillips HD Monitor

      So the problem is:
      I bought the iiyama to use as a 3rd monitor. Previously I was using the DELL through a DisplayPort, and the Phillips through HDMI which worked fine.
      When I first got the iiyama monitor and I plugged it in everything was working great. The next day I boot up my machine and it will freeze on a black screen after I boot macOS through the clover bootscreen. I unplugged the new monitor, restarted the machine and it would boot normally again.

      I started trying some different inputs and nothing seemed to solve the problem. All that I know is that the machine freezes as soon as I plug in a 3rd cable, doesnt matter if its HDMI or DP. I even bought a HDMI to DP cable for the Phillips, to see if it was an HDMi problem, but even then it doesn't work. I've also tried powering the monitors off and turning them on once the machine has booted. Also no luck.

      Any help from one of you Hackintosh guru's would be highly appreciated. I bought the 3rd screen to make working from home even more efficient, but sadly enough my build won't allow me...

      Thanks in advance!

      Greets,

      Kevin
      config.plist
    • By Tristana
      Hello, and thank you for your help!
       
      Ever since installing my new Sapphire Radeon Pulse RX580, I've been having issues with audio freezing up for the whole system- seemingly the coreaudiod process crashing / my USB audio interface not working. It feels random but seems to correlate with playing youtube videos, streaming audio in Finder, playing sound files from chat clients like Telegram/Discord and such. The system otherwise works as normal, with only audio related functions breaking. Sometimes instead of a full freeze / crash, the sample rate of audio will just drop significantly, causing a lot of aliasing.
      I followed this guide here, though it is outdated and some KEXTs have been merged with WhateverGreen. The shikigva=4 & -rad4200 boot arguments weren't available in WhateverGreen so I didn't add any boot arguments.
      https://hackintosher.com/guides/fix-rendering-issues-fcpx-high-sierra/
       
      My issue was not fixed by this. I also learned that USBInjectAll hadn't been given a custom SSDT and so I made one, which I have included at the end of this post. I also disabled the 15 port patch which had been left on. My USB ports now show up properly (though I've excluded my mobo's type-c port to meet the 15 port limit). My audio issues still have not been fixed, though.

      On High Sierra, the crash was irrecoverable- opening sound in system prefs just froze up, and I have to reset the system to get audio back. In Catalina, I seem to be able to choose a different audio device then go back to my external interface to reset the driver and get sound back.

      Thank you for any help / ideas you can offer!

      UPDATE: Issue still persists. I'm now using a USBPorts.kext created by Hackintool and have updated my list of current kexts below.

      System:

      Kexts:


       
       
    • By ayeshch
      Me (and many other people) experience eye-ache from new Macbooks (and windows machines).
       
      I have spent two years of trial-and-error and found that installing macOS Mavericks on my MacBook (pro 13 late 2013, Intel Iris 1536 MB) resolves the issue of eye ache completely. (it is believed that newer systems use harsher version of temporal dithering that causes of a certain group of indivisuals eye aches).

      I cannot stay at Mavericks because of software support and security issues, so the only thing is an issue now:

      How can I take drivers from Mavericks and install them on Catalina? (I tried replacing .kext in /System/Library/Extensions with old files but it didn't work).

      It would be so great if possible!

      Thank you
    • By Amit Meena
      This card is working OOB, but it has some graphical issues as per attachments.

      If someone has a solution please share.






×