Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
Kailash

Audio, Brightness Control and Battery indicator not working

1 post in this topic

Recommended Posts

I successfully managed to install Hackintosh on my Lenovo Ideapad 520 but now I don't have audio, brightness control feature or battery indicator. My audio driver is an ALC230. I am new to all this. What do I do to solve this? I have attached my EFI files below.

EFI.zip

Share this post


Link to post
Share on other sites

  • Similar Content

    • By plexiputer
      I'm happy to do some Gigabyte 100 / 200 / 300 DSDT edits , just as long as that's cool with MaLd0n.
    • By MacNutty
      Apple has always fascinated me with their outstanding hardware and software. Always wished of having a piece of Apple at my hand, but due to its high cost, at-least in India, never I had a chance of buying a Mac, have a iPhone though. Years ago I had made a desktop hackintosh when Apple had released MAC OSX Leopard, which actually worked quite well. But after switching over to laptop and donating my old desktop, my days of MacOS were completely lost. Busy work schedules also made me cut-off from the hackintosh zone.
       
      Being a software developer, I recently received a project for developing cross platform mobile app using Xamarin. As I was not having a Mac, building a hackintosh became a necessity for building iOS version of the app. But after so many years of gap, didn't knew where to start from.
      After searching the web and various forums, came to know about OpenCore vanilla installation. So, followed the Dortania guide for installation on my Dell Inspiron 7572 (India edition) laptop.
      Things didn't work perfectly at the beginning but after trail and error, search and patching, now I have almost a perfect hackintosh laptop. Here are the details:
      Dell Inspiron 7572 Laptop:
      Processor: Intel Core i5-8250U (8th Gen) | 8 GB DDR4 RAM | Graphics: Intel UHD 620 + Nvidia MX150 | Audio: Realtek ALC3246 | Realtek RTL8168H Ethernet | Qualcomm Atheros QCA6174 Wifi & Bluetooth.
      WORKING / NOT WORKING:
      Graphics: Full HD with HDMI detection working using Lilu.kext & Whatevergreen.kext. Sound: Speaker, headphone jack and mic working using AppleALC.kext (Layout ID: 21) Bluetooth: working out of the box. Ethernet: RealtekRTL8111.kext Sleep: working with patched SSDTs using Dortania's ACPI guide. Camera: working out of the box. SSD / HDD (Raid 0): working using CtlnaAHCIPort.kext. USB 3.0: working out of the box. Battery Status: working with patched SSDTs. Trackpad with all gestures & Keyboard: working using VoodooI2C.kext & VoodooI2CHID.kext iMesssage, App Store, FaceTime & Updates: working as real Mac. Wifi: Qualcomm adapter not working. Got a cheap USB adapter from Amazon TPLink TL-WN725N for INR. 439 (US $6). Card Reader: Not working. Didn't bother as am not using it at all.  
      ScreenShots:


       
       

    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See OC (UEFI) draft EFI here
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the USBPorts.kext in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A or 02.14.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.9 WhateverGreen.kext 1.4.4 AppleALC.kext 1.5.4 IntelMausi.kext 1.0.4 (acidanthera version) EFIChecikDisabler.kext 0.5  
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk 800 G4 Mini - CLOVER Rev 1.4.zip
    • By davi11084
      Buongiorno a tutti.
       
      Io ho da poco effettuato l'installazione di High Sierra 10.13.6. Successivamente ho risolto qualche problema con i due monitor e ho messo i driver nvidia.
      Adesso devo risolvere il problema dell'audio.
       
      La mia scheda madre è: MSI Gaming M3 H270 con chipset audio ALC1220.
       
      Ho provato a installare lilu con appleALC e ho provato i vari codec(1,2,5,7,11) ma nulla, non funziona.
      Metto in allegato la cartella efi con tutto.
      Come posso risolvere?
       
      EFI.zip
×