Jump to content

14 posts in this topic

Recommended Posts

Advertisement
Just now, IDON-NO said:

@midi-sama

Did you manage to fix fan speed noise which happen somtimes? 

Also does VirtualSMC.kexts show correct info about CPU , Fans , Battery ... etc with iStat menu ?

Thanks 


Fan speed noise? My fans rarely even ramp up to hear them. No, VirtualSMC cannot show Fans reading but everything else (read the guide properly). No, I do no use iStat, so I cannot really tell.

Share this post


Link to post
Share on other sites
Just now, IDON-NO said:

I am using Bios v1.60 latest.

Fans sometimes under load make noise .. don't know why !! In windows everything is normal 

I've tried both OC and Clover . But I'm using Clover and FakeSMC.kext they works good with iStat menu

 

That's unusual, can you check that your CPU isnt being hammered by some process?

Share this post


Link to post
Share on other sites
2 minutes ago, IDON-NO said:

@midi-sama

I've managed to disable CPU Turbo boost by using VoltageShift. but this doesn't fix the fan issue . Also tried CPUFriendFriend SSDT with all Profiles 

Nothing help 

Any way it is not a big problem.  I am living with it for 2 years now 

Thanks

 

I hope you fix it. This doesnt seem normal, I helped 2 people with P50s (both i7s) and never reported such problem. Make sure it's not something physical.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, IDON-NO said:

@midi-sama

No it's not . 

Windows side works very well . 

My model is Xeon P530 4K workstation with Nvme SSD 

 

And Fans 99% of time is silent or works as usual. 

But when I start  an App like Photoshop , fan start with noise like Jet and then work normal 

 

Don't know why 

That's totally not ok, since I use PS and Autocad and Archicad all open at the same time and I never had this issue .

Edited by midi-sama

Share this post


Link to post
Share on other sites

@midi-sama I tried following your guide but i boot to blackscreen. My config.plist seems normal but i can't seem to boot. I have the same Lenovo P50. Can you help me check where am doing it wrong...

LENOVO.rar

Share this post


Link to post
Share on other sites

Still the same black screen after picking the recovery partition or my main mac drive. But with clover it loads just fine. though i wanna try opencore

Share this post


Link to post
Share on other sites
On 4/12/2020 at 5:58 AM, IDON-NO said:

try this 

Place it inside (OC folder) beside Opencore.efi , delete the one which outside EFI

config.plist

Im sorry that config is just messed up.

Nullcpu

No proper cleaning of the config

Using EC ssdt when not needed. That's not how OC works.

Share this post


Link to post
Share on other sites

Have followed the guide as best as i could. And when i run it into that sanity check website, it seems fine. Can you help on what am missing for it to boot..

Share this post


Link to post
Share on other sites
24 minutes ago, IDON-NO said:

can you share your config.plist please ?

something is not clear or incomplete in your tutorial in GitHub

just share it for comparison 

thx

 

Also do you use DSDT or NO ?

 

 

My guide on github is to follow the main *OpenCore Laptop Guide*, that one has everything, but then I added things that will need to be changed for our particular models. My guide does not (and will not) provide any config.plist/kexts because 1) you should make your own config, 2) kexts are updated every day, so no.

 

If you properly read my guide I'm not patching my DSDT statically, im patching it dynamically with OpenCore ACPI binpatch (read the documentation at the end of the guide, there are tons of links).

9 minutes ago, Rocdrew said:

Have followed the guide as best as i could. And when i run it into that sanity check website, it seems fine. Can you help on what am missing for it to boot..

Your config is a mess and the laptop guide didnt call for any of those. The sanity check is really not a good indicator (it just shows if things exist the way the guide says, but not how they should be for your exact situation). You're using uneeded kexts, you're using uneeded SSDT (the EC one, and I clearly stated in the guide not to use it), your ig-platform is wrongly put and so on... I dont expect it to boot. Please redo your setup again following the laptop guide with the modifications that my guide ask for. 

Share this post


Link to post
Share on other sites
Just now, IDON-NO said:

@midi-sama

I knew you won't share your config.plist 

But I don't understand one thing ; are you using DSDT ? Or only SSDT ? 

I have same model as you exactly.

When following your steps I have KP 

 

1) your computer has its own dsdt, I dont like patching the dsdt statically because of bios/uefi updates, im doing it dynamically with binpatch + ssdts.

2) that's a vague answer, show the kernel panic log.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
       
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Solved. Problem resolves itself after a few boot cycles) After applying the Catalina 10.15.5.02 supplemental update, Catalina booted to a single display.  After a few boot cycles, multi-display operation was restored to normal. (Solved and included in the attached EliteDesk.zip archive) Unable to upgrade from 10.15.4 to 10.15.5 when using IntelMausiEthernet.kext.  Solution is to switch to IntelMausi.kext (Rev 1.0.2 here). (Solved and included in the attached EliteDesk.zip archive) Some USB devices were not recognized. My SSDT-UIAC.aml was incomplete and did not specify all required USB port types (missing SSxx ports). The attached EliteDesk.zip archive includes this fix. (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (No longer observed) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (Solved - this is a BIOS setting and requires no macOS changes) Safari has problems loading insanelymac web pages after sleep / wake.  I suspect that the problem is with the embedded video on the pages.  Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable.  Solution is to enable Intel ME in BIOS. (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers AudioDxe DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.5.02 Clover (UEFI) r5118 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
       







      EliteDesk800 G4 Mini - Rev 0.81.zip
    • By dmpcoke
      Hi,
       
      I followed the OC guide, and installed Catalina 10.15.5 on my PC.
      The installation went very well. Most parts also work well after I login to the desktop except the following
      issue:
      Each time I tried to log back into the desktop from sleep, I would get a black screen very shortly after I entered the desktop.
      And black screen will last from a few seconds to a few minutes, no exact lasting time.
      Keyboards and mouse are still working during black screen, I can see the operations after the monitor works again.
       
      It connects LG monitor via DP port and I tried to modified the dp version between 1.2 and 1.4, got the same issue.
       
      Attached my entire OC folder, I'm so appreciated if someone could help me check it out, or tell me which part I should focus on.
       
      Thanks in advance!
       
      P.S. Here is my PC summary: Dell Optiplex 7060 MFF
       
      CPU Intel(R) Core(TM) i3-8100 CPU @ 3.60GHz; 8th Gen, Coffee Lake GPU Intel(R) UHD Graphics 630 RAM Team Group 32 GB (2 × 16GB), 2400 MHz, DDR4 Chipset
      Intel 300 Series LPC (Q370) – A306 Audio Realtek ALC255/3234 (Codec ID: 0x10EC0255) Ethernet Intel(R) Ethernet Connection I219-LM WiFi/BT M.2 BCM43224 802.11a/b/g/n Storage Samsung SSD 970 EVO 500GB USB Ports Type-C × 1,USB 3.0 × 5 Video Output DP × 2 Monitor LG 4K 3840 x 2160 @ 60 Hz
      BIOS v1.4.2 OC.zip
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
      -Donations with PicPay 
      @danielnmaldonado
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
      DSDT.Gigabyte Z490-UD.zip
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--























       









       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
×