Jump to content

Best way to upgrade to 10.4.8 with 8.8.1 kernel?


10 posts in this topic

Recommended Posts

I have a properly working installation of 10.4.5 on my Dell Dimension 8400 desktop with an Nvidia 6800 but it is currently lacking QE/CI support. I would like to upgrade to the latest version to get that.


There seem to be several ways to get to 10.4.8:


(1) Fresh install of 10.4.8: I tried it but I had some issues with "Still waiting for root device"


(2) Use Jas combo update


(3) Use mac.nub's guide here - http://forum.insanelymac.com/index.php?showtopic=33342


(4) Use aberracus guide here - http://forum.insanelymac.com/index.php?showtopic=32025


(5) Use smethex's slightly complicated method - http://forum.insanelymac.com/index.php?showtopic=33039



I am wondering which would be the best way to do it?



Link to comment
Share on other sites

you can install from any of 10.4.4,10.4.5, or 10.4.6, the only thing you need to fix is one of the kexts (r2d2) permisions, and reinstall in safe mode the intel gma 900 support, I've installed the 10.4.5 than updated with 10.4.7 Jas and than 10.4.8 jas, afther reboot:


in -s:

mv /System/Library/Exrensions/r2d2.kext /System/Library/Extensions


diskutil fixPermissions /System/Library/Extensions/r2d2.kext

kextcache -k /System/Library/Extensions


and than as Jas said run 10.4.6.GMA.Support.pkg in -x mode.


reboot and all is working quite fast, but there is 8.4.1 kernel:


System Software Overview:


System Version: Mac OS X 10.4.8 (8L2127)

Kernel Version: Darwin 8.4.1


{censored}:~ admin$ uname -a

Darwin {censored}.local 8.4.1 Darwin Kernel Version 8.4.1: Tue Jan 3 18:23:53 PST 2006; root:xnu-792.7.90.obj~1/RELEASE_I386 i386 i386





strange thing... the chmod and chown commands to restore permissions for r2d2 were not working at all (still wrongly installed r2d2 message)


but using diskutil and kextcache as I said a few lines before makes r2d2 to load properly (QE and CI) all apps working no hangs, a bit faster even i think...



but i have 8.4.1 so how to get 8.8.1 ?

Link to comment
Share on other sites

NET: once again we run into this misunderstanding.. your answer does not lead to 10.4.8 with 8.8.1


the "10.4.8 Combo updates" in circulation for AMD / Intel / sse2 /sse3 are now out of date for all sse3 users, and it is only the fact that they carry the 10.4.8 version number that causes them to still crop up.


people using these are still using largely 10.4.4 components, particularly the 8.4.1 kernel.


"true" 10.4.8 uses an 8.8.1 based kernel and asssociated components.

Simply replacing the kernel will not update an 8.4.1 based system to an 8.8.1 based one, it requires a major upgrade, or ideally a full clean install.

Link to comment
Share on other sites

My choice was to follow the guide from the semthex FAQ - that is after I tried a jas-10.4.7 install and 10.4.8-combo update and experienced several strange crashes. I noticed that many of the kexts' had dependency errors and others had reproted that following the semthex method they had no dependency errors.


I used a Linux live-cd system to partition my hard drive, set the partition type=af and flag the partitions as active - bootable. I created 3 partitions - one each for maintenance ( 8gb ) - Production ( 60gb ) and test ( 30 gb ). I used the jas-10.4.7-install dvd to create the maintenance partition.


Using the maintenance partition, I built the production partition starting with the 10.4.4 install image and - following the semthex FAQ build instructions applied the Apple delta updates for 10.4.5 through 10.4.8. Once the production partition was running I used it to construct the maintenance partition following the same semthex procedure.


When I want to backup my production partition - like before major updates - I boot the maintenance partition and use disk utility to create an image which is stored on an external firewire drive. This process has saved my system more than once.


good luck with whatever you chose.

Link to comment
Share on other sites

Hagar, i know that the patches are using 8.4.1, and not changing the sytem to "true" 10.4.8, but in all of the topics many people have said (wrongly) that 10.4.8 patches made by jas brings 8.8.1 ker. ver. maby it's time to close some stupid topics made by script kids, my post was made to show that 10.4.8 (patched) is not even equail to real 10.4.8 and only changing the printed ver (and system ver, cause the 10.4.8 apps are working) but they do not have the real 10.4.8 "power" of new fetures.


I do not have lastely much time to work under osx86 so i'm not in the center of the work (studyes,girlfriend and my own company takes all the time) but i steel remember times when me and NT2000 were fighting with 10.4.1 to work without forums HCL's and comunity help )


P.S. any ideas how to brake thru the firewall ? and not with ToR proxy, my network is copletely cuted off (a few ports working only) no torrents and no ability to share my work (normaly 10MB/s) im using campus network


sorx for bad english :) and cheers

Link to comment
Share on other sites


  • Create New...