Jump to content
Denny

hackintosh con High Sierra problema con audio

32 posts in this topic

Recommended Posts

Salve a tutti, ho un problema con l'audio. Ovvero non riconosce le giuste porte audio e manca anche l'audio tramite DP tramite GPU. Allego la cartella EFI nel caso vorreste dare uno sguardo.
Config:

GigaByte Z370P D3
I5 8400
Ram corsair vengeance LPX 16gb 3000MHz

Nvidia 1050ti 

Grazie in anticipo!

P.S. Se serve ioreg posto

 

https://www.mediafire.com/file/0hmpnp6x1f6u26p/EFI.zip/file

 

Share this post


Link to post
Share on other sites
Advertisement

Mostra tutte queste e manca l'uscita audio tramite DisplayPort, e tre le 4 solo la prima funziona effettivamente le altre sono in più

 

Schermata 2019-08-12 alle 22.29.11.png

Share this post


Link to post
Share on other sites

da una ricerca la tua mobo ha il chip alc887

 

quindi sempre alc e lilu in efi

 

layout da provare 

 

layout 1, 2, 3, 5, 7, 11, 13, 17, 18, 33, 99

 

aggiorna anche applealc e lilu che sono vecchi...aggiorna anche clover se non lo è...

Share this post


Link to post
Share on other sites

quando posti le EFI, non importa che lasci le cartelle APPLE e Microsoft... pesano e NON ci servono a niente

 

segui i consigli di Marzillo, ti avrei detto uguale... 

visto che hai il tema di macOS86 per cui la EFI quasi sicuramente te l'ha preparata Baio a meno che non sei un'amico di Carlo67 :) questo per dire che se vuoi la soluzione per l'audio HDMI sulla 1050 apri thread e richiesta anche qui come hai fatto ora su IM ;)

Share this post


Link to post
Share on other sites
On 8/12/2019 at 10:39 PM, MARZILLO said:

layout 1, 2, 3, 5, 7, 11, 13, 17, 18, 33, 99

 

queste impostazioni possono modificare il comportamento dei jack cuffie frontali (quelli del case)?

Share this post


Link to post
Share on other sites

quale provo prima?

commander o aggiornare i vecchi kext? (a proposito, come si aggiornano?)

25 minutes ago, XCLele72 said:

non mi sembra ci sia una impostazione simile, ora ricontrollo...

 

Nel bios ho HD Audio "Enabled". Nessuna menzione però sul pannello frontale (come ho visto su altri bios)

Share this post


Link to post
Share on other sites
12 minutes ago, MARZILLO said:

sto leggendo varie guide con la tua mobo

se me ne passi qualcuna provo a chiedere magari trovo chi ha il mio stesso cabinet e posso fare prove ad esclusione

3 minutes ago, MARZILLO said:

https://github.com/acidanthera/AppleALC/releases

 

https://github.com/acidanthera/Lilu/releases

 

scarica e prendi il kext della cartella release..prima aggiorna e prova ...poi se non va metti codec commander

 

ok

Share this post


Link to post
Share on other sites

In entrambe le release dei due kext c'è un file in più rispetto al solo kext.

Li metto entrambe dentro EFI o metto solo i kext come ho fatto finora?

Edited by XCLele72

Share this post


Link to post
Share on other sites

per mettere codec commander devo togliere quelli messi prima?

l'ho messo ma la situazione non cambia...

Edited by XCLele72

Share this post


Link to post
Share on other sites

non ho piu idee mi spiace...hai visto se per caso l'uscita cuffia appare nel pannello preferenze vicino la voce altoparlante interno?

prova a vedere con la cuffia inserita se la voce appare

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By andyapple
      Hi, I need help to fix my HDMI output on my Acer Aspire F5 573G with Intel HD 520.
       
      This is the situation, and it is unstable:
       
      When I connect my HDMI cable the internal monitor of the notebook gets black but the secondary monitor works.

      To get also the internal notebook monitor working I have to close the notebook for like 5-6 seconds and then open it up, and also the secondary monitor works.
       
      So I would like to fix this and get both monitor always working when HDMI cable is connected.
       
      I noticed that if I keep the notebook closed, the secondary monitor works in 4K resolution (while if the notebook is open, even with 4k resolution selected the secondary monitor is 1080p), so the secondary monitor works in 4k only if the notebook is closed.
       
      And I would like to fix this too.
       
      Audio over HDMI is not working and I would like to fix this too.
       
      I'm attaching useful report files as EFI and others.
       
      Thanks,
       
      Andyapple
      Problem Files Report.zip
    • By tom666
      osx10.14
      i5-4250u
      i have added "irq hdef hdau  mutex osys10" patch
      and install acpibettery on clover ,but the battery management still donot work

      my audio card is alc269vc ,i try to use applealc,and tried all the layoutid, all of those colud not work.
      2019-03-31 20:18:23.389590+0800  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to find IOHDACodecVendorID, retrying 0
      i have also use linux to find the codec
      i uploaded the clover , dsdt,codec.
      This problem has been bothering me for two days.
      thanks
       
       
      all.zip
      2019-03-31 20:18:17.997435+0800  localhost kernel[0]: calling mpo_policy_init for Lilu
      2019-03-31 20:18:18.003796+0800  localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.5 (Lilu)
      2019-03-31 20:18:23.389590+0800  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to find IOHDACodecVendorID, retrying 0
      2019-03-31 20:18:23.398483+0800  localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 0 patches out of 1
    • By noisegate
      Hi,
       
      I use AppleALC v1.3.5, I can see the device in system info but no sound. Any idea?
       
      Thanks!
       
    • By grisno
      Hi people,
       
      Installer to activate the sound card REALTEK ALC282-v2 (10ec:0282) with LayoutID 1 or 3 in MacOS. This installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA.kext.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      Speakers : OK Headphones : OK HDMI Audio : OK (Intel HD4K Tested) LineIn : N/A (Model Without LineIn) MicInt : OK MicIntNoiseReduction : OK MicExt : N/A (Model Without MicExt) AutoDetectLineIn : N/A (Model Without LineIn) Sleep : OK WakeUp : OK AutoSleep : OK Hibernate : OK Siri : OK   Tested Laptops:
       
      - HP Pavillion 15-D002SS
       
      Coming Soon:
       
      - Unified installer for the different supported operating systems.
      - Support model with LineIn jack.
       
      Modified Verbs:
      01271C20 01271D00 01271EA0 01271F90 01471C10 01471D00 01471E17 01471F90 01871CF0 01871D00 01871E00 01871F40 01E71CF0 01E71D00 01E71E00 01E71F40 02171C30 02171D10 02171E21 02171F00 01470C02   DSDT:
       
      Patch to apply with MaciASL in your DSDT
      ######################################### HDEF v1.00######################################## into method label _DSM parent_label HDEF remove_entry;into device label HDEF insertbeginMethod (_DSM, 4, NotSerialized)\n{\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "layout-id", Buffer() { 0x01, 0x00, 0x00, 0x00 },\n //"layout-id", Buffer() { 0x03, 0x00, 0x00, 0x00 },\n "hda-gfx", Buffer() { "onboard-1" },\n "PinConfigurations", Buffer() { },\n })\n}\nend;  
    • By grisno
      Hi people,
       
      This is a preliminary installer to activate the sound card IDT 92HD87B2/4 (111D:76D9) in MacOS. This new version of the installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA Kext.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      Speakers : OK Headphones : OK HDMI Audio : OK (Intel HD3K/4K Tested) LineIn : OK MicInt : OK MicIntNoiseReduction : OK MicExt : OK AutoDetectLineIn : OK Sleep : OK WakeUp : OK AutoSleep : OK Hibernate : OK Siri : OK   Tested Laptops:
       
      - HP Pavillion G6-2209SS
      - HP Probook 4440S
       
      Coming Soon:
       
      - Unified installer for the different supported operating systems
       
      Original Verbs:
      00a71cf0 00a71d00 00a71ef0 00a71f40 00b71c1f 00b71d10 00b71e21 00b71f04 00c71c20 00c71d10 00c71ea1 00c71f04 00d71c10 00d71d01 00d71e17 00d71f90 00f71cf0 00f71d00 00f71ef0 00f71f40 01171c30 01171d01 01171ea3 01171fd5   Modified Verbs Layer ID 3 & 12:
      00A71CF0 00A71D00 00A71EF0 00A71F40 01371C40 01371D10 01371E21 01371F04 00C71C20 00C71D10 00C71E81 00C71F04 01471C10 01471D01 01471E17 01471F90 00F71C50 00F71D00 00F71EF0 00F71F40 01171C30 01171D01 01171EA0 01171F90  
      Modified Verbs Layer ID 2:
      00B71C10 00B71D10 00B71E21 00B71F04 00C71C20 00C71D10 00C71E81 00C71F04 00D71C30 00D71D00 00D71E17 00D71F90 01171C40 01171D00 01171EA0 01171F90  
        AppleHDAHardwareConfigDriver.kext > Info.plist (Layer ID 2, 3 & 12): <key>HDAConfigDefault</key> <array> <dict> <key>AFGLowPowerState</key> <data> AwAAAA== </data> <key>Codec</key> <string>IDT 92HD87B2/4</string> <key>CodecID</key> <integer>287143641</integer> <key>ConfigData</key> <data> AKcc8ACnHQAApx7wAKcfQAE3HEABNx0QATce IQE3HwQAxxwgAMcdEADHHoEAxx8EAUccEAFH HQEBRx4XAUcfkAD3HFAA9x0AAPce8AD3H0AB FxwwARcdAQEXHqABFx+Q </data> <key>FuncGroup</key> <integer>1</integer> <key>LayoutID</key> <integer>2</integer> </dict> <dict> <key>AFGLowPowerState</key> <data> AwAAAA== </data> <key>Codec</key> <string>IDT 92HD87B2/4</string> <key>CodecID</key> <integer>287143641</integer> <key>ConfigData</key> <data> ALccEAC3HRAAtx4hALcfBADHHCAAxx0QAMce gQDHHwQA1xwwANcdAADXHhcA1x+QARccQAEX HQABFx6gARcfkA== </data> <key>FuncGroup</key> <integer>1</integer> <key>LayoutID</key> <integer>3</integer> </dict> <dict> <key>AFGLowPowerState</key> <data> AwAAAA== </data> <key>Codec</key> <string>IDT 92HD87B2/4</string> <key>CodecID</key> <integer>287143641</integer> <key>ConfigData</key> <data> ALccEAC3HRAAtx4hALcfBADHHCAAxx0QAMce gQDHHwQA1xwwANcdAADXHhcA1x+QARccQAEX HQABFx6gARcfkA== </data> <key>FuncGroup</key> <integer>1</integer> <key>LayoutID</key> <integer>12</integer> </dict> </array>   DSDT:
       
      Patch to apply with MaciASL in your DSDT. You must change the value of the layout-id before applying the patch. In MacOS Mojave should always be 0x02
      ######################################### HDEF ######################################## into method label _DSM parent_label HDEF remove_entry; into device label HDEF insert begin Method (_DSM, 4, NotSerialized)\n {\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "built-in", Buffer () { 0x00 }, \n "hda-gfx", Buffer() { "onboard-1" }, \n "layout-id", Buffer () { 0x03, 0x00, 0x00, 0x00 }, \n "PinConfigurations", Buffer () {}, \n "MaximumBootBeepVolume", Buffer () { 0x4d } \n })\n }\n end;  
×