Jump to content
JRevenge

Ottimizzazione Hackintosh Asus

23 posts in this topic

Recommended Posts

Ciao ragazzi,

alla fine sono riuscito a risolvere il problema che riscontravo qualche mese fa, dopo l'ottima EFI sistemata da @gengik84 e l'ho risolto rimuovendo dart=0 che creava kernel panic e problemi quando la batteria scendeva sotto ad un livello di batteria basso. Adesso il sistema non crea più problemi di kernel panic, ma volevo chiedervi se allo stato attuale secondo voi c'è qualcos'altro da ottimizzare.

 

Vi allego la EFI.

 

Grazie anticipatamente.

CLOVER.zip

Edited by JRevenge

Share this post


Link to post
Share on other sites
Advertisement
Ciao perchè OsxAptioFixDrv256m-64.efi?
puoi mettere allora la V2 ma sarebbe meglio aptiomemory
Perché è una versione creata appositamente per i notebook Asus che soffrono dei problemi che mi dava di nvram, onestamente non ho più provato dopo aver tolto Dart=0 a mettere Aptio, quasi quasi provo e ti faccio sapere

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Ciao perchè OsxAptioFixDrv256m-64.efi?
puoi mettere allora la V2 ma sarebbe meglio aptiomemory
Confermo, con AptioMemoryFix64 funziona correttamente e la nvram è nativa. Sono riuscito anche ad abilitare il Trim dal config.plist che prima creava problemi di crash di sistema. Al boot-arg abm_firstpolldelay ho messo 16000, forse è meglio tornare a quanto c'era prima? 8000? o conviene toglierlo? Cosa mi consigli?

Grazie.

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
dipende..se non hai problemi della batteria, riguardo a visualizzazione etc, puoi rimuoverlo
 
Si, l'ho rimosso e funziona correttamente. Noto solamente una lentezza nel boot iniziale, poi dopo un minuto circa dall'avvio completo gira bene. C'è qualcos'altro da modificare secondo te? Posso mandare volendo un verbose dove si blocca per un 30 secondi.

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

durante il verbose vedo che perde un po' tempo su apfs riguardo al disco

CsmVideoDxe-64.efi questo lo usavi per la risoluzione?

 

Share this post


Link to post
Share on other sites
durante il verbose vedo che perde un po' tempo su apfs riguardo al disco

CsmVideoDxe-64.efi questo lo usavi per la risoluzione?

 

Si esatto, se ti ricordi andava in crash mettendo una risoluzione non predefinita (tipo 1368x qualcosa). Quindi sono riuscito a mettere CSM dal BIOS e in driver64uefi, più quello e 1920x1080 in GUI e niente di più. Provo a toglierlo?

 

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

 

 

 

Share this post


Link to post
Share on other sites

Prova a rimuoverlo perchè "rallenta" anche quando carica la grafica

Anche se come detto prima il più è dato nella lettura di apfs

 

Questo è sempre successo oppure?

 

Share this post


Link to post
Share on other sites
Si esatto, se ti ricordi andava in crash mettendo una risoluzione non predefinita (tipo 1368x qualcosa). Quindi sono riuscito a mettere CSM dal BIOS e in driver64uefi, più quello e 1920x1080 in GUI e niente di più. Provo a toglierlo? 
Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk
 
 
 
Togliendo CSM dalla cartella EFI e lasciando attivo quello del BIOS, la risoluzione iniziale non è FHD ma bassa, poi si avvia con quella sua (ma noto sempre lentezza). Se rimuovo CSM dal BIOS, oltre che dalla driver64uefi si avvia velocemente (in tempi minori) ma non carica i driver video (glitch grafici pieni di righe). Se invece tolgo la risoluzione di Clover, si avvia clover con risoluzione bassa, ma dopo l'avvio è veloce e funzionante

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Prova a rimuoverlo perchè "rallenta" anche quando carica la grafica
Anche se come detto prima il più è dato nella lettura di apfs
 
Questo è sempre successo oppure?
 
Purtroppo da quando ho tolto dart=0 non ci ho fatto più caso.

Adesso riprovo a togliere csm dal BIOS, mettendo la risoluzione nel config vuota e vedo i tempi di avvio.

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Purtroppo da quando ho tolto dart=0 non ci ho fatto più caso.

Adesso riprovo a togliere csm dal BIOS, mettendo la risoluzione nel config vuota e vedo i tempi di avvio.

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Domanda stupida: tempo fa notavo rallentamenti, se non addirittura blocchi, con il Trim attivo da Clover, provo a toglierlo? Può dipendere da quello la lentezza con apfs?

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Purtroppo da quando ho tolto dart=0 non ci ho fatto più caso.

Adesso riprovo a togliere csm dal BIOS, mettendo la risoluzione nel config vuota e vedo i tempi di avvio.

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Domanda stupida: tempo fa notavo rallentamenti, se non addirittura blocchi, con il Trim attivo da Clover, provo a toglierlo? Può dipendere da quello la lentezza con apfs?

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Prova a rimuoverlo perchè "rallenta" anche quando carica la grafica
Anche se come detto prima il più è dato nella lettura di apfs
 
Questo è sempre successo oppure?
 
Ho provato con:

- Trim disabilitato
- GUI con risoluzione vuota
- Senza CSM nei driver
- CSM nel BIOS spento

Da glitch grafici

Se invece metto:
- Trim disabilitato
- GUI vuota
- CSM nel BIOS attivo
- Non presente il CSM nei driver

Clover parte con bassa risoluzione, ma il PC poi si avvia senza glitch grafici

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Il trim su apfs può rallentare il boot
a parte questo, nelle prove la velocità del boot è migliorata?
Ci mette 39 secondi (dal video mi pare siano circa 50 secondi).

Inoltre, noto, che anche mettendo su "fast" bypassando la schermata di clover, un glitch grafici lo fa, però poi si avvia prima in bassa risoluzione, poi mette quella FHD.

L'unica sarebbe rimettere la risoluzione che piace a lui 1368x768 (una cosa simile) lasciare Clover con bassa risoluzione che poi converte in quella FHD ed evitare tutto. Cosa ne pensi?

Inviato dal mio ONEPLUS A6013 utilizzando Tapatalk

Share this post


Link to post
Share on other sites
4 minutes ago, gengik84 said:

Ok prova

 

La risoluzione esatta che lui accetta è: 1280x1024 , disabilitando il CSM nel BIOS e togliendolo da driver64uefi, sembra andare un pochino più veloce (fa lo switch da risoluzione bassa a quella normale).

Share this post


Link to post
Share on other sites
3 minutes ago, gengik84 said:

Avevi detto che hai tolto dart=0 dal config ma sul bios vt-d come è impostata?

 

E' disabilitato VT-D dal BIOS

Share this post


Link to post
Share on other sites
5 minutes ago, gengik84 said:

Ok

 

Secondo te come posso fare? mi tengo la combinazione di prima? anche se ci mette un pò ad avviarsi?

Share this post


Link to post
Share on other sites

ioreg è ok come anche la EFI, kext e driver sono aggiornati

Puoi provare un altra versione di clover oppure se hai modo installare su un altro supporto solo per vedere se nel caso una nuova installazione non avesse tali ritardi al boot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By karthiksh1989
      can somebody walkthrough with the mojave installation guide?
      i have a mac high sierra 13.6 version on my macbook pro and want to install mojave on my desktop
      Exact config is Gigabyte gaming wifi 7 motherboard amy ryzen 7 2nd gen 2700X processor Gigabyte G1 8GB grapgic card VEGA 64
      running 2 nvme Samsung 256gb cards and 1 intel 180gb ssd internal and 1tb WD HDD, with 64 GB 3200Mhz Ram
       
      https://wa.me/919611736534 (whatsapp)
    • By ltooz_audis
      I always want to have a long lasting battery ultrabook to install Mojave on. I was looking at Dell XPS 13 but its design is not very good with the camera and other problems. HP Spectre x360 is a nice design but the wifi module is soldered on board. The Envy 13" is the best one in the bunch for MacOS Mojave. I would not use any other macOS besides Mojave, it's the best one so far. If you can't get it done with macOS Mojave, you don't do it correctly, it's much more refined and given than older macOS's.
      I wanted the 8th generation because of the 4 cores which is almost 1.5 times faster than this 7th generation i7-7500u, but the price is too high. I picked up this one on Craigslist for $400. I've just ordered the 500GB NVME WD Black for $104 and DW1560 for $29. So, the perfect MacBook Pro 14,2 is less than $600 that last 5-6 hours with Mojave and 8-9 hours on Windows 10. The bench mark is the same as the real MacBookPro 14,2. BTW, this is the first try, there will be on going testing and confirming. 250GB hard drive is hardly enough for dual boot Windows and Mac. You need at least 500GB, I don't use Windows at all, so I'll partition 200GB for Windows and 300GB for Mojave.
      All new HP laptops will have kernel panic if using Clover to boot UEFI, at least a fix was found. I'll have more videos and info when I have time to write them. Watch the videos and ask questions if you have any problems.
      1. Clover 4558 - Lilu.kext (1.3.3) - AppleALC.kext (1.3.1) - Whatevergreen.kext (1.2.3) - USBInjectAll.kext (0.6.5) - Fakesmc.kext (6.25-332-gf3a8525c.1758) - ACPIBatteryManager.kext (1.81.4) - AHCIPortInjector.kext - BrcmFirmwareRepo.kext (2.2.7) - BrcmPatchRAM2.kext (2.2.7) - CodecCommander.kext (2.6.2) - FakePCIID_Broadcom_WiFi.kext (1.3.9) - FakePCIID_Intel_HD_Graphics.kext (1.3.9) - FakePCIID.kext (1.3.9) - SSDT-AUIC-ALL.aml - SSDT-USBX.aml - SSDT-PNLF.aml - SSDT-PluginType1.aml - PreLoader.efi.
      2. For the keys F2 & F3 to work with backlight slider - the Fakesmc.kext version is important for some reasons, I'm still trying to find out why.
      The touchscreen actually works without the voodooI2C kexts, just need to patch the clover.
       
      I've been playing with the laptop for over a week now. Ordered the WD 500GB WDS500G2X0C from Amazon for $104, the 256GB is too small for dual booting Windows 10 & Mojave. It's really plug and play.
       
      Hardware - needed to make this a perfect macbook Pro14,2.
      1. DW1560 BCM94352Z - make sure it has 2 notches - Tape the 2 right pins on the 4 pins tab for it to work without a hitch on both Windows 10 and Mojave. You can buy from Ebay cheaper but you have to wait for months.
      2. 500GB NVMe SSD m.2 connector M is a must for dual boot - the cheaper one will be slower - Crucial NVMe 500GB is $25 less than WD.
      3. NOVOO USB-C to HDMI hub that works and inexpensive.
       
      Let's start to get this Kaby Lake working on the HP - I believe HP has the same components for similar configuration on different models. In order to get Mojave to work on Intel Laptop, we need a few important components - Sound is important (look for Realtek - ALC295) - Ethernet if any -Realtek - Trackpad  and TouchScreen (Synaptics or Elan).
       
      REPLACE VNMe SSD HARD DRIVE and DW1560 BCM94352Z
       
      The current BIOS is F22, the newest one is F27 but I don't want to update since it's working well. Since I don't really need the original Windows 10 with Junk software in it, I install the latest Windows 10 using Media Creation USB Boot Drive. The important thing is we have to prepare the SSD correctly or our EFI folder will only be set at 100MB which is not enough to install Clover or any other boot loaders. So instead of letting the Windows installer to create the EFI folder automatically, we can set the size ourselves using "diskpart" command. In order to use diskpart, we need to boot with Windows 10 USB installer (hit F9 then select UEFI USB installer) - select system repair and not installation - then select command prompt, from here we can create EFI folder and MSR for Windows installer to install. The product ID is already in the UEFI bios, so we don't really have to manually activate the Windows 10.

       
       
      diskpart
      select disk 0
      clean
      convert gpt
      create partition efi=300 !!! you can change it from 300MB to any size.
      format quick fs=fat32 label="EFI"
      create partition msr size=16
      exit

      After exit, reboot with the USB installer again in UEFI mode, select the custom. The Windows installer will select the 300MB EFI folder we've just created.
       
       
      How to fix KP on Clover UEFI Boot.
       
       
      This is the macBook Pro 14,2 from HP 13-ad010nr
       
       
       
      Louis
       
    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By yehia2amer
      Dell Precision T7610 Workstation
      Hackintosh GUIDE (Work in Progress)
       
                        
      Introduction: 
      Hi Everyone,
      This Workstation used to be a Beast with Dual CPUs and tons of RAM, I Know it is now normal to get that much cores in a Desktop but it is still a very decent machine for me (As a Programmer), and I thought it would be a good idea to Install MacOS as the Daily Driver Rather than Linux and It turns out to be a very Great Experience (with Some Challenges ).
       
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors RAM: 128 GB 1333 MHz DDR3 ECC Memory GPU: SAPPHIRE PULSE Radeon RX 580 8GD5 Chipset: Intel C602 Audio: Realtek ALC3220 (ALC280) High Definition Audio SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      Working:
      Both "Xeon E5-2680 v2" and all cores with Power Management and P-States (using VoodooTSCSync & ssdtPRGen.sh) ATI Radeon HD 4870 (Vanilla) Realtek ALC3220 (ALC280)  (using VoodooHDA till Now - it is partially working with AppleALC using layout-id 13) LSI 2308 SAS (using AstekFusion2) Intel 82579 Network Controller (Vanilla) Intel I210 Network Controller (IntelMausiEthernet) USB 2.0  
      Not Working:
      NEC USB3.0 xHCI Controller (Renesas Electronics uPD720201 & uPD720202) Sleep  
      https://github.com/yehia2amer/Dell-Precision-T7610-Workstation-Hackintosh-Guide
×