Jump to content
Guest millusions

log show --style syslog | fgrep "Wake reason"

3 posts in this topic

Recommended Posts

Guest millusions

hey guys,

 

so log show --style syslog | fgrep "Wake reason" shows the wake reasons, it's great, but it goes back too far and takes too long.

i just ran it, it goes back to 16-11-18 - one month.

 

is there any way to clear those entries?

 

ive tried sudo periodic daily weekly monthly

 

thanks in advance

Share this post


Link to post
Share on other sites
Advertisement
On 12/16/2018 at 11:40 AM, gengik84 said:

have you tried "sudo log erase --all " ?

HI 

 

Did try the above but did not work. 

 

For anyone else needing to clear the log this is what I have found and believe it has worked.

You need to run the command in terminal using root access. To enable root access you use the command dsenableroot. 

To clear down the log on logged as root you need to use log erase --all.

Do not forget to undo root access by using dsenableroot -d.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×