Jump to content

Mojave 10.14.1 on Lenovo 330s

17 posts in this topic

Recommended Posts



CPU: Intel i5-8250u

RAM: 4GB DDR4 on board, 8G in additional slot

disk: 128GB NVMe SSD(comes with Windows 10 Home)

disk2: 1TB HDD(replaced with Patriot Burst 480GB SATA SSD and install Mojave on it)

2 USB3 ports

1 USB Type-C


Card-Reader(havn't tested yet)

14" display 1920x1080

weight: around 1.6KG

Intel wifi, I replaced it with BCM94350Zae

I havn't tried Bluetooth yet because it's not a necessity for me, but wifi works well.


battery works after following Rehabman's guide, a lot of work but worth it :)

ELAN touchpad also works after DSDT patching, no GPIO pinning required

need to install VoodooI2C, VoodooI2CHID in /Library/Extensions and rebuild cache

you might also need to remove AppleIntelLpssI2C.kext and AppleIntelLpssI2CController.kext as well


sleep/wake works fine, but the system drains about 8% of power during 20 hours of sleep,

it also drains power more quickly than expected when I'm using it.

I wonder if I could do anything thing to improve power consumption.


sometimes it would take up to 15 seconds to fall asleep, sometimes less than 5 seconds

(I mean when the power button goes from "on" to "flashing slowly", indicating it's sleeping)


please help me improve clover config or DSDT if u can.


overall, i think this is a good choice for hackintosh laptop :)







Screen Shot 2018-12-07 at 8.52.40 PM.png

Screen Shot 2018-12-07 at 9.13.51 PM.png

Screen Shot 2018-12-07 at 9.15.25 PM.png

DSDT final.aml

DSDT final.dsl



Screen Shot 2018-12-07 at 9.27.04 PM.png

Screen Shot 2018-12-07 at 9.34.34 PM.png

Share this post

Link to post
Share on other sites

Can you please make a full guide for this hackintosh? I have the same laptop, but stuck at booting to the installation step, getting just a constant bootloop, thank you so much, for letting me know with this post, that it's at least possible, to make our laptop a decent replace for macbook!

Share this post

Link to post
Share on other sites

I have the similar (but very different) 330s 15IBK, which has Kaby Lake Refresh i3-8130 + not ELAN trackpad :-(


I cannot get battery status/lid sleep/trackpad working...


I can get barely usable trackpad with VoodooI2C + I2CHID kexts


I have also gotten partially working battery status, but after the 16bit patching to 8bit, DSDT would no longer compile :-(


If you know of any info/guide regarding this model, could you please let me know!

Share this post

Link to post
Share on other sites

I have 330s-15IKB which does not have ethernet port, wifi only. I boot off usb just nice (clover) to installer.
First strange thing is that in installer, in listed MacOS Utilities I have an option to Reinstall macOS where I would expect an option to Install macOS.

When I click on it I got error message (see below) since it needs an internet connection which I don't have (yet) since I don't have ethernet nor can set up usb wifi in installer (or I can?).


So can somebody please explain my options here - maybe getting usb to ethernet adapter with appropriate kexts? Is there a way to install it without internet connection - I don't get it why internet connection is really needed as I have full installer on usb stick? No need to download anything I believe.

Is it normal to have Reinstall option instead of Install?


all help appreciated, thanks




Share this post

Link to post
Share on other sites

Thanks !! The guide really helped.

I am still facing couple of issues, sleep is broken- it used to work, but only solution for now is by pressing "Sleep".

Audio is getting disable after few hours. Even headphones produce noise. It works after restart.

Please help if anybody has idea on this.

Edited by tusharppp

Share this post

Link to post
Share on other sites
On 01.05.2019 at 01:40, brandonh4693 said:

ребята, вот мои последние файлы. самое главное, я нашел новую версию VoodooI2C, которая решила мою проблему с мышью при использовании трекпада.



Прошу игнорировать OpenVanilla, это просто инструмент для китайского метода ввода

Please write what else kexts need to use in the louse assembly?

Share this post

Link to post
Share on other sites
On 4/30/2019 at 6:40 PM, brandonh4693 said:

folks, here's my latest files. most importantly, I found a new version of VoodooI2C that solved my jumpy mouse cursor problem when using trackpad.



pls ignore OpenVanilla, it's just a tool for Chinese input method

Hi brandonh4693,
I have the same laptop Lenovo 330S-14ikb, Intel UHD Graphics 620.
I downloaded your files and put it on Clover USB but when I try to boot Mojave install it boots to Clover initial screen again...

I think it should work because it's the same model but can you be more specific with your installation process? How you made your usb boot loader, your bios setting, clover version...etc.

I will appreciate if you can help me!! Thanks a lot.

Share this post

Link to post
Share on other sites
On 12.05.2019 at 22:42, yh44 said:

Привет brandonh4693, у
меня есть тот же ноутбук Lenovo 330S-14ikb, Intel UHD Graphics 620.
Я загрузил ваши файлы и поместил его на Clover USB, но когда я пытаюсь загрузить Mojave, установить его снова загружается на начальный экран Clover ...

Я думаю, что это должно работать, потому что это та же модель, но можете ли вы быть более конкретным в процессе установки? Как вы сделали свой загрузчик USB, настройки BIOS, клеверную версию и т. Д.

Я буду признателен, если вы можете помочь мне! Большое спасибо.

используйте свой Clover а от сюда кехты , патчи и конфигплист 

Share this post

Link to post
Share on other sites

Hey @brandonh4693 . I was really hoping that you could help me out. I've managed to get almost everything working, but the close lid to sleep doesn't work. If I use ACPIPoller kext it works for the first time but doesn't work on reboot. Opening the lid wakes the laptop without any problems though. Any idea how to fix this?

Edited by erinviegas

Share this post

Link to post
Share on other sites
On 6/29/2019 at 3:16 AM, slowTerminal said:

Where did you get your new wifi (BCM94350ZAE) card? Can you confirm your FRU?



Capture d’écran .png


Many sellers from china write that BCM94350ZAE dont work with lenovo and IBM because these mobules not in whitelist. I'm confused how topic starter made it work.


I have 330s-14ikb and have problem with touchpad its works without right button and taps as click, only hard button from bottom side of touchpad. In settings touchpad not found.

Still freezes every some seconds.

Anybody knows these symptoms?

Edited by aden16rus

Share this post

Link to post
Share on other sites

Hello bro, can you help me? I have the 15 inch Lenovo Ideapad 330s with Core i3 8130u processor. I wanna fix the trackpad, audio and battery status. I'm new with hackintosh and I don't know how to use your files!.. Thanks in advance.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.