Jump to content
macadventure

Installation of High Sierra

18 posts in this topic

Recommended Posts

Hello,

I am new to hackintosh. I have High Sierra on bootable memory chip 16GB with the help of TransMac. I get the boot screen with options to boot but on choosing to go ahead the screen goes into verbose mode and then stalls at a certain point. Actually the PC hangs and I cannot use my keyboard to get a screenshot. I do have a photo of it though. What config do I need to change, to be able to install onto a partition of HDD?

My System is :

Mobo: GA-H81M-S (rev 1.0); Nvidia GeForce 710 1GB DDR3 (with VGA, HDMI and DVI-D ports), I have connected my monitor (ASUS VP228H) to the HDMI port; 6GB DDR3 1600Mhz RAM; SSD 120GB with Windows 7 Pro 64-bit; Western Digital 1TB with two partitions (with old Windows 7 Pro 64-bit installation); Western Digital 500GB with two partitions and Windows 10 Pro 32-bit on the first partition. I want to install to the second partition of this HDD.

Share this post


Link to post
Share on other sites
Advertisement
Hello,
I am new to hackintosh. I have High Sierra on bootable memory chip 16GB with the help of TransMac. I get the boot screen with options to boot but on choosing to go ahead the screen goes into verbose mode and then stalls at a certain point. Actually the PC hangs and I cannot use my keyboard to get a screenshot. I do have a photo of it though. What config do I need to change, to be able to install onto a partition of HDD?
My System is :
Mobo: GA-H81M-S (rev 1.0); Nvidia GeForce 710 1GB DDR3 (with VGA, HDMI and DVI-D ports), I have connected my monitor (ASUS VP228H) to the HDMI port; 6GB DDR3 1600Mhz RAM; SSD 120GB with Windows 7 Pro 64-bit; Western Digital 1TB with two partitions (with old Windows 7 Pro 64-bit installation); Western Digital 500GB with two partitions and Windows 10 Pro 32-bit on the first partition. I want to install to the second partition of this HDD.

You will get more help once you post your CLOVER folder minus serials.
Do you have access to a hack or real Mac to create the USB properly and install clover to the USB?
How did you install clover to the USB?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

First of all thank you for your reply. Since I am new to hackintosh I don't know how to post my CLOVER folder minus serials.

No I do not have access to a hack or real Mac.

Clover got installed via the *.dmg file I burned to SD card via TransMac.

Share this post


Link to post
Share on other sites
18 minutes ago, macadventure said:

First of all thank you for your reply. Since I am new to hackintosh I don't know how to post my CLOVER folder minus serials.

No I do not have access to a hack or real Mac.

Clover got installed via the *.dmg file I burned to SD card via TransMac.

What are you using as a boot loader?

Share this post


Link to post
Share on other sites
I think I have Enoch r2848

Unfortunately I don’t know anything about Enoch. Clover boot loader is more widely used for both legacy and UEFI booting.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On choosing to boot in safe mode the PC hangs at System model name: iMac14,2
68AB95A0-4ED4-4339-B7CD-526FB47522C2.thumb.jpeg.a456e561e048495e768642071699f304.jpeg
3DE90EF1-3E52-471F-BDF8-6F2828FC3A6C.thumb.jpeg.c71f9da88314d6de4e99958ea78f0984.jpeg
On choosing the first option the PC reboots automatically

Unfortunately you will not get any support here for a macOS distro. Please install vanilla os with Clover. Once you can figure out how to boot into the os you can download macOS from the App Store and clover bootloader. Then return and you will receive help.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, SavageAUS said:


Unfortunately you will not get any support here for a macOS distro. Please install vanilla os with Clover. Once you can figure out how to boot into the os you can download macOS from the App Store and clover bootloader. Then return and you will receive help.


Sent from my iPhone using Tapatalk

 

I am in India. I managed to order ML from the App Store via my iPad. But it does not give me a link to download the OS since I don't have a mac. Can you or someone you know help me get my OS from the App Store?

 

Share this post


Link to post
Share on other sites
 
I am in India. I managed to order ML from the App Store via my iPad. But it does not give me a link to download the OS since I don't have a mac. Can you or someone you know help me get my OS from the App Store?
 

This is why you need a real Mac or a hack not an iPad or iPhone. You either need to get support elsewhere for your distro or use the forum search on how to get macOS via windows.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
1 minute ago, SavageAUS said:


This is why you need a real Mac or a hack not an iPad or iPhone. You either need to get support elsewhere for your distro or use the forum search on how to get macOS via windows.


Sent from my iPhone using Tapatalk

 

Because I don't have a Mac I am attempting to get a hack. That is why I am here for help. I think you are right about getting help with my distro from the provider. 

Share this post


Link to post
Share on other sites

I managed to get the distro installed after searching. It was a cpu issue. But now after install, I can’t boot into my hac, after code suddenly the screen gives bsod even the the computer is on. So it seems a display setting needs to be done. Is that possible from clover?

Share this post


Link to post
Share on other sites
I managed to get the distro installed after searching. It was a cpu issue. But now after install, I can’t boot into my hac, after code suddenly the screen gives bsod even the the computer is on. So it seems a display setting needs to be done. Is that possible from clover?

So you now have a fresh App Store install? Using clover as the bootloader?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, SavageAUS said:


So you now have a fresh App Store install? Using clover as the bootloader?


Sent from my iPhone using Tapatalk

Yes after install the distro got updated to the next version like from 10.12.3 to 10.12.6 and it does use clover as the bootloader only it does not boot from the hdd but from the usb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By 22eme_arkane
      Hi everyone !
       
       I build a new os on High Sierra and i have problem with my Skarkoon RAID 5 - 5 bay, is unmounting, work fine in windows but not in Mac Os.
      I use a card eSata in chipset Marvell 88SE9215, and i have the kext 3-party eSata  but nothings change.
      I try with the AppleAHCIPort.kext v328, nothings change.
       
      Any solution ?
       
      Thanks a lot !
       
      Config : GA-Z68X-UB3-B3 // BIOS UEFI, Version: U1f //
    • By bummercheese
      I have what's been said to be a natively supported wifi card, but for the life of me I cannot get it working properly with High Sierra. It is detected in DPCIManager but the wifi symbol at the top is hollowed and I can't turn it on.
       
      Here's some basic info about my hackintosh. It's running an i7 9700k with an MSI Z390-A PRO, a GTX 1070, and it's SMBIOS is running as an iMac 18.1

      Someone else has posted here about this with an ac66, which I think is very similar and uses the same device number 43A0. But he didn't get his problem solved in the end. And I have looked up this problem in a million different ways, I haven't found a solution that works from any yet.
       
      I've tried a large amount of different kext patches, kexts (fakepciid, airportbrcmfixup, etc), changing fake ID, modifying kext info.plist files, and every combination of those, none have gotten it to properly work.
       
      I have gotten it to work in one way but it's so unstable that it's unusable. Using the IO80211family.kext from yosemite works, but then it will randomly freeze about 10-15 minutes in, and then it'll not boot 9/10 times, and when it will it'll freeze on the login or right after. It gives errors about out of date kext, only way get back in is by reinstalling. So I figure this method is unusable.
       
      I'm just stumped on why a supposed confirmed working out of box card doesn't just just work, even with every amount of tweaking and adding kexts. I'm in my 4th day of almost nonstop testing and researching on how to fix this, and I'm too stubborn and determined to just buy a different card. Any suggestions would be greatly appreciated. 
    • By gannok
      Hello and thanks for taking the time to read this, I can't seem to get past this screen, I've tried booting in verbose and safe mode to help diagnose the issue, but it keeps looking like the system is rejecting my CPU? am I forgetting something to do in the bootloader menu of clover on the drive? Kernel extensions? or the plist files? I've tried a lot of things. help would be much appreciated.

      Don't have access to download the Mojave installer and try that, but I assume it would be similar to this.

      I have included my EFI boot loader, and the error in hopes that it may help

      System build here

      Z370 Aorus Ultra Gaming Wifi
      i3-8100
      32GB ballistix ddr4
      RX560 4GB

      EFI.zip
    • By crazybirdy
      Patched OSInstaller.framework to allow macOS 10.13 installation on MBR partition.
       
      To use those patched files you must follow HowTo to create an USB installer. You can't just run the app downloaded from Mac App Store.
      The patch is made base on 落下爱@pcbeta 10.10.x MBR patch method, and more patch for 10.13 Firmware check by crazybirdy.
       
      What is this patched OSInstaller doing?
      1. Patch the MBR check, allow macOS 10.13 installation on MBR partition.
      2. Patch the Firmware check, bypass the error of "An error occurred while verifying firmware".
      3. This patched MBR OSInstaller method works with both MBR and GPT partition (GPT+recovery).
      No longer need to set new SMbiosversion, FirmwareFeatures, and FirmwareFeaturesMask with this MBR-patch.
       
      What's the difference between createinstallmedia method, MBR-Manual-Method, and MBR-Automatic-Method?
      As the following....
      1. createinstallmedia method,
          needs stage 1, stage 2 installation process, which is worked with GUID partition only.
      2. MBR-Manual-Method (same as 10.12),
          install via stage 2 manually, which is worked with both MBR and GUID, HFS+ and APFS.
          We can manually format as MBR or GPT, HFS+ or APFS on installation screen like as 10.12.
          We can manually select MBR HFS+ partition to install 10.13 and 10.14 on installation screen now.
          Needn't to update the MBR-Manual-Method files, it will still work on 10.13, and 10.14 future versions, I think so.
          It can be installed as Fresh installation on formated blank partition only, but can't be installed as update from previous version.
      3. MBR-Automatic-Method (new for 10.13+),
          install via stage 2 automatically, which is worked with both MBR and GUID, HFS+ and APFS.
          It can be installed as Fresh installation on formated blank partition, and can be installed as update from previous version.

      How to make 10.13 installer for MBR (MBR-Manual-Method)?
      Just use EasyMBR-InstallerMaker to make installer, it works with both MBR and GPT.
      Read HowTo inside the dmg first, same as 10.12.
      Read HowTo Q/A Q6. How to download the full installer app via swscan.apple.com, instead of App Store?
      Read HowTo Q/A Q7. How to update 10.13.x combo-update to MBR and GPT with installScript directly?

      How to make 10.13 installer for MBR (MBR-Automatic-Method)?
      Just use 13MBRinstallerMaker to make installer, it works with both MBR and GPT.
      Read HowTo inside the dmg first, new for 10.13+.
      Read HowTo Q/A Q6. How to download the full installer app via swscan.apple.com, instead of App Store?
      Read HowTo Q/A Q7. How to update 10.13.x combo-update to MBR and GPT with installScript directly?
       
      And, need a SMBIOS supported with /System/Library/CoreServices/PlatformSupport.plist.
       
       


       
×