Jump to content
jaderyan

Intel HD4000 1536Mb but no acceleration - High Sierra

10 posts in this topic

Recommended Posts

Hello,

 

i know it's an old topic but i still can't find solution, i follwed many tuto on the web.

i build an hackintosh with high sierra 10.13 (17A405), 

i7 3770k , 8gb memory

 

Everything works expect the graphic HD4000 which shows real amount 1536Mb in About this Mac but i have no acceleration (slow animation and flickering).

I put integraphicfix.kext and lilu.kext in EFI/Clover/kexts/others

 

I have HP 17'' monitor which has only vga port so i use an hdmi/vga adaptor.

 

Thank you very much for any help

 

Share this post

redo your clover config under graphics mark/tick intel then try to put this ig platform id one by one 0166000a,0166000b,01620005,then under gui set your screen reoslution to 1280x1024,or 1024x768

Share this post

3 hours ago, jaderyan said:

I put integraphicfix.kext and lilu.kext in EFI/Clover/kexts/others

IntelGraphicFix it's deprecated...

 

Download the last version of WhateverGreen.kext and Lilu.kext, and put it on Clover/folders.

Don't forget to use https://clover-wiki.zetam.org/Configuration/SystemParameters#systemparameters_injectkexts

<key>InjectKexts</key> 
<string>Yes</string>

 

Share this post

Thanks for all your reply.

 

I already use all ig platform for desktop and laptop hd4000, all have the same result except 002 to black screen.

 

I didn't use whatevergreen.Kext because i thought it was for nvidia web drivers. I will try it later. 

 

but for now i change the screen to 1280x800 and the screen is completly illegible as in picture attached. 

 

I don't know how to get the screen back to 1440x900.

20181001_165517.jpg

Share this post

ok i want to try those kexts but i can't access desktop because of the screen illegible as picture below.

 

i don't have recovery partition on boot.

 

don't you a way to restore my resolution to default please

Share this post

  • 3 weeks later...

Hello, I have the same problem with my Intel HD4000 iGPU and its like this:
I have discrete Nvidia GTX750 and also Intel HD4000.
Till now, in BIOS I had only GTX750 enabled. But with mojave webdrivers unsupport I tried HD4000.
I enabled it in BIOS and made it primary.
In clover I injected Intel Graphics with IG platform 0x166000a (and others) and with HDMI Mac recognise my iGPU (pic)
But I have no full acceleration. When I use Launchpad the animation is not smooth and various glitches occure

Can you advise me what I am missing? I tried putting lilu and whatevergreen kexts but it did not help
Thank you

Screenshot 2018-10-23 at 19.32.22.png

Share this post

×