Jump to content

Digital Audio Output (Dolby / DTS) Through HDMI


6 posts in this topic

Recommended Posts

I have a receiver with 7.1 channels, in which I transmit the formats Dolby Digital and DTS without problems by Windows, through the HDMI output of HD4000. On that same Laptop, I have the Hackintosh, with the High Sierra 10.13.6, and with audio enabled using AppleALC, but in the audio preferences, I can not enable the Digital audio format. Also did not find players like Mirillis SplashPro (which I have used in Windows) with the option of HDMI output Bitstream. Is it possible to enable this digital output on Hackintosh?

You can of course enable HDMI audio output if that's what you meant by digital output. The audio contents format (such as Dolby Digital, AC3 or other) is not directly related to the available output interface. That's a matter of software codecs/players, i.e. audio format support. In macOS, you'll 1st select your output interface (eg: speakers, headphones, Bluetooth, HDMI, etc.) and then play your contents with whatever suitable player software.

 

To enable HDMI output out of your HD4000 computer you must apply a binary patch to the Capri framebuffer kext. You'll find details at various places, including this forum or here.

 

Basically, you patch your layout-id (0x0166003 or 0x01660004) to inject HDMI connector-type 0008 0000 to the associated output port that you'll have identified through, say, IOReg. I would suggest you hook-up your HDMI device and post a zipped copy of your Clover config + saved IOReg output (use IORegistryEpxlorer app to that effect)

Edited by Hervé
14 minutes ago, Hervé said:

You can of course enable HDMI audio output if that's what you meant by digital output. The audio contents format (such as Dolby Digital, AC3 or other) is not directly related to the available output interface. That's a matter of software codecs/players, i.e. audio format support.

 

To enable HDMI output out of your HD4000 computer you must apply a binary patch to the Capri framebuffer kext. You'll find details at various places, including this forum or here.

 

Basically, you patch your layout-id (0x0166003 or 0x01660004) to inject HDMI connector-type 0008 0000 to the associated output port that you'll have identified through, say, IOReg. I would suggest you hook-up your HDMI device and post a zipped copy of your Clover config + saved IOReg output (use IORegistryEpxlorer app to that effect)

Thanks for the answer. I already have audio in the output working, my question is in the surround formats. I have some SACD and movies that are in this format, and I can not forward to the Receiver. I've read a few tutorials to add a virtual audio device in MIDI settings, but I still couldn't get it to work. Generally, players with the option "Audio Passtrought ", but even enabling it in Kodi, the receiver only sees as PCM and not as Dolby Digital.

7 hours ago, Hervé said:

It's a matter of players, you'll have to find something that supports your format needs. Tried VLC?

Great news, I just updated Lilu.kext and AppleALC, and tried the players I already use here and the digital sound is being processed by the receiver. I used an old version of AppleALC because it was compiled to work on my Laptop, where I made the corrections to work the Mic and the Line-in. I saw that in one of the changelogs, I had the information "Added digital audio property injection for AMD, Intel, NVIDIA", maybe that helped. Although other players work fine, JRiver still does not send in Dolby, but I'll look at it later. Thank you very much for your attention.

  • 1 year later...

@maiconjs  I know this thread is a couple of years old but I am having a similar issue.  I am on a Gigabyte GA-Z77X-UD5H motherboard which uses ALC898 codec.  Like you, I have no issue playing most dolby surround formats  from windows using VLC but from macOS Catalina, also using VLC, I only have one test file I downloaded from Demolandia that shows on my receiver as DTS-ES Mtrx  but all of my other movies and Dolby test files just show PCM.

 

(On a sidenote, VLC channel mappings are screwed up in macOS.  Instead of 1,2,3,4,5,6,7,8 they need to be reordered in Audio Midi Utility to 1,2,5,6,7,8,3,4 but this of course screws up other correctly mapped apps that might use the surround channels).

 

My AppleALC and Lilu are completely up to date.  What player do you use?  The majority of the movies I download are .mkv so I think VLC is still my best option unless you know another.  I have Dolby as the output in advanced settings and also Force Dolby Detection but still just PCM on the receiver.  To my ears, it does sound like Dolby surround but its not showing on my very expensive receiver.

×
×
  • Create New...