Jump to content

maiconjs

Members
  • Content count

    32
  • Joined

  • Last visited

About maiconjs

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. maiconjs

    Alternatives to Dolby Audio for MacOS

    Thanks for the answer ! Yes, on my two devices I use AppleALC + Lilu, where layouts have been edited by me for proper connectorization. I already used the application mentioned a while back, and I did not like the results. On Windows, I use the Dolby Home Theater V4, which in addition to making improvements in audio, transmits in Dolby Digital format instead of PCM format.
  2. One of the reasons for which I do not leave Windows, is to have Dolby audio, which is an advanced audio processing engine, which brings incredible improvements to my sound system. I searched to find something close on MacOS, and the only thing I found was the Boom audio, which already by name, makes the audio well explosive, distorted and worsening quality compared to the system without the application. Is there any other application capable of bringing audio enhancements to MacOS?
  3. maiconjs

    AppleALC — dynamic AppleHDA patching

    I tested this kext in layout13 and the Mic and Line-in is not working. In this kext generated another problem too, the internalspeaker is not working. In the file that was edited by me, the internal speaker is working.
  4. maiconjs

    AppleALC — dynamic AppleHDA patching

    Thanks for the reply I tried the layouts present in AppleALC and they don't work well for that codec, so im working for a solution. The posted files have codec_dump.txt in the codecgraph folder.
  5. maiconjs

    AppleALC — dynamic AppleHDA patching

    @insanelyDeepak, @MacPeet, @jaymonkey Can you help me? It is not necessary to compile the Kext, just tell where to look for is correcting these codecs.
  6. maiconjs

    AppleALC — dynamic AppleHDA patching

    I'm trying to add 2 new codecs, however I'm having difficulties, and I hope they can help me. The first codec is CS4213, which made several changes in platforms.xml and layout, and I could not get audio. In ioreg I see that the alc-layout-id has been injected, however in the system report does not display the audio device. The other codec is the CX20751 / 2, which runs the audio normally through the internalspeaker and the p2 connector, but the Line-in and Microphone does not work. When extracting the verbs by verbit, I receive the warnings: Codec: Conexant CX20751 / 2 Node 0x13: Amp-In vals count is wrong: values found: 3. expected: 1 Node 0x14: Amp-In vals count is wrong: values found: 3. expected: 1 I ask community help to fix these two codecs. Files ALC CS4213 and debug.zip Files ALC CX20751_2.zip
  7. maiconjs

    XCPM not working properly on I5-3210m

    Thanks again for your answers @Hervé. I've tried setting it up this way, and I keep getting the failed. And I agree with @TheRacerMaster, the flag "-XCPM " has no effect on 10.13 +. The curious, is that these failures only present with the plugin-type.
  8. I'm trying to activate the XCPM in the i5-3210m using CPUFriend.kext, with the vector data of MacBookAir6,1, but when generate a SSDT with the plugin-type, I see that the startup log displays the messages: 2018-08-17 08:39:10.814893-0300 0x212 Default 0x0 0 0 kernel: (IOPlatformPluginFamily) IOPPF - Found another boot volume. 2018-08-17 08:39:10.814896-0300 0x212 Default 0x0 0 0 kernel: (IOPlatformPluginFamily) IOPPF - Found another boot volume. 2018-08-17 08:39:10.819735-0300 0x212 Default 0x0 0 0 kernel: (IOPlatformPluginFamily) X86PlatformPlugin::setRingTable - AICPM failed to load ring table with status 0x0: Get=0, Load=0, Install=0 2018-08-17 08:39:10.819738-0300 0x212 Default 0x0 0 0 kernel: (IOPlatformPluginFamily) X86PlatformPlugin::setRingTable - AICPM failed to load ring table with status 0x0: Get=0, Load=0, Install=0 2018-08-17 08:39:10.826168-0300 0x212 Default 0x0 0 0 kernel: (IOPlatformPluginFamily) X86PlatformPlugin::configResourceHandler - Failed to set ring table! 2018-08-17 08:39:10.826170-0300 0x212 Default 0x0 0 0 kernel: (IOPlatformPluginFamily) X86PlatformPlugin::configResourceHandler - Failed to set ring table! 2018-08-17 08:39:10.839388-0300 0x62a Default 0x0 0 0 kernel: (IOPlatformPluginFamily) IOPPF: XCPM mode 2018-08-17 08:39:10.839390-0300 0x62a Default 0x0 0 0 kernel: (IOPlatformPluginFamily) IOPPF: XCPM mode After the boot, I see that the vectors were loaded through the commands: MacBook-Air-de-Maicon: ~ Maiconsantos $ sysctl-n machdep. xcpm. Vectors_loaded_count 1 MacBook-Air-de-Maicon: ~ Maiconsantos $ sysctl-n machdep. xcpm. Mode 1 I already own MSR 0xE2 unlocked, and is enabled KernelXCPM on clover at KextsToPatch. Should I ignore the warnings of boot-args, or can there be a problem with the XCPM? If that's the problem, how can I be solving this? Attached, it has a copy of Ioreg, SSDT and the full log. Files.zip
  9. maiconjs

    AppleALC — dynamic AppleHDA patching

    Hello @vit9696 and @vandroiy2012 I made the correction for the Asus A45A and K45 laptop. Could you please add the new id 45 layout to the ALC269VB1. The settings are: Outputs: Integrated Internal and HP with Switch Input´s: Internal Mic, Line in (Fixed to Work) Thx Files Fixed ALC269 Asus A45 and K45.zip
  10. Great news, I just updated Lilu.kext and AppleALC, and tried the players I already use here and the digital sound is being processed by the receiver. I used an old version of AppleALC because it was compiled to work on my Laptop, where I made the corrections to work the Mic and the Line-in. I saw that in one of the changelogs, I had the information "Added digital audio property injection for AMD, Intel, NVIDIA", maybe that helped. Although other players work fine, JRiver still does not send in Dolby, but I'll look at it later. Thank you very much for your attention.
  11. Thanks for the answer. I already have audio in the output working, my question is in the surround formats. I have some SACD and movies that are in this format, and I can not forward to the Receiver. I've read a few tutorials to add a virtual audio device in MIDI settings, but I still couldn't get it to work. Generally, players with the option "Audio Passtrought ", but even enabling it in Kodi, the receiver only sees as PCM and not as Dolby Digital.
  12. I have a receiver with 7.1 channels, in which I transmit the formats Dolby Digital and DTS without problems by Windows, through the HDMI output of HD4000. On that same Laptop, I have the Hackintosh, with the High Sierra 10.13.6, and with audio enabled using AppleALC, but in the audio preferences, I can not enable the Digital audio format. Also did not find players like Mirillis SplashPro (which I have used in Windows) with the option of HDMI output Bitstream. Is it possible to enable this digital output on Hackintosh?
  13. maiconjs

    AppleALC — dynamic AppleHDA patching

    I made a compilation of my own, to make working a mic on an ALC 269 codec, on a Asus A45A laptop. I copied the Layout-ID and Platforms files that are functional in the patched AppleHDA, and pasted into the/Resource/ALC269 directory, with the Laytout45 and Platforms45. I made the due changes in the Info. plist files and in the PinConfigs. Kext, and I performed the build. I installed the Kext, however I receive the following errors: kernel: kxld[as.vit9696.AppleALC]: The following symbols are unresolved for this kext: kernel: kxld[as.vit9696.AppleALC]: __ZN13KernelPatcher13routeMultipleEmPNS_12RouteRequestEmymbb kernel: kxld[as.vit9696.AppleALC]: __ZN6WIOKit12renameDeviceEP15IORegistryEntryPKcb kernel: kxld[as.vit9696.AppleALC]: __ZN7LiluAPI20onEntitlementRequestEPFvPvP4taskPKcRP8OSObjectES0_ kernel: Can't load kext as.vit9696.AppleALC - link failed. kernel: Failed to load executable for kext as.vit9696.AppleALC. kernel: Kext as.vit9696.AppleALC failed to load (0xdc008016). kernel: Failed to load kext as.vit9696.AppleALC (error 0xdc008016). Can anyone help?
  14. Update A few months ago, I identified the problem that was in the BIOS, specifically in the Intel ME region. The Intel Managment Engine driver was not loaded into Windows due to a BIOS issue. This guide coming from the Win-Raid forum helped me with the solution of the problem: https://goo.gl/nE1CHW It is necessary to have a programmer device to make the modifications in the BIOS. I used the Skypro, but some people use Arduino to program the BIOS chip. I thank @Hervé very much for his dedication to solving my problem.
×