Jump to content
Sign in to follow this  
Followers 0
darkbluecode

[Guide] Install Mac os High Sierra on Asus ROG GL553VD

27 posts in this topic

Recommended Posts

Overview
Hi . i was working hard for full use this laptop on mac .
It's so easy but you most install mac os high sierra for use my file .

Hardware Specs
Intel i7-7700HQ CPU
Intel HD Graphics 630 / nVidia GTX 1050 Ti (the nVidia card is disabled due to its Optimus configuration)
12GB 2400MHz DDR4 RAM
15.6” 1080p matte display
128GB SSD
1TB 7200RPM HDD

Intel AC 7265 Wireless card:
  • You WILL need to replace this to get wireless functionality! or use usb wifi

What’s Working:
  • cpu
  • intel gpu
  • touch pad
  • brightness
  • usb
  • speker with out noise and so loud
  • battery* number in setting fake ( 100 = 97 or 96 - i used HWMonitor for show true number )
  • keyboard
  • lan
  • fn only for sound
  • hdmi
  • NVIDIA Chip Model ( only for see necessary for work hdmi )




Step 1 : how can i install ???

you most block gtx1050m 
but how ?
you most use my clover file.
--------------------------------------------
Step 2 : after install i have so bad graphic 
you most install kext ( IntelGraphicsFixup.kext and Lilu.kext ) in s/l/e with kext unity .
-------------------------------------------------------------------------------------------------------

Step 3 : i haven't audio  
you should install kext ( AppleALC.kext and CodecCommander.kext ) in l/e
--------------------------------------------------------------------------------------------------------
Step 4: how can i use touch pad ??
for install touch pad i use dsdt patch (Elan 1200) and voodooi2c 
  • one !!! you most remove kext (AppleIntelLpssL2C.kext and AppleIntelLpssI2CController.kext )
  • you most install kext ( VoodooI2C.kext and VoodooI2CHID.kext ) in s/l/e
but after install kexts touch pad doesn't worked ??
you most use my clover file in clover file i inserted dsdt patch for i2c elan 1200
-------------------------------------------------------------------------------------------------------

       Step 5 : tell about the battery ?
       install kext (ACPIBatteryManager.kext) in s/l/e

--------------------------------------------------------------------------------------------------------
Step 6 : i can't control Backlight ?
install kext (AppleBacklightInjector.kext) in l/e
-------------------------------------------------------------------------------------------------------

Step 7 : but other item ??
 for other item only use my clover file in EFI partition .

-----------------------------------------------------------------------------------------------------------------

for temp i installed HWMonitor.dmg ( kext install in l/e )

after all Steps open terminal in use code (sudo kextcache -i /)

***** for install kext in s/l/e you most use kext unity *****

for Backlight fn key go to the setting - keyboard - shortcuts - display and set f5 and f6 )

------------------------------------------------------------------------
New step ! = hdmi 
for use hdmi port we most use Nvidia but how ?? ( use HDMI zip file ) 
not really work that chip . 

  • install NvidiaGraphicsFixup.kext on s/l/e 
  • copy NvidiaGraphicsFixup.kext on EFI/CLOVER/kexts/Other 
  • remove old config.plist on EFI/CLOVER/ and replace with new config.plist file 
  • remove SSDT-DiscreteSpoof on EFI/CLOVER/ACPI/patched
  • install WebDriver-387.10.10.10.35.106 ( link )
  • now reboot your mac os !!

CLOVER.zip

kexts.zip

HDMI.zip

Edited by darkbluecode

Share this post


Link to post
Share on other sites
Advertisement

HI 

the guide doesn't complete ! please help me to complete this guide. 

Problems ::: 

1 : buttery number fake ( IMG )

2 : Nvidia chip ( doesn't  M model !!! please watch IMG )

3  Internal Microphone 

4 : find cpu fan by system 

5 : cpu temp ( base 50 degrees centigrade ) !

6 : buttery work only for 2H or 3H ! and so fast use by system 

7 : control keyboard backlit ( asus aura ) 

8 : tern off bluetooth ( please watch IMG )

 

Screen Shot 1397-04-08 at 13.13.06.png

Screen Shot 1397-04-08 at 14.48.18.png

Screen Shot 1397-04-08 at 14.47.33.png

Edited by darkbluecode

Share this post


Link to post
Share on other sites

@MaLd0n

HI 

i'm using DGPU patch after use this patch my fan speed go to max !!! but my battery work fixing and my battery work for 5 H and cpu power working fixing . 

how can i fix fan speed ?

with out patch.zip

-----------------------------------

with patch 

debug_15987.zip

SSDT-DGPU.aml

3n65_untitled.png

Share this post


Link to post
Share on other sites
20 minutes ago, MaLd0n said:

stay with ur usb stick for rescue if fail

CLOVER.zip

thank you 

work ( on usb boot)

but battery number fake !! ( system tell 100 % but in really 97 % ) 

and cpu doesn't  fixed - SSDT-DGPU.aml fix cpu using but fan speed go to max !!! now my battery work doesn't  changed because  only work for 2H 

and cpu doesn't  good work and eat many power ( W )

-----------------------------------

in img we can see so good work cpu and eat small power 

image.png.d724eb79da8679e1dccebd1f9457356f.pngimageproxy.php?img=&key=c17464ef1b1b51c7

Screen Shot 1397-04-08 at 23.07.56.png

Screen Shot 1397-04-08 at 23.08.16.png

Screen Shot 1397-04-08 at 23.07.41.png

Edited by darkbluecode

Share this post


Link to post
Share on other sites

 

8 hours ago, MaLd0n said:

test 2

CLOVER.zip

remove NULLCPUPM kext

u need a voodootscsync?

hi .

cpu doesn't fixed

in L/E i think for system kexts because i'm not install it 

and system can't find fan speed :(:( 

MR when use DGPU patch cpu very good work but speed fan doesn't control by system why ? 

 

 

VoodooTSCSync.kext.zip

Screen Shot 1397-04-09 at 08.56.14.png

Edited by darkbluecode

Share this post


Link to post
Share on other sites
1 hour ago, darkbluecode said:

 

hi .

cpu doesn't fixed

in L/E i think for system kexts because i'm not install it 

and system can't find fan speed :(:( 

MR when use DGPU patch cpu very good work but speed fan doesn't control by system why ? 

 

 

VoodooTSCSync.kext.zip

Screen Shot 1397-04-09 at 08.56.14.png

CPU u need read WHP, in comments have all solutions, is a common bug

Share this post


Link to post
Share on other sites
58 minutes ago, MaLd0n said:

CPU u need read WHP, in comments have all solutions, is a common bug

but how ? i read guide but i can't understand do :(:(

now only work for 20M on battery

---------------------------------

:shock::shock:

1139169185_ScreenShot1397-04-09at11_09_13.png.5688c9aad4af90e5bbe6a0ce6ba69025.png

 

cpulog.rtf

Edited by darkbluecode

Share this post


Link to post
Share on other sites

It's so amazing !

Bois sys battery level is 97 !

But system 59 

And monitor app says 57

 

1669346983_IMG_20180630_111559.thumb.jpg.ce126f00aa8418994f39f62ed89800fdcopy.jpg.d3659b66c98a66a5078e31ecabc37fdc.jpg

IMG_20180630_111425.jpg

Edited by darkbluecode

Share this post


Link to post
Share on other sites

HI .

@MaLd0n

thank you man. now system boot so fast 

problem :

buttery number and battery about by system ! buttery using by system ( now only work for 20M )

cpu power using on battery ( cpu battery mode doesn't on )

-----------------------

new log file .

and i get cpu log for work HWP modecpulog.rtf

MR most i uninstall   voodootscsync on L/E ?

 

Send me darks-MacBook-Pro.zip

Edited by darkbluecode

Share this post


Link to post
Share on other sites

 

@MaLd0n

I was work on buttery number and to how can i patch it . when i go to the safe mode i sew battery number is true and i start to get aspi patch on safe mode . !!

after went to the normal boot i test it and it was work very goooood !!!! the number = boise number but i have one problem my patch convert to many patch file !!! can you convert to one and optimize ?? ( make one DSDT file )

my laptop has 2 hard = 1 ssd ( m.2) and hhd 1t 7200 my mac installed on ssd but in mac i sew hhd work !!! and  it have so hot temp (40 c ) how can i off hard for when i haven't work with hdd file . 

 

clover.zip

Share this post


Link to post
Share on other sites
4 minutes ago, MaLd0n said:

is a same notebook?

use files edited above ;)

yes but this is  now file and this file fix buttery number !! the buttery number in up file is not true 

Edited by darkbluecode

Share this post


Link to post
Share on other sites
On 6/30/2018 at 12:15 AM, MaLd0n said:

test 2

CLOVER.zip

remove NULLCPUPM kext

u need a voodootscsync?

HI . 

when i use this battery data fake ! for example buttery health  and battery work for 15 Mint  !! and power using 120 w to 250 W !!!!

microphone doesn't work .

fan doesn't find by system .

 

Share this post


Link to post
Share on other sites
On 6/30/2018 at 12:15 AM, MaLd0n said:

test 2

CLOVER.zip

remove NULLCPUPM kext

u need a voodootscsync?

Hi .

i check full your . it's so good because pci show device !! and system V go to down ( 10 V or 9 V ) using  but battery data so false ( battery number ( 100 = 10 % !! ) , buttery health )  . in my original patch is true . please fix it and i check HWP mode !! it's so bad because use so many power ( W ) 120 W to 140 W !! please remove that on patch and clover config . 

thank you

Share this post


Link to post
Share on other sites
On 7/16/2018 at 1:30 PM, jonee316 said:

I got asus fx553vd but the same motherboard as gl553vd.

 

Can I ask how the clover + installer was made?

 

Thanks a lot! Sorry I am just new here

yes . not same . it's this . gl553vd=fx553vd = g553v = zx53 ....

Share this post


Link to post
Share on other sites
On 6/29/2018 at 11:28 AM, darkbluecode said:
Overview
Hi . i was working hard for full use this laptop on mac .
It's so easy but you most install mac os high sierra for use my file .

Hardware Specs
Intel i7-7700HQ CPU
Intel HD Graphics 630 / nVidia GTX 1050 Ti (the nVidia card is disabled due to its Optimus configuration)
12GB 2400MHz DDR4 RAM
15.6” 1080p matte display
128GB SSD
1TB 7200RPM HDD

Intel AC 7265 Wireless card:
  • You WILL need to replace this to get wireless functionality! or use usb wifi

What’s Working:
  • cpu
  • intel gpu
  • touch pad
  • brightness
  • usb
  • speker with out noise and so loud
  • battery* number in setting fake ( 100 = 97 or 96 - i used HWMonitor for show true number )
  • keyboard
  • lan
  • fn only for sound
  • hdmi
  • NVIDIA Chip Model ( only for see necessary for work hdmi )




Step 1 : how can i install ???

you most block gtx1050m 
but how ?
you most use my clover file.
--------------------------------------------
Step 2 : after install i have so bad graphic 
you most install kext ( IntelGraphicsFixup.kext and Lilu.kext ) in s/l/e with kext unity .
-------------------------------------------------------------------------------------------------------

Step 3 : i haven't audio  
you should install kext ( AppleALC.kext and CodecCommander.kext ) in l/e
--------------------------------------------------------------------------------------------------------
Step 4: how can i use touch pad ??
for install touch pad i use dsdt patch (Elan 1200) and voodooi2c 
  • one !!! you most remove kext (AppleIntelLpssL2C.kext and AppleIntelLpssI2CController.kext )
  • you most install kext ( VoodooI2C.kext and VoodooI2CHID.kext ) in s/l/e
but after install kexts touch pad doesn't worked ??
you most use my clover file in clover file i inserted dsdt patch for i2c elan 1200
-------------------------------------------------------------------------------------------------------

       Step 5 : tell about the battery ?
       install kext (ACPIBatteryManager.kext) in s/l/e

--------------------------------------------------------------------------------------------------------
Step 6 : i can't control Backlight ?
install kext (AppleBacklightInjector.kext) in l/e
-------------------------------------------------------------------------------------------------------

Step 7 : but other item ??
 for other item only use my clover file in EFI partition .

-----------------------------------------------------------------------------------------------------------------

for temp i installed HWMonitor.dmg ( kext install in l/e )

after all Steps open terminal in use code (sudo kextcache -i /)

***** for install kext in s/l/e you most use kext unity *****

for Backlight fn key go to the setting - keyboard - shortcuts - display and set f5 and f6 )

------------------------------------------------------------------------
New step ! = hdmi 
for use hdmi port we most use Nvidia but how ?? ( use HDMI zip file ) 
not really work that chip . 

  • install NvidiaGraphicsFixup.kext on s/l/e 
  • copy NvidiaGraphicsFixup.kext on EFI/CLOVER/kexts/Other 
  • remove old config.plist on EFI/CLOVER/ and replace with new config.plist file 
  • remove SSDT-DiscreteSpoof on EFI/CLOVER/ACPI/patched
  • install WebDriver-387.10.10.10.35.106 ( link )
  • now reboot your mac os !!

CLOVER.zip

kexts.zip

HDMI.zip

Can you post all the necessary file for installation ? the links is not working anymore. Or can you just give me the config.plist ?

Share this post


Link to post
Share on other sites

I find a more comprehensive guide than this one also DSDT file in that guide is builded with an outdated bios so who ever has that device 

https://gitee.com/QiuChen_863/ASUS_FX53VD_10.13.1EFI

use that clover after you boot open the terminal and type

sudo kextcache -i /

then reboot only thing that is not work after after adding 8.9.3 Patch 1 AppleALC and its layout id (You need to enter that id after you open your config.plist with Clover Configurator  Devices / Properties /Properties value correct id is 0F000000 ) most of the fn buttons not working but internal microphone or anything else works fine also that guide has no dsdt in it so you can use it with any bios. goodluck  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×