Jump to content
bluenote56

HP 15bs059nl High Sierra

30 posts in this topic

Recommended Posts

Salve, grazie  a guide e consigli della parte in lingua inglese del sito sono riuscito ad installare High Sierra sul laptop HP che appare anche in firma.

Ho però un problema principale abbastanza sgradevole. Non riesco a fare il boot da pc (boot0Af error)ma solo da penna usb, malgrado abbia installato Clover come indicato.

Premetto che su clover sono fortemente ignorante visto che ho sempre usato Enoch. Credo che il fatto di avere un hd da 1 tb con 4096  sectors invece di 512 possa essere importante (partizione guid 500 gb win- 500 gb mac), ma sinceramente brancolo nel buio. Vorrei evitare di ricominciare tutto da capo rischiando di fare un buco nell'acqua perchè sbaglio. Mi date cortesemente qualche indicazione o suggerimento? Grazie mille

Share this post


Link to post
Share on other sites
Advertisement

Clover può essere installato in vari modi; per UEFI, Legacy nella ESP o Legacy nella root.

"malgrado abbia installato Clover come indicato" non indica cosa tu abbia fatto.

Share this post


Link to post
Share on other sites
2 minutes ago, Jolly said:

Clover può essere installato in vari modi; per UEFI, Legacy nella ESP o Legacy nella root.

"malgrado abbia installato Clover come indicato" non indica cosa tu abbia fatto.

Giustamente, colpa mia, ho provato prima EFI, poi ho raso tutto al suolo e installato nella ESP. 

Share this post


Link to post
Share on other sites

Scherzavo nei termini.. ho riformattato tutto e fatto installazione ex novo

 

Share this post


Link to post
Share on other sites

Ricapitolando, ho provato varie volte ad installare il sistema operativo e Clover. Non riesco a fare il boot da hd senza l' errore indicato. Dove sbaglio? Non essendo pratico con Clover non ho idea di dove mettere le mani. Su gli altri desktop su cui ho installato High Sierra non ho avuto problemi. Prima di procedere ad ottimizzare il tutto (audio, luminosità, ecc..) è cruciale che riesca a risolvere questo errore. Mi potete dare un' indicazione su come procedere gentilmente? se serve potrei fare un upload di quello che serve. Grazie mille.

Share this post


Link to post
Share on other sites

L'errore boot0Af error...avviene in legacy, quindi visto che il portatile lo supporta dovresti installare clover in UEFI

Se invece vuoi usare legacy puoi selezionare boot0ss al posto di booo0af mentre installi clover

Segui la mia guida in firma anche se è per creare la usb per installare, le impostazioni per installare Clover in UEFI oppure in Legacy rimangono invariate sia per la usb, sia per il disco

Share this post


Link to post
Share on other sites
3 hours ago, gengik84 said:

L'errore boot0Af error...avviene in legacy, quindi visto che il portatile lo supporta dovresti installare clover in UEFI

Se invece vuoi usare legacy puoi selezionare boot0ss al posto di booo0af mentre installi clover

Segui la mia guida in firma anche se è per creare la usb per installare, le impostazioni per installare Clover in UEFI oppure in Legacy rimangono invariate sia per la usb, sia per il disco

Grazie innanzitutto per l'aiuto. Poi.. devo dire che mi sento un pò incapace. Ho provato ad installare piu' volte Clover esattamente con il settaggio solo uefi e non mi installa nulla nella partizione efi ma direttamente sull' hd. ??? Ho provato anche a fare l' installazione legacy con boot0ss e se provo mi da errore boot0ss....vorrei solo evitare di reinstallare tutto da capo anche perchè mi sembra illogico. Sto sbagliando qualcosa io altrimenti dovrebbe funzionare.  Ti allego una slide di quello che succede dopo l'ennesima installazione solo uefi. 

Schermata 2018-03-24 alle 12.34.06.png

Share this post


Link to post
Share on other sites
6 hours ago, gengik84 said:

Per installare nella partizione EFI devi selezionare installa nella ESP altrimenti installa nella root del disco

 

E' quello che ho fatto... stanotte proverò  ad installare ex novo dopo aver fatto un back up Time machine.. voglio capire che cosa impedisce di installare Clover correttamente. Solo per curiosità il fatto che l' hd abbia quelle caratteristiche (4096 byte sectors) non has nulla a che vedere con l' errore boot0?

Edited by bluenote56

Share this post


Link to post
Share on other sites

Fai prima la prova a installare clover in uefi su una usb, successivamente aggiungi i tuoi kext, sostituisci il config etc

Bios impostato per effettuare il boot uefi.

Se riesci a fare il boot a quel punto ti basta montare la partizione efi del disco, copiare e sostituire la efi con quella funzionante della usb

Se hai una cartella efi nella root del disco questa deve essere cancellata come se vi fosse un file boot, stessa cosa se questo è presente nella efi

il boot esterno alla cartella efi è presente solo per avvio legacy

Share this post


Link to post
Share on other sites
9 hours ago, gengik84 said:

Fai prima la prova a installare clover in uefi su una usb, successivamente aggiungi i tuoi kext, sostituisci il config etc

Bios impostato per effettuare il boot uefi.

Se riesci a fare il boot a quel punto ti basta montare la partizione efi del disco, copiare e sostituire la efi con quella funzionante della usb

Se hai una cartella efi nella root del disco questa deve essere cancellata come se vi fosse un file boot, stessa cosa se questo è presente nella efi

il boot esterno alla cartella efi è presente solo per avvio legacy

Evvai.. ho seguito il tuo consiglio e adesso funziona. Unica cosa ho dovuto cancellare anche la cartella Microsoft che era nella EFI e adesso ho perso almeno momentaneamente la possibilità di far partire la partizione Winzozz. Magari poi un consiglio su come recuperare o installare nuovamente senza rovinare il boot High Sierra sarebbe graditissimo.

Ora quindi funziona credo tutto tranne ovviamente: scheda Radeon, bluetooth wifi originali. Devo ottimizzare il controllo luminosità perchè malgrado l' AppleBacklightInjector.kext e NativeDisplayBrightness App i tasti funzionano ma non succede niente. Per l'audio ho usato Pandora e Mirone ma è bassissimo. Mi piacerebbe magari sapere se la dsdt ha errori ed ottimizzarla se fosse possibile. Per il momento davvero grazie.

Share this post


Link to post
Share on other sites

Per windows in dual boot segui la guida di Netgear

Per l'audio usa AppleALC...conosci il tuo codec audio?

Per il BT e wifi bisogna vedere cosa monta e nel caso se è compatibile

vai nella mia guida, segui il post 2 e posta l'occorrente, compreso la tua attuale EFI

Share this post


Link to post
Share on other sites
19 minutes ago, gengik84 said:

Per windows in dual boot segui la guida di Netgear

Per l'audio usa AppleALC...conosci il tuo codec audio?

Per il BT e wifi bisogna vedere cosa monta e nel caso se è compatibile

vai nella mia guida, segui il post 2 e posta l'occorrente, compreso la tua attuale EFI

Visto che è Intel combo bluetooth/wifi credo proprio non sia compatibile. Hack Info mi ha dato errore, spero vada bene lo stesso. Dato che non riesco da tempo a fare upload diretto causa errore -200, presumo per il restyling del sito, posto anche un link con tutto tramite runme se fosse necessario. Per l'audio credo sia 292 l'ALC sulla scheda info dell' HP non c'è una specifica. Dopo aver ottimizzato High Sierra mi vedo la guida come dici per installazione win. Non so che dire a parte grazie. L'EFI non la posso caricare zippata è 36 mega.

http://www109.zippyshare.com/v/gnFZ7VuX/file.html

MacBook Pro di HARRY.zip

HackInfo_Report.zip

Schermata 2018-03-25 alle 09.50.53.zip

Schermata 2018-03-25 alle 09.51.01.zip

Edited by bluenote56

Share this post


Link to post
Share on other sites

L'errore è relativo a bdmesg...ma tutto normale perché non hai installato direttamente clover

Guardo il tutto, per il wifi, si essendo intel non è compatibile, dovresti sostituirlo

Share this post


Link to post
Share on other sites

Alla gui di clover, premi F4, attendi 20 secondi circa e poi avvia

Controlla che in efi/clover/acpi/origin ci siano delle tabelle acpi

allega la cartella origin

Share this post


Link to post
Share on other sites
25 minutes ago, gengik84 said:

Alla gui di clover, premi F4, attendi 20 secondi circa e poi avvia

Controlla che in efi/clover/acpi/origin ci siano delle tabelle acpi

allega la cartella origin

fatto

origin.zip

Share this post


Link to post
Share on other sites

Elimina aDummy da S/L/E, oppure ripristina AppleHDA originale...questo dipende dal metodo di Mirone utilizzato

sostituisci la cartella Clover

ricostruisci la cache

Riavvia, se non hai problemi al boot, controlla il tutto...fai ioreg e postalo

Edit: credo tu abbia proprio installato un AppleHDA patchato, quindi reinstalla l'originale

Da S/L/E elimina ACPIBatterymanager.kext... perché è già presente nella EFI...non tenere kext doppi

Share this post


Link to post
Share on other sites
35 minutes ago, gengik84 said:

Elimina aDummy da S/L/E, oppure ripristina AppleHDA originale...questo dipende dal metodo di Mirone utilizzato

sostituisci la cartella Clover

ricostruisci la cache

Riavvia, se non hai problemi al boot, controlla il tutto...fai ioreg e postalo

Edit: credo tu abbia proprio installato un AppleHDA patchato, quindi reinstalla l'originale

Da S/L/E elimina ACPIBatterymanager.kext... perché è già presente nella EFI...non tenere kext doppi

Per il momento è fantastico. Apparso il controllo su Monitor, bella definizione. Sostituito audio e fatto tutto quello che hai consigliato. Ecco il file. Sarà l'entusiasmo ma sembra che vada meglio.

MacBook Pro di HARRY.zip

Share this post


Link to post
Share on other sites
1 hour ago, gengik84 said:

L'audio tutto ok?

si tutto ok.. sinceramente non so come avrei fatto senza aiuto. Ora tranne accidenti imprevisti sembra una macchina perfetta. Devo provare la velocità delle usb ma sinceramente me ne frega poco se non dovessero andare a 2000. Io uso il laptop per piacere e per lavoro .. con calma vedrò di sistemare la parte win solo perchè "devo" usare certi programmi ma sono felice come un ragazzino.  Ho sempre usato Enoch e con Clover mi muovo come un elefante in una cristalleria. Davvero ancora una volta thank you. Ti aggiornerò su tutto comunque. Grande successo. Spesa per il laptop in offerta sotto i 600 euro nuovo compresa estensione garanzia 3 anni. Che voglio di più dalla vita? Una lucana (possibilmente carina). Scherzi a parte va benissimo. 

Share this post


Link to post
Share on other sites

Fatti un backup dell'attuale efi, per reinstallare ti basta copiarla su una usb..ed una volta fatto avrai già tutto configurato

Se alle volte tu volessi cambiare il wifi interno ti consiglio Broadcom BCM943602BAED

wifi nativo + Bluetooth

Share this post


Link to post
Share on other sites
1 hour ago, gengik84 said:

Fatti un backup dell'attuale efi, per reinstallare ti basta copiarla su una usb..ed una volta fatto avrai già tutto configurato

Se alle volte tu volessi cambiare il wifi interno ti consiglio Broadcom BCM943602BAED

wifi nativo + Bluetooth

E' sorto un piccolo problema solo relativo a win. Visto che avevo un backup ho reinstallato ed ovviamente l'installer ha messo la cartella Microsoft nella efi. Peccato che da bios non mi faccia scegliere tra windows boot manager e clover tra le opzioni relative del boot. Per farlo devo spingere f9 al boot e poi scegliere/ efi/ clover/ ecc-- tutte le volte altrimenti parte direttamente da win. Una bella palla. Anche stavolta sto facendo qualche scemenza? 

Share this post


Link to post
Share on other sites

Prova a guardare qui https://www.insanelymac.com/forum/forums/topic/317725-tripledualquad-boot-uefi-custom-entries/

Nel caso chiedi a Netgear che sicuramente ti aiuterà

Intanto potresti seguire qui ed aggiungere manualmente la voce di clover nei dispositivi di boot e successivamente provare  far bootare windows tramite clover

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×