Jump to content
Sign in to follow this  
Followers 0
unexpectedsense

Sin Audio en Sierra 10.12 - ZOTAC Nano ID61

4 posts in this topic

Recommended Posts

Estimados desde ya muchas gracias por cualquier aporte que puedan hacerme para intentar solucionar en este caso el AUDIO HDMI y si fuera posible las frontales de micrófono y auriculares.
Tengo corriendo Mac OS Sierra 10.12 en una ZOTAC NANO ID61 y va muy bien en el desempeño general y los gráficos aunque el video algo ralentizado.
La instalación inicialmente arrancó (siempre en SAFE MODE y hasta ahora mismo, de otra forma queda en la manzana eterna) sin red (el bluetooth funciona perfecto) y sin audio.
Em el caso de la red pude hacer funcionar la ethernet con la kext RealtekRTL8111.kext pero no directamente sino a través del paquete HoRNDIS-rel8.pkg.
Para el caso del wifi el DPCIManager me muestra Centrino Wireless-N 130 integrada que no he podido hacer funcionar pero no es prioridad ahora mismo puesto que tengo red.

Los datos de manual y algo mas son:

ZOTAC ZBOX nano ID61

Bios
• American Megatrends - Core Versión 4.6.4.0 - UEFI 2,1
Chipset
• Intel HM65
Onboard CPU
• Intel ® Celeron ® CPU 867 @1,30GHz
Onboard graphics
• Intel HD Graphics Family
• HDMI & DP output
Memory
• 8 GB SO-DIMMs DDR3-1333
Storage
• SATA 320 Gb
Network
• Gigabit (10/100/1000Mbps) LAN
• IEEE 802.3 compatible
WiFi/Bluetooth support
• Compliant with IEEE802.11b/g/n standard
• High speed wireless connection up to 150 Mbps • Fully qualited Bluetooth v3.0
Audio
• 2-channel high-definition audio • Jack-sensing compatible
• Optical SPDIF
Operating System support
• 32-bit and 64-bit support
IR receiver
• Support carrier frequencies 36k Hz


NOTA: En la Bios / Chipset /OnBoard Device Configuration, hay un item AZALIA con un sub item AZALIA INTERNAL HDMI CODEC que probé habilitado y desabilitado. Si lo desabilito desaparece en el DPCIManager. Habilitado aparece pero no el Codec ID.
* Por otro lado hay un item de la Bios /Advanced que es Sandybridge PPM Configuration que por default esta todo habilitado.


La guía que use en el intento de hacerlo funcionar:

https://github.com/toleda/audio_CloverHDMI/blob/master/README.md

Al ejecutar audio_cloverALC-120.command
La terminal muestra:

Last login: Wed Aug 16 04:05:36 on ttys000
Mac-mini-de-umac:~ umac$ /Users/umac/Downloads/audio_cloverHDMI-120_v1.0d.command ; exit;
 
Agreement
The audio_cloverHDMI script is for personal use only. Do not distribute
the patch, any or all of the files for any reason without permission.
The audio_cloverHDMI script is provided as is and without any warranty.
 
File: audio_cloverHDMI-120.command_v1.0d
Release Mode
EFI partition is mounted

No audio codec detected
No system files were changed
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Proceso completado]

------


Con MACIAsl agregue algunos repositorios de Toleda (audio hdmi hd 3000, zotac), pero no pude en ningun caso aplicar patches.
No se si he sido extenso en la descripción o me falta algun dato importante, disculpas por ello.

Adjunto:
Reporte DarwinDumper
config.plist
DPCIManager (pantalla)
DSDT.aml
IORegistryExplorer (pantalla)
Informe de Sistema (algunas pantallas)


Saludos y gracias desde ya.

config.plist.zipDarwinDumper_3.0.3_15.08_23.42.15_Macmini5,1_Clover_X64_4063_Sierra_16A323_umac.zipDSDT.aml.zippost-1822891-0-60880200-1502917679_thumb.pngpost-1822891-0-01523700-1502917725_thumb.pngpost-1822891-0-96057800-1502917739_thumb.pngpost-1822891-0-84598400-1502917761_thumb.pngpost-1822891-0-57792200-1502917794_thumb.pngpost-1822891-0-35952500-1502917820_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

Sinceramente hace mucho que no toco las guías de Toleda pero vamos a ver que se puede hacer.

 

A simple vista te digo que el sistema de audio no te va a funcionar porque cargas el kext "net.osrom.kext.Disabler" (lo puedes ver en el ioreg, se desprende del dispositivo HDEF) que evita que se cargue el AppleHDA. No estoy seguro donde esta este kext  :rofl: pero buscalo en las carpetas /System/Library/Extensions y /Library/Extensions.

 

Mas allá de esto y como mencionas, te falta parchar el DSDT. Por ahora podes activar algunos parches DSDT de Clover, creo que con AddDTGP, FixHDA y AddHDMI debería bastar. Si no sabes como editar el config.plist te recomiendo la aplicación "Clover Configurator" así no lo editas a mano. Y para que entiendas mejor que hace cada opción del config.plist te dejo un link a la wiki de Clover.

 

Los kexts NullCPUPowerManagement VoodooPS2Controller y FakeSMC los tenés en 2 carpetas de kexts de Clover (EFI/CLOVER/kexts). Te recomiendo dejar los de Other y eliminar los demás. En 10.12 también tenés el AppleHDA completo, supongo que es una versión parchada pero desconozco qué tiene de distinto y no parece parte del método Toleda, este normalmente consiste en editar el AppleHDA del sistema si mal no recuerdo. De donde lo sacaste al kext? Y el kext HDAEnabler2.kext solo inyecta el layout de audio, cosa que ya estas haciendo con Clover actualmente así que tampoco te hace falta.

 

Aparte todo esto, no estoy seguro siquiera si es soportado el audio HDMI con tu video Intel Graphics de primera generación. Creo que ni la aceleración de video funciona.

Share this post


Link to post
Share on other sites

Buenas,

 

Te agradecería que me facilites la información de la pestaña PCI List del DCIPCIManger, ya que en el volcado de DarwinDumper no se han capturado los datos del informe LSPCI (DirectHW.kext not loaded). Necesito saber el vendorid de la tarjeta de sonido para poder indicarte el parche a aplicar. La informacion que muestras en DCIPCIManager se corresponde con el codec de audio de la tarjeta de video. Este codec no funcionará correctamente hasta que habilites la tarjeta de sonido de la placa base.

 

Referente a la tarjeta de video, el modelo que tienes se puede activar la aceleracion de video injectando el

lMEI en DSDT y habilitar el audio hdmi parcheando el

framebuffer e inyectado las propiedades de audio en el dispositivo.

 

Pásame el dato que falta, y te dare un respuesta completa con todas las posibles cosas que puedes hacer para que empieces a trastear.

 

Un saludo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By AppleCampus
      My computer was using Intel core i5-4210u ,My computer was using Intel core i5-4210u ,Sound card is cx20751/2,I use applealc inject id=3 successfully drive my onboard soundcard,but I found that HDMI Output is still no sound,how can i deal with it?
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
    • By ITzTravelInTime
      KX AUDIO DRIVER MOD
       
      Hi guys i am a small developer, i really like to use my sound blaster cards on my machines and i love also coding, so when i find the source code for the kx audio driver on git hub and then Eugene, the creator of kx audio driver decided to no longer maintain the project, i decided to start working on a mod of this driver and maintain it. 
       
      With my mod, created starting from the sources of the last official version of kx audio driver and all the small commiunity updates, i am working to keep the driver compatible with the latest mac os versions and to improove the driver over time.
       
      Supported cards are:
       
       - most of the Sound Blaster live!, live! 5.1 and live! 5.1 digital series (except for the cards not using the 10k1 architecture)
       - sound blaster pci 512 and pci 256
       - Sound Blaster Audigy, Audigy 2 and Audigy 2 zs series
       - E-MU cards based on the 10k2 sound chip (like the EMU8852 aka 0404m, including the pcie version)
       - Sound Blaster Audigy 4 (SB0610 only) and the Audigy 4 pro
       - Sound Blaster Audigy RX (SB0155)
       - other creative and e-mu cards based on the (10k1,10k2, 10k2.5 and CA10300 based cards)
       
      The NOT supported cards includes (but are not limited to):
       
       - ES1370/ES1371/ES1372/ES1373 based sound cards
       - Any CA0106 based card and cards with similar architectures (like sound blaster live! 24 bit, sound blaster audigy SE SB0570, audigy LS and similars, but audigy SA is supported)
       - Any sound blaster x-fi (some of them works on macOS using a modified version of voodoo hda)
       - Any sound blaster recon3D
       - Sound blaster Audigy FX
       - Any sound blaster Z/ZS/ZX and similar series
       - Any sound blaster AE5/AE7/AE9 series
       - Any sound card without an emu sound chip
      - Any ISA Sound card
       
      In the time being the things i have modded or added with this mod are:
       
      - cracking and stability fixes
       
      - added a more proper support for the pci express Sound Blaster audigy rx SB0155 (which basically is an audigy 4 with a pcie bridge chip) 
       
      - more user-frienly names for the cards in the settings and other system menus (so the name will be, for example, SB live! 5.1 SB0060 instead of kx SB0060 [e880] witch was shown in the original driver)
       
      - added support to sample rate changing and bit resolution change (the absolte worst supported quality is 7 khz at 8 bit dept while the absolute best is 192 khz at 32 bit depth)
       
      - inputs support
       
      - added boot args to manage the driver (more info on those soon)
       
      What i'd like to implement but i don't know how to do:
       
       - fix the support when using more than one card, to get all the cards shown in the settings and other menus,
       
       - have the gameport/midi port of older cards to be used in mac os as a midi in/out
       
      If other developers would like to join and help they are free to do so, this is a free open source project afterall, and also an hand from other people with testing and feedback will be nice.
       
      LINKS and downloads:
               -  github repo:                                               https://github.com/ITzTravelInTime/kx-audio-driver   (kext download coming soon, since an update is coming)  
       





×