Jump to content

[RELEASE] Open-source Clover fork with Ryzen support


216 posts in this topic

Recommended Posts

just get a amd card lol i got a used r9 270x for cheap

 

I would, but i locked myself into nVidia with this $1000 screen. It doesn't support Free Sync (AMD Cards).

Try efi_rc3 ))

attachicon.gifEFI_rc3.zip

Hello Bronya,

 

0:100  0:000  Running on: 'System Product Name' with board 'PRIME B350M-A'

0:100  0:000  === [ GetCPUProperties ] ==================================

0:100  0:000  CPU Vendor = 68747541 Model=800F11

0:100  0:000   The CPU supported SSE4.1

0:100  0:000      Looking to disable C1E if is already enabled by the BIOS:

0:100  0:000  BrandString = AMD Ryzen 7 1700 Eight-Core Processor          

0:100  0:000  CurrentSpeed: 3650

0:100  0:000  maxratio 72

0:100  0:000  cpudid_zen 8

0:100  0:000  FSBFrequency = 50 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz

0:100  0:000  MaxDiv/MinDiv: 36.0/9

0:100  0:000  Turbo: 0/0/0/0

0:100  0:000  Features: 0x178BFBFF

0:100  0:000  Threads: 16

0:100  0:000  Cores: 8

0:100  0:000  FSB: 25 MHz

0:100  0:000  CPU: 3649 MHz

0:100  0:000  TSC: 3650 MHz

0:100  0:000  PIS: 100 MHz

post-2087795-0-00996700-1498821036_thumb.png

  • Like 1

Hello Bronya,

 

0:100 0:000 Running on: 'System Product Name' with board 'PRIME B350M-A'

0:100 0:000 === [ GetCPUProperties ] ==================================

0:100 0:000 CPU Vendor = 68747541 Model=800F11

0:100 0:000 The CPU supported SSE4.1

0:100 0:000 Looking to disable C1E if is already enabled by the BIOS:

0:100 0:000 BrandString = AMD Ryzen 7 1700 Eight-Core Processor

0:100 0:000 CurrentSpeed: 3650

0:100 0:000 maxratio 72

0:100 0:000 cpudid_zen 8

0:100 0:000 FSBFrequency = 50 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz

0:100 0:000 MaxDiv/MinDiv: 36.0/9

0:100 0:000 Turbo: 0/0/0/0

0:100 0:000 Features: 0x178BFBFF

0:100 0:000 Threads: 16

0:100 0:000 Cores: 8

0:100 0:000 FSB: 25 MHz

0:100 0:000 CPU: 3649 MHz

0:100 0:000 TSC: 3650 MHz

0:100 0:000 PIS: 100 MHz

How do you get that output? I'm trying the new clover but I dont known how?

Try EFI_rc4 ! Should maxratio = 36.5   :)))

 

I plan to add in the kernel and the bootloader Chameleon for Ryzen ! 

 

I'm still having issue with the USB controller, i can't get passed that error....

If someone knows how to fix that issue it would be great.

I'm still having issue with the USB controller, i can't get passed that error....

If someone knows how to fix that issue it would be great.

 

in menu clover :

Disable or Enable USB Ownership , USB Injection . 

Or in ACPI Patching-> DSDT Fix Mask -> enable Fix USB 

You need use other modify config.plist . 

I also get error ACPI, ok , i modified config.plist and working ! 

 

Why you just don't give me the config.plist, so we can see if it works...

Try EFI_rc4 ! Should maxratio = 36.5   :)))

 

I plan to add in the kernel and the bootloader Chameleon for Ryzen ! 

:)

 

0:100  0:000  Running on: 'System Product Name' with board 'PRIME B350M-A'

0:100  0:000  === [ GetCPUProperties ] ==================================

0:100  0:000  CPU Vendor = 68747541 Model=800F11

0:100  0:000   The CPU supported SSE4.1

0:100  0:000      Looking to disable C1E if is already enabled by the BIOS:

0:100  0:000  BrandString = AMD Ryzen 7 1700 Eight-Core Processor          

0:100  0:000  CurrentSpeed: 3650

0:100  0:000  maxratio 72

0:100  0:000  cpudid_zen 8

0:100  0:000  FSBFrequency = 50 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz

0:100  0:000  MaxDiv/MinDiv: 36.0/3

0:100  0:000  Turbo: 0/0/0/0

0:100  0:000  Features: 0x178BFBFF

0:100  0:000  Threads: 16

0:100  0:000  Cores: 8

0:100  0:000  FSB: 25 MHz

0:100  0:000  CPU: 3649 MHz

0:100  0:000  TSC: 3650 MHz

0:100  0:000  PIS: 100 MHz

 

sound is perfect

post-2087795-0-70429800-1498846084_thumb.png

Look at my picture ^^^

Think that you use wrong Extensions in /S/L/E or wrong kexts ... 

:)

 

0:100  0:000  MaxDiv/MinDiv: 36.0/3

0:100  0:000  Turbo: 0/0/0/0

0:100  0:000  Features: 0x178BFBFF

0:100  0:000  Threads: 16

0:100  0:000  Cores: 8

 

sound is perfect

 

Thank ! But this wrong MinRatio . And wrong MaxRatio. Should 36.5 ! 

What really Min Ratio in bios ?

You tried cloverx64.efi from  #46 ?

Think that you use wrong Extensions in /S/L/E or wrong kexts ... 

 

FakeSMC is the only kext that i'm using now...

That ACPI Error and Kernel error has nothing to do with Kexts.

You use dsdt.aml ???

 

Why should i use a DSDT? 

Sorry man, i'm having major issues understanding what you're saying... 

Write French,i may get it the right way.

×
×
  • Create New...