Jump to content

Nvidia Web Driver updates for macOS High Sierra (UPDATE Nov 13, 2020)


fantomas
2,071 posts in this topic

Recommended Posts

1 hour ago, fullerfun said:

Hey all, Starting yesterday, June 2nd. The NVidia web driver no longer seem to be working on my system in 10.13.6.
I have another friend also running 10.13.6 who had the EXACT same problem. Stopped working as of yesterday for him as well.
 

Everything has been working perfectly for several years, then all the sudden, when booting in verbose, we get
AMFI code signature failed error,

Screen goes black for a second, then an endless loop follows of

ACM:findCredentialSet: returning err -2

ACM:CreateCredentialSet: Credential set created

ACM:verifyPolicy: Verifypolicy UserIdentificationWithBiometrics, checkKeybagUUID = N0, CS[107]
ACM:verifyPolicy: Policy satisfied = No

ACM:deleteCredentialSet: deleting credential set, CS[107]

ACM:findCredentialSet: returning err -2

ACM:CreateCredentialSet: Credential set created

ACM:verifyPolicy: Verifypolicy UserIdentificationWithBiometrics, checkKeybagUUID = N0, CS[108]
ACM:verifyPolicy: Policy satisfied = No

ACM:deleteCredentialSet: deleting credential set, CS[108]

IOConsoleUsers: time(0) 0->0, lin 0, lik1,

IOConsoleUsers: gIOGreenLockState 3, hs 0, bs 0, now 0, sm 0x0

 

Then screen refreshes, and it keeps trying to load credential sets endlessly counting up...and no graphics ever load.

 

The NVidia web drivers will not load.

Can easily boot the system with nv_disabled=1

 

It's like some sort of credential/certificate/code signing certificate...or something expired on June 1st 2022, and failed to load as of June 2nd, 2022

I've found a few older threads from 2018 with people who had this same error message....who seemed to solve it by

uninstalling the NVidia web driver, and re-installing. I've tried that, same error.
i tried using an older NVidia driver, same problem

I've tried using lilu and whatevergreen(which I never needed before), and Also tried adding EMuVariableUefi-64.efi to clover(which I didn't need before)but doesn't help.

Tried clearing NVRAM

Of course repaired, cleaned kext cache.

 

Booting an older system of 10.10 works fine with NVidia web drivers.

Very strange.

 

Anyone have any ideas?

 

Hi. You are not alone and I´m not too. 

 

https://forums.macrumors.com/threads/cannot-install-or-use-nvidia-webdrivers-anymore.2346445/?fbclid=IwAR0uD15T4OVJkEmCM0Z8BMSAuDx0A2nODNMAl8puVfBiYrlJqIC1o61z2vA

 

 

 

Just now, Krustif said:

Seems to be certificate problem ¿Apple or Nvidia? It is not clear. Buy AMD card or wait ... I'm screwed

Link to comment
Share on other sites

Posted (edited)

Yeah, thanks. People at that link are trying tons of workarounds...I haven’t been able to get any of them to work for me yet, but I haven’t tried them all yet either. Will report back if I get something to work.


For someone smarter than I...seems like there should be a way to bypass/or force a trust of the certificate...like you can in the keychain access with secure website certificates....I'm sure it's different when it comes to kexts..(someone who seems to know, just reported that this type of certification is done by Apple directly, and can only be done by them....hmm.... if true, that is not good....cause NVdia and Apple do not seem to have a good relationship anymore...)

 

Edited by fullerfun
Link to comment
Share on other sites

18 hours ago, fullerfun said:

Anyone have any ideas?

 

all good here
10.13.6 (17G14042)
387.10.10.10.40.140

Link to comment
Share on other sites

Posted (edited)

okay okay. later, obviou I also got same issues))
fixed instaling https://www.nvidia.com/download/driverResults.aspx/125379/en-us
oldie but working))

who needs CUDA, also install first HighSierra version
https://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/Mac/Quadro_Certified/9.0.214/cudadriver-9.0.214-macos.dmg&lang=us&type=Other

Spoiler

 

 

Edited by MICKHAEL
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

Setting the clock back, staying offline, and reinstalling the 387.10.10.10.140 Web Drivers hasn't worked for me (latest High Sierra 10.13.6 build 17G14042, OpenCore 0.8.0, Nvidia GTX1080Ti, Asus X299 ROG Rampage VI Extreme). I am now on a "OConsoleUsers: gIOScreenLockState 3" loop and I can only boot with nv_disable=1.

Edited by gorg
Link to comment
Share on other sites

Posted (edited)

I remove certificate of this Package from Pkgutil command  but I can not test because I have no Nv card then No High Sierra 10.13

The command will downloads WebDriver-387.10.10.10.40.140.pkg then Unpack, repack

 

make sur you dont have the package in downloads folder, and Files folder, it will be deleted.
there is the script code ⬇︎

#!/bin/bash
# By chris1111

echo "Downloads WebDriver-387.10.10.10.40.140  "
echo "= = = = = = = = = = = = = = = = = = = = = = = = =  "

curl -L https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.40.140.pkg -o $HOME/Downloads/WebDriver-387.10.10.10.40.140.pkg

# Expand the Packages with pkgutil
echo "Expand the Packages with pkgutil  "
echo "= = = = = = = = = = = = = = = = = = = = = = = = =  "
pkgutil --expand $HOME/Downloads/WebDriver-387.10.10.10.40.140.pkg $HOME/Downloads/Files

# Flatten the Packages with pkgutil
echo "Flatten the Packages with pkgutil  "
echo "= = = = = = = = = = = = = = = = = = = = = = = = =  "
pkgutil --flatten $HOME/Downloads/Files $HOME/Downloads/MyWebDriver-387.10.10.10.40.140.pkg

rm -rf $HOME/Downloads/WebDriver-387.10.10.10.40.140.pkg
rm -rf $HOME/Downloads/Files
echo "Done!   "
echo "= = = = = = = = = = = = = = = = = = = = = = = = =  "

attaching command ⬇︎

PKGUTIL.command.zip

 

1349392673_ScreenShot2022-06-04at10_52_50PM.png.f0b5cd166749a1c464d46bdea4ae72e7.png

 

 

 

 

1090733-24b44ebe467e5de46a8549e861826483.jpeg.c5869573ea392764469d3a071f207c55.jpeg

Edited by chris1111
The command will downloads WebDriver-387.10.10.10.40.140.pkg then Unpack, repack
Link to comment
Share on other sites

Posted (edited)

Thanks @chris1111 but that didn't help me either. After booting with nv-disable=1, disconnecting from internet and staying offline, and setting the clock back in time, I also tried to remove code signatures from everything included in the expanded Nvidia installer (kexts, bundles, preference panes) using "codesign --remove-signature" , manually copied the kexts to /S/L/E and /L/E, cleaned CRL caches in /var/db/crls, fixed permissions with Kext Utility, removed  nv-disable=1 from OpenCore, and rebooted.

 

Still no go, during boot I get "com_driver_GxxxDriver::probe falls", then the "OConsoleUsers: gIOScreenLockState 3..." loop.

Edited by gorg
  • Sad 1
Link to comment
Share on other sites

1 hour ago, gorg said:

Grazie @ chris1111 ma neanche questo mi ha aiutato. Dopo aver avviato con nv-disable=1, disconnesso da Internet e rimanere offline e aver riportato l'orologio indietro nel tempo, ho anche provato a rimuovere le firme del codice da tutto ciò che era incluso nel programma di installazione di Nvidia espanso (kexts, bundle, riquadri delle preferenze) usando "codesign --remove-signature" , ha copiato manualmente i kext in /S/L/E e /L/E, ha pulito le cache CRL in /var/db/crls, ha corretto i permessi con Kext Utility, ha rimosso nv-disable=1 da OpenCore, e riavviato.

 

Ancora no, durante l'avvio ottengo "com_driver_GxxxDriver::probe falls", quindi il ciclo "OConsoleUsers: gIOScreenLockState 3..." .

i also have the same problem as you, i can't solve

Link to comment
Share on other sites

Posted (edited)
UPdate****
Instal new driver instead. problem solved
https://drive.google.com/uc?export=download&id=1lPuKuQqI7OtNzMMmSrQ8MqVMC1EnlfCv
 
 
Unblocked trustd and oscpd rules in little snitch.

I was then able to get it back in the stuck state by clearing the DYLD cache using ONYX. Then rebooting.

I then reboot with nv_disable=1 flag.
This allows me to boot in VESA mode. (terrible video flickering/resolution..which is what it's supposed to do)

I ran the new installer from NVidia 
https://drive.google.com/uc?export=download&id=1lPuKuQqI7OtNzMMmSrQ8MqVMC1EnlfCv
Didn't click restart, left window open.
Ran Cuda installer.

Restarted computer.

Boom, back to normal!
 
------
Here’s the best current workaround, and brought my system back to life!. (Based on solutions by eierftucht and dayo on macrumors site)
 
 
(This may not work unless you were previously running latest 10.13.6 with the latest security updates already applied. If you go to apple menu top left, select about this mac, then click system report then click on software. what version of 10.13.6 does it show? If (17G14042) then you were. If running older version, 1st run security updates, force instal of web drivers using pacifist 3.2.17, rebuild kext caches, then follow procedures  below)
 
(Also may not work unless sip is disabled)

 
 
Step 1. Physically disconnect computer from the internet. 

Step 2. Boot into Safe Mode. Everything will be extremely laggy, be patient.  (-x in clover or opencore will boot safe mode, safe mode is essential step..will not work otherwise)

Step 3. Launch Terminal and enter the command ‘sudo nano /etc/hosts’, once prompted provide the password. (You can also use something like little snitch to block trustd instead of changing hosts...in step 3 &4)

Step 4. Append the following lines to the file’s contents:

127.0.0.1 ocsp.apple.com
127.0.0.1 ocsp2.apple.com

Save changes and exit.

Step 5. Run the following batch of Terminal commands:

crlrefresh rp
sudo rm -f /var/db/crls/*cache?.db

Step 6.
Go to finder,
Make invisible files visible command-shift-.
navigate to var/db/crls/
if there is a file called "crlcache2.db" still there, throw it in the trash, enter pass if needed
navigate to /Library/Keychains/crls/ throw "valid.sqlite3" in the trash, enter pass if needed
empty the trash
 
Restart computer normally,
 
you should be back to normal, and you can now turn the internet back on without issues.


good to go!
—-
If above doesn’t work for you, a new alternative on the macrumors site, several people(credit to DTRX &  Dayo) have developed a script that will disable trustd’s functionality on your computer. Personally, I would take some caution into doing this, for security reasons, however it does work more consistently, and is a simple and fast solution.
--
Alternative way is:
Restore from time machine from date before June 1st.
Completely disconnect from internet.
Boot restored system.
Open terminal. (Or use little snitch method)
Paste this, hit enter, type in pass.
sudo sh -c 'echo "0.0.0.0 ocsp.apple.com" >> /etc/hosts' && sudo sh -c 'echo "0.0.0.0 ocsp2.apple.com" >> /etc/hosts' && sudo killall -HUP mDNSResponder

Restart, reconnect to internet.
Good to go.
 
 
Edited by fullerfun
Link to comment
Share on other sites

On 6/6/2022 at 8:22 AM, fullerfun said:
Here’s the best current workaround, and brought my system back to life!. (by eierftucht on macrumors site)
 
 
 
Step 1. Physically disconnect the affected device from the web. Powering down the router for a few minutes will do just fine.

Step 2. Boot into Safe Mode. Everything will be extremely laggy, be patient.  (-x in clover will boot safe mode, safe mode is essential step..will not work otherwise)

Step 3. Launch Terminal and enter the command ‘sudo nano /etc/hosts’, once prompted provide the password. (You can also use something like little snitch to block trustd instead of changing hosts...in step 3 &4)

Step 4. Append the following lines to the file’s contents:

127.0.0.1 ocsp.apple.com
127.0.0.1 ocsp2.apple.com
127.0.0.1 ocsp.digicert.com

Save changes and exit.

Step 5. Run the following batch of Terminal commands:

crlrefresh rp
sudo rm -f /var/db/crls/*cache?.db
sudo date -u 020200002020
sudo reboot

Your computer will immediately reboot after the last command. Upon seeing the desktop again, you should notice that everything is back to normal. You can now reconnect to the internet. System time and date will automatically adjust themselves upon reconnecting. If some apps throw errors related to bad time and date, another reboot will fix that. Don’t worry if you run into any scary messages upon the first reboot.

The ‘sudo date’ shift trick is 90% likely unnecessary but better safe than sorry. It’s there just to lure the system (now reverted to a clean state) into repeating any sneaky moves it’s compelled to make since the 1st of June, just to check it no longer breaks itself.
 
good to go!
 
--
Alternative way is:
Restore from time machine from date before June 1st.
Completely disconnect from internet.
Boot restored system.
Open terminal.
Paste this, hit enter, type in pass.
sudo sh -c 'echo "0.0.0.0 ocsp.apple.com" >> /etc/hosts' && sudo sh -c 'echo "0.0.0.0 ocsp2.apple.com" >> /etc/hosts' && sudo killall -HUP mDNSResponder

Restart, reconnect to internet.
Good to go.
 
 


Anyone tried this?

Link to comment
Share on other sites

On 6/6/2022 at 8:22 AM, fullerfun said:
Here’s the best current workaround, and brought my system back to life!. (by eierftucht on macrumors site)
 
 
 
Step 1. Physically disconnect the affected device from the web. Powering down the router for a few minutes will do just fine.

Step 2. Boot into Safe Mode. Everything will be extremely laggy, be patient.  (-x in clover will boot safe mode, safe mode is essential step..will not work otherwise)

Step 3. Launch Terminal and enter the command ‘sudo nano /etc/hosts’, once prompted provide the password. (You can also use something like little snitch to block trustd instead of changing hosts...in step 3 &4)

Step 4. Append the following lines to the file’s contents:

127.0.0.1 ocsp.apple.com
127.0.0.1 ocsp2.apple.com
127.0.0.1 ocsp.digicert.com

Save changes and exit.

Step 5. Run the following batch of Terminal commands:

crlrefresh rp
sudo rm -f /var/db/crls/*cache?.db
sudo date -u 020200002020
sudo reboot

Your computer will immediately reboot after the last command. Upon seeing the desktop again, you should notice that everything is back to normal. You can now reconnect to the internet. System time and date will automatically adjust themselves upon reconnecting. If some apps throw errors related to bad time and date, another reboot will fix that. Don’t worry if you run into any scary messages upon the first reboot.

The ‘sudo date’ shift trick is 90% likely unnecessary but better safe than sorry. It’s there just to lure the system (now reverted to a clean state) into repeating any sneaky moves it’s compelled to make since the 1st of June, just to check it no longer breaks itself.
 
good to go!
 
--
Alternative way is:
Restore from time machine from date before June 1st.
Completely disconnect from internet.
Boot restored system.
Open terminal.
Paste this, hit enter, type in pass.
sudo sh -c 'echo "0.0.0.0 ocsp.apple.com" >> /etc/hosts' && sudo sh -c 'echo "0.0.0.0 ocsp2.apple.com" >> /etc/hosts' && sudo killall -HUP mDNSResponder

Restart, reconnect to internet.
Good to go.
 
 



I can confirm, this trick is working good

  • Like 2
Link to comment
Share on other sites

On 6/5/2022 at 9:22 PM, fullerfun said:
Here’s the best current workaround, and brought my system back to life!. (by eierftucht on macrumors site)
 
 
 
Step 1. Physically disconnect the affected device from the web. Powering down the router for a few minutes will do just fine.

Step 2. Boot into Safe Mode. Everything will be extremely laggy, be patient.  (-x in clover will boot safe mode, safe mode is essential step..will not work otherwise)

Step 3. Launch Terminal and enter the command ‘sudo nano /etc/hosts’, once prompted provide the password. (You can also use something like little snitch to block trustd instead of changing hosts...in step 3 &4)

Step 4. Append the following lines to the file’s contents:

127.0.0.1 ocsp.apple.com
127.0.0.1 ocsp2.apple.com
127.0.0.1 ocsp.digicert.com

Save changes and exit.

Step 5. Run the following batch of Terminal commands:

crlrefresh rp
sudo rm -f /var/db/crls/*cache?.db
sudo date -u 020200002020
sudo reboot

Your computer will immediately reboot after the last command. Upon seeing the desktop again, you should notice that everything is back to normal. You can now reconnect to the internet. System time and date will automatically adjust themselves upon reconnecting. If some apps throw errors related to bad time and date, another reboot will fix that. Don’t worry if you run into any scary messages upon the first reboot.

The ‘sudo date’ shift trick is 90% likely unnecessary but better safe than sorry. It’s there just to lure the system (now reverted to a clean state) into repeating any sneaky moves it’s compelled to make since the 1st of June, just to check it no longer breaks itself.
 
good to go!
 
--
Alternative way is:
Restore from time machine from date before June 1st.
Completely disconnect from internet.
Boot restored system.
Open terminal.
Paste this, hit enter, type in pass.
sudo sh -c 'echo "0.0.0.0 ocsp.apple.com" >> /etc/hosts' && sudo sh -c 'echo "0.0.0.0 ocsp2.apple.com" >> /etc/hosts' && sudo killall -HUP mDNSResponder

Restart, reconnect to internet.
Good to go.
 
 

Thank as it works great again.

Link to comment
Share on other sites

43 minutes ago, Hervé said:

You can't have searched much... The link on p1 is just corrupt. Use this:

https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.40.108.pkg

I have and I do have 387.10.10.10.40.108, alongside older ones archived for safe keeping. But not 387.10.10.15.15.108, which suspiciouly was supposed to be the only (?) one to be HS build number independent (?).

Edited by gorg
Link to comment
Share on other sites

My apologies, I had missed the typo on p1 on top of the corrupt link! Indeed, no such thing as WebDriver-387.10.10.15.15.108 any longer.

 

All the drivers for High Sierra 10.13.6 are versions 387.10.10.10.40.xxx; they include one in .108.

All the drivers for High Sierra 10.13(.0)  are versions 387.10.10.10.15.xxx but none in .108.

  • Like 1
Link to comment
Share on other sites

@fullerfun As far as editing the etc/hosts file is concerned: there's an App for that called GasMask, so you don't need to do it in safe mode to do it.

 

And also: can you fix the formatitin of your post so that it's actually readable?

 

715979204_Bildschirmfoto2022-06-18um20_14_45.png.7381c58a27d4bb81365eb23b77c3cf53.png

Edited by 5T33Z0
Link to comment
Share on other sites

×
×
  • Create New...