Jump to content
tarasis

Hanging booting normally, fine in safe mode: IOHDACodecFunction

4 posts in this topic

Recommended Posts

I upgraded my ElCap install to Sierra (Beta 1) mostly without issue. When I first tried the post install boot it seemingly hung.

 

Turning on verbose there seemed to be an issue caused by a broken install of Little Snitch. Having uninstalled LS, on the next normal, the boot log kept repeating:

busy timeout[0], (60s), kextd wait(0): 'IOHDACodecFunction'

After removing the AppleALC kext, I was able to boot normally.

Share this post


Link to post
Share on other sites
Advertisement

Cheers. It was a combination, the AppleALC was old and wouldn't have responded to that argument. I will try it out again soon, now that I have a baseline.

Share this post


Link to post
Share on other sites
On 8/22/2016 at 5:20 PM, artur_pt said:

hello

 

must insert this boot flag


-alcbeta

https://github.com/vit9696/AppleALC/releases

 

good hack

My hack still slow boot at this stage : "iohdacodecfunction" although used to above bootflag, clear ticked acpi and vice versa.

 

Do you have any guidance to make my hack boot normaly?

VoodooHDA good and my hack will boot fast, but the audio not very satisfy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×