Jump to content

Patch for using NVMe under macOS Sierra is ready.


1,382 posts in this topic

Recommended Posts

So my system is a:

Z77X-UD5H

I'm using a M.2 PCIE adapter in the slot 3 (x4) and using a Samsung 960.

 

I clean installed MacOS Mojave.

 

I had it working in 'Sierra' but forgot how I did it and didn't made a backup from it.

 

What do I need to do to get it recognised again ?

Link to comment
Share on other sites

  • 1 month later...

@Pene Attempting to install 10.14.6 to a new system with an SK Hynix PC601 NVME SSD.  I tried your version of the patch for 10.14.4, as well as @Jief_Machak's patch for 10.15.1, just to see if it worked.  Neither did; I get kernel panics related to IONVMeFamily no matter what I do.

 

For context, this is an install using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 9.3.0, and I have not yet been able to load the installer because (if I'm interpreting it correctly) it's panicking every time IONVMeFamily attempts to load the SSD.  Any thoughts?

Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...

Hi!

Recently I bought an Enterprise M.2 NVMe SSD Samsung 983 DCT M.2 1.92TB (MZ-1LB1T9N). I’m trying to launch the Mac OS 10.15.5 in 1-st configuration with it on board. Getting such panic report:

 

000009.780357 AppleUSB20HubPort@14d20000: AppleUSB20HostPort::disconnect: persistent enumeration failures

panic(cpu 0 caller 0xffffff7f878004a7): nvme: “Fatal error occurred. CSTS=0x1 US[1]=0x0 US[0]=0xa VID=0x144d DID=0xa808

. FW Revision=EDA7602Q\n@/BuildRoot/Library/Cashes/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-470.40.4/IONVMeController.cpp:5258

 

Without SSD in M.2 slot the system launches well. Screenshots are attached.

 

Configurations:

 

1. Asus Maximus XI Hero: Intel Core i9-9900K (LGA 1155-2), Z370, 32GB DDR4 3200MHz, Intel UHD Graphics 630, Samsung 983 DCT M.2 1.92TB (MZ-1LB1T9N) NVMe Express PCIe 3.0 x4 SSD; macOS 10.15.5/Windows 10

2. Asus P8Z68-V GEN3: Intel Core i7-2600K (LGA 1155), Z68, 16GB DDR3 1600MHz, Asus nVidia GT 710 2gd5, Samsung SSD 860 EVO 1TB SATA 3; macOS 10.15.5/Windows 10

image2.jpeg

image1.jpeg

image3.jpeg

Edited by mrAlexis777
Link to comment
Share on other sites

  • 5 months later...

Hi guys, would appreciate any help on how to fix my Plextor M9PeG not being recognized on cMP 3,1 (early 2008) on High Sierra 10.13.6. I am using a cheap generic adaptor. Bootrom patched with nvme.ffs, The adapter is displayed in System Profiler NVMe section but the Plextor is not recognized. Based on @RehabMan github branch info the patch is usually not required on 10.13 but it is noted that Plextor might need the extra patch in the InfoPlist. I am wondering what would be the right way to apply the extra patch for Plextor. Can I manually add the <dict></dict> section to the plist? There were updates posted displaying how it should look in the patched plist so I might try those but I am not sure how to properly apply them. When I try to refrence the custom_patches plist I get an error message in Terminal that the file is not found (and I have properly used cd to get to the folder with all of the patches downloaded from the github repository. Thanks in advance for your help!

Edited by Axegrinder
typo fix
Link to comment
Share on other sites

  • 4 weeks later...
On 12/9/2019 at 5:33 PM, Jief_Machak said:

Patch for Liteon/Plextor/Hynix doesn't seem to work with 10.15.1

 

Here is a new one :

            <dict>
                <key>Comment</key>
                <string>IONVMeFamily patch for SSD Liteon etc. (c)jief_machak</string>
                <key>Disabled</key>
                <false/>
                <key>MatchOS</key>
                <string>10.15.x</string>
                <key>Name</key>
                <string>com.apple.iokit.IONVMeFamily</string>
                <key>Find</key>
                <data>D4NOAQAA</data>
                <key>Replace</key>
                <data>kJCQkJCQ</data>
            </dict>
 

 

Hi,

 

Would you happen to know if there is anything out for Big sur? 11.2.2 Perhaps?

Link to comment
Share on other sites

  • 1 year later...

Hi,

 

Having trouble addressing Nvme drives that are behind two bridge switches as follows. The first switch is at address _SB_.PCI0.PEG0.PEGP at address 0x0009000. Then nested down we have

four more at 0x00110000,0x00100000,0x00800000, + 0x00900000. Hopefully I'm writing those addresses correctly.  Took down the ACPI paths from Windows Device Manager.  

 

Here they are:

ACPI(_SB_)#ACPI(PCI0)#ACPI(PEG0)#ACPI(PEGP)#PCI(0900)#PCI(0000)#PCI(1100)#PCI(0000)
ACPI(_SB_)#ACPI(PCI0)#ACPI(PEG0)#ACPI(PEGP)#PCI(0900)#PCI(0000)#PCI(1000)#PCI(0000)
ACPI(_SB_)#ACPI(PCI0)#ACPI(PEG0)#ACPI(PEGP)#PCI(0900)#PCI(0000)#PCI(0800)#PCI(0000)
ACPI(_SB_)#ACPI(PCI0)#ACPI(PEG0)#ACPI(PEGP)#PCI(0900)#PCI(0000)#PCI(0900)#PCI(0000)

 

These four Nvme drives installed in a raid card that show up as external and despite my best attempt I can't get them to go 'Internal'. Was able to get it to work with another drive with only one parent bridge directly off the motherboard but these four drives being doubly nested is making it difficult. Furthermore not sure if I'm writing the built in Buffer code correctly either. On a single drive and switch bridge it works. The code Rehabman posted makes it disappear however which I find useful in cases of dual booting sometimes you want to hide a drive from macos. Anyhow my main objective is to get these four drives to show up as Internal drives and if I'm lucky get the Highpoint controller card working if not hide them from osx. Heres my experimental ssdt code:

DefinitionBlock ("", "SSDT", 2, "hack", "NVMe", 0x00000000)
{
    External (_SB_.PCI0.PEG0.PEGP, DeviceObj)

    Device (_SB.PCI0.PEG0.PEGP.HPC1)
    {
        Name (_ADR, 0x00090000)  // _ADR: Address
        Device (SSD0)
        {
            Name (_ADR, 0x00110000)  // _ADR: Address
        }
    }

    Method (_SB.PCI0.PEG0.PEGP.HPC1.SSD0._DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
    {
        If (!Arg2)
        {
            Return (Buffer (One)
            {
                 0x03                                             // .
            })
        }

        Return (Package (0x04)
        {
            "built-in", 
            Buffer (0x0A)
            {
                "NVMe SSD"
            }
        })
    }
}

 

 

 

Have a thread here describing the issue. Please place comments there:

 

 

Thank you

Edited by davidm71
Link to comment
Share on other sites

×
×
  • Create New...