Jump to content

My 2° Amd Attempt Asus F7Kr Turion64 x2


16 posts in this topic

Recommended Posts

Hi guys, 

I'm trying to boot el capitan (I know it's a challenge :P) on an old Turion 64 x2 laptop I had forgotten on a bag, the Asus K7Fr...

(I'm trying to boot from a cloned tested on another machine 10.11.3 clean install, not the installer)



CPU: AMD Turion 64 X2

Chipset: AMD M690G

GPU: ATI Mobility Radeon HD 2400

Memory: 2GB DDR2 SDRAM

HDD: 250GB 5400RPM


I'm booting using latest Enoch (It seems that this laptop don't digest Clover, I wasn't able to make it load) and using this kernel (S/L/K) + system.kext (S/L/E) as suggestions from spakk! (thx :D)

and tried booting using these flags at boot:


npci=0x2000 idelhalt=0 cpus=1 usekernelcache=No  GraphicsEnabler=Yes PCIRoot=1


the kexts I'm injecting from E/E:


FakeSMC, NullPowermanagement.kext, VoodooPS2Controller, AppleNForceATA.kext, AppleVIAATA.kext, SuperViaATA.kext, Patched_10.7_AppleRTC.ext,  VoodooTSCSyncAMD.kext


but the system always get stuck on:

Applekeystore Starting (built...)


Here a screenshot!



Thanks for every kind of help!



Link to comment
Share on other sites

Try this kernel, http://www.insanelymac.com/forum/topic/310796-amd-os-x-el-capitan-1011-fx-kernel-task-force/?p=2228832


And the FakeSMC I've uploaded. You won't need AppleNForceATA.kext as it has an AMD Chipset. I assume you have KernelBooter_kexts set to Yes in the kernel.plist file in Extra.




Also boot using the following,


-f -v UseKernelCache=No GraphicsEnabler=Yes npci=0x3000

  • Like 1
Link to comment
Share on other sites

Ok, give me one minute to try...

yes kernelbooter_kext is in the kernel.plist, the kexts are injecting...

thx  ^_^

It seems getting stuck there, the same way. :/

this appeared before the kexts injection on enoch screen...

rsdp_mod size incorrect

Link to comment
Share on other sites

sory, I forgot to mention that you have to delete the: appleintelcpupowermanagement.kext and appletmc.. kext ... from S /L /E then repair the permissions and renew Kernel cache.

Link to comment
Share on other sites


I tried, and it still hangs there... :( I'm not so lucky.

Can you upload an picture

Link to comment
Share on other sites

try to boot with: -x -f npci=0x2000 cpus=1 usekernelcache=No  GraphicsEnabler=Yes /NO PCIRoot=1 (idelhalt=0) 

Link to comment
Share on other sites

  • 3 years later...

  • Create New...