Jump to content
Swad

Boots fine with USB, won't boot with Clover, probably just hates me.

4 posts in this topic

Recommended Posts

First, big thanks to everyone who's been working on this stuff recently - as someone who was around in the early days, it's so exciting to see how far things have come.

I'm installing El Capitan on my new ThinkServer w/ Xeon E3-1225V3, 8GB RAM, Model 70A4001MUX

It boots and installs just fine with the USB - the graphics are choppy, but otherwise it's good. 

It just won't boot on its own. I've tried installing Clover using the quick installer linked in the homepage instructions, as well as the Sourceforge installer, but with no luck - it just hangs on the following screen.

I also tried all the variations of OSXAptioFixDrv but none worked (It's an AMI Aptio board)

(I can't thank P1lgrim enough for his guide; I followed it to the letter.)

I'm attaching screenshots of where it gets stuck and my current Clover settings.

Thanks in advance for your help!

IMG_0042.JPG

IMG_0046.JPG

IMG_0047.JPG

IMG_0048.JPG

IMG_0050.JPG

Share this post


Link to post
Share on other sites
Advertisement

Sir, you are breaking our rules :whistle: (tonymacx86.com)

-----------

Want to try Enoch bootloader? is here (just point the package to your usb installer... you want only try..no? otherwise install directly to the HD).

Then copy/replace this Extra.zip folder to the root of the usb pen/choosen volume.

Extra/Extension already contain some extensions, so check for (and to avoid) duplicates in /System/Library/Extensions/ (if your installer have one).

Check also for the correct resolution of your Display in /Extra/org.chameleon.Boot.plist

If problem, try to type GraphicsEnabler=No at boot time.

 

Then, try to boot and good luck!

Share this post


Link to post
Share on other sites

The plusses get output right before the kernel takes over if I remember correctly (might be a little earlier, but I doubt it even matters).

I would try OsxAptioFixDrv rather than OsxAptioFix2Drv for now, because the first has more verbose output in terms of memory allocation messages (boot.efi used to output errors too, but somehow stopped a while ago, probably with some El Capitan DP). That way you can see whether the issue is with the allocation of the memory, or with the early kernel itself. Once OsxAptioFix works, you can still check if OsxAptioFix2 works, as latter is certainly better for daily use.

 

A usual cause for hanging at this point is also early kernel trying to write to MSR 0x2E for XCPM, so make sure KernelPm is checked for now. You can still disable it after, in case it isn't the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×