Jump to content
About Just Joined group Read more... ×

Kernel Panic on Using RealtekRTL8111 kext

9 posts in this topic

Recommended Posts

Hi Guys,

Thanks a lot devs for making hackintosh possible on AMD.


I just updated to 10.10.5 from 10.10.3 and I get Kernel Panic until I remove the RealtekRTL8111.kext from S/L/E


My Config:


FX 8120

GA 970A DS3 (Non UEFI)




I am using Chameleon as bootloader.


Everything was working fine in 10.10.3 I updated and used the kernel and other files in Zip in AMD Development Section. Everything else is working fine. It boots all fine If I remove the kext and clear the cache. I have tried both v 1.2.3 and 2.0

It doesnt boot into Safe Mode with the kext.


Kindly Help finding a solution. I mainly use this for iOS development. I have a Mac book Air but its too small for long time work.




Share this post

Link to post
Share on other sites

use these newer drivers from Mieze and rehabman for your LAN: Realtek RTL8168 / 8111


I am already using those kexts. 


I have found one more thing.

If I load the kext using Kext Wizard after login, ethernet works fine. This is using the same kext which causes the above error


Edit: The above process also causes a shutdown/reboot problem. The screen goes off but the Fan etc keep running. i.e. PC doesnt shutdown completely.

Share this post

Link to post
Share on other sites

Do you use a custom DSDT?

I will contact you back this afternoon, when I come home from work, then we can try to resolve the issue.

Share this post

Link to post
Share on other sites

Do you use a custom DSDT?

I will contact you back this afternoon, when I come home from work, then we can try to resolve the issue.

No, Never even tried DSDT thing.


Thanks a lot. :)

Share this post

Link to post
Share on other sites

install the contents of the folder in the appendix in your /Extra/Extensions/ repair the permissions and renew the kernel cache with Kext Wizzard. then use the AMD.DMG of rampagedev, there should be included files for your board. if should not be the case, then Install maciasl or dsdt editor and export a raw dsdt and upload it here



If you have any questions, ask your questions here: http://www.insanelymac.com/forum/topic/285760-help-topic-further-help-in-chatosx86hulegacykernel-irc/page-128


Share this post

Link to post
Share on other sites

Xcode 7 wasnt working properly and I was trying something and system went bad. 

Now I am thinking of clean install 10.10.5 and not use a distro. (I was using one from Hackintosh.zone)


Can you guide me to a proper tutorial


Thanks a lot guys

Share this post

Link to post
Share on other sites

create an USB installer using by Disk Utility, install Enoch bootloader (current version), then use the contents, see package, what I have uploaded in to --> Extra/Extensions/ ... then Download my latest AMD kernel, see above under download, install the kernel in your USB Installer to  /S/L/kernel/

Then prepare the BIOS Settings for OS X, then boot from USB Installer and install yosemite....then install the AMD kernel in your partition to /S/L/kernels/  .... that's it!



in the package (see my Post #7) is a Chipset Driver, so should your system run better


Edit 2:

these Problematic drivers should remove from USB Installer and later from your finished installed Yosemite partiton from S/L/Extensions/  "AppleGraphicsControl.kext, AppleTyMCEDriver.kext, AppleUpstreamUserClient.kext"



as boot flags you can test with: -v -f kext-dev-mode=1 npci=0x3000 usekernelcache=no  GraphicsEnabler=NO nvda_drv=1


..... and do not use so called super-tony-tools that promise much and cause only problems in the long term. make every possible installation manually !


Share this post

Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By kokozaurs
      Hi all,
      I'm using ESXI 7.0b (did use 6.7 to try but with no difference).
      Right now on Catalina but I can't seem to try to get GPU (RX580) working properly.
      I pass it through to the VM(tried with windows before with no problems) and it appeared just as pci-device with no name.
      After that, I've applied whatevergreen + lilu kexts and it does properly recognize it under system report however that's all there is. It's listed at GFX0. See attached images.
      No hardware acceleration. Monitor also not turning on using either DP/HDMI. 
      Since it is being passed through to the VM, it seems that the problem is not on ESXi side but on macOS side. 
      Has anyone has been able to pass through an AMD GPU to ESXI VM? Can anyone suggest some pointers as to where I could find some solutions to this problem?

    • By b2550
      Currently my install is 100% working except that so far I have only been able to get one of my 1080p monitors working with a MiniDP to HDMI cable. I currently am getting a second MiniDP to HDMI cable but for now I am stuck with a DVI to HDMI cable.

      The monitor that is working is plugged in via the MiniDP to HDMI. The monitor that isn't working is using the DVI cable. However I also tried switching it to HDMI to HDMI which had the same result. The monitor wakes up but it's black. However for whatever reason, both monitors are still recognized in system preferences and hackintool.

      I know all my cables are good and work because I updated from an install of El Capitan (which I still have on it's original SSD just in case this install fails) as well as a Windows install. Both monitors worked fine on El Capitan for literally years. El Capitan is just too old now and I need to update to keep up with software updates.

      Problem reporting files should provide needed info about how I've configured this install. Build is in my signature.
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
    • By asheenlevrai
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
      Thank you very much in advance for your help.
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.