Jump to content

[GUIDE] USB Fix El Capitan 10.11


830 posts in this topic

Recommended Posts

  • 6 months later...

Hello, here my situations:

- I own a GA-Z97X-UD3H-BK with an Xeon E3 1241v3;

- for USB ports I renamed controllers to EH01/EH02/XHC and use the injector with only those ports I plan to use;

- I don't use the ports limiter patch.

 

Sometime at early boot I get a KP related to Apple USB kexts; after some reboot it boots up and works just fine.

I tried to play with various combinations of Clover USB flags, but the random boot KP still occurs.

 

Initially a set all USBConnector to value 3 except two internal ports set to 255 where I connected internal BT board and an internal card reader.

Yesterday a changed all HSx ports to value 0 and all SSx ports to 3, to see if this solves the KP at boot.

 

Have you an idea of what can be the cause of that?

 

I've also an HP Elite 7000 (i5 750) and an Intel NUC 5I3MYHE (i3 5010U) that runs without USB injectors and works fine, and another hack with GA-Z87-D3H with an i5 4440 with the injector that soffers with the same early boot random KP... this let me think that it is related to ports injection.

 

Thanks in advance

  • 2 weeks later...

Hello, I have followed this guide to get USB 2.0 to work on El Capitan and Sierra and have not been successful.

 

Steps I have tried from the guide include Steps 1, 2 and 2a and 2b.  I also tried to change EHC0 and EHC1 to EH01 and EH02 in my DSDT.  I tried using the USBInjectAll.kext to try to map out my ports.  This didn't work.  When I would plug in my USB devices, it would not show up on IORegistry explorer.

I am sure there is something I am missing with regards to patching my DSDT.

Any help is appreciated

 

I have a HP Probook 6450b.

6 GB of Ram

Sierra 10.11

SMBIOS MacBookPro6,1

 

 

My hard drive is partitioned and on my other partition, I have a working Yosemite install with working USB ports.

 

I have included my screen shot of my IORegistry File.  Tried to upload my DSDT file but error message indicated I could not upload this type of file?

 

Thanks.

 

RK 

post-2260868-0-18725500-1507833299_thumb.png

×
×
  • Create New...