Jump to content

[FIX] Fix for black screen on AMD 7XXX cards!


IntelFanatic
 Share

120 posts in this topic

Recommended Posts

  • 1 month later...
  • 4 weeks later...

@wern apfel @polyzargone I'm planning to buy Chinese HD7770 4GB Version card. Will it work in macOS Seirra 10.12.6.

What is the path or fix I should use ?

Will it work ?

Will it be future proof, Means How long will it be supported by apple ?

If the Chinese version has the same device-id it should work with WhateverGreen (FAQ) + Lilu. No idea about the future.

Link to comment
Share on other sites

  • 1 month later...

rollback of this kext to sierra to high sierra

 

AMDRadeonX4000.kext

AMDRadeonX4000GLDriver.bundle

IOAccelerator2D.plugin

IOAcceleratorFamily2.kext . 

 

then

 

sudo rm -/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch /System/Library/Extensions && sudo kextcache -/

 

work to me with 7750 and 7950

 

http://www.insanelymac.com/forum/topic/325279-ati-7750-1013/page-2

  • Like 1
Link to comment
Share on other sites

use kekt wizard or terminal,how you want


I recommend,

after to terminal

 

 

sudo rm  f  Sistema Libreria Cache com mela kext cache avvio kernelcache  &&  sudo touch  Sistema libreria estensioni &&  sudo kextcache  u  / 


if you need it

Kext Wizard.zip

Link to comment
Share on other sites

rollback of this kext to sierra to high sierra

 

AMDRadeonX4000.kext

AMDRadeonX4000GLDriver.bundle

IOAccelerator2D.plugin

IOAcceleratorFamily2.kext . 

 

then

 

sudo rm -/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch /System/Library/Extensions && sudo kextcache -/

 

work to me with 7750 and 7950

 

http://www.insanelymac.com/forum/topic/325279-ati-7750-1013/page-2

I confirm this method.

For AMD Radeon HD6450 it requires replacing four kexts

AMDRadeonX3000.kext

AMDRadeonX3000GLDriver.bundle

IOAccelerator2D.plugin

IOAcceleratorFamily2.kext . 

Same but other family.
Really bad is the bundle. Other kexts should be replaced because of dependencies.
Link to comment
Share on other sites

rollback of this kext to sierra to high sierra

 

AMDRadeonX4000.kext

AMDRadeonX4000GLDriver.bundle

IOAccelerator2D.plugin

IOAcceleratorFamily2.kext . 

 

then

 

sudo rm -/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch /System/Library/Extensions && sudo kextcache -/

 

work to me with 7750 and 7950

 

http://www.insanelymac.com/forum/topic/325279-ati-7750-1013/page-2

care to share the file cause im on el capitan

Link to comment
Share on other sites

The problem is I can't boot to High Sierra to replace the kexts. I thought I can copy kexts using Terminal from USB Installer High Sierra.

You also can boot into Single User Mode (with arg -s). In this case you should have access to some other partition where you can place these kexts. 

  • Like 1
Link to comment
Share on other sites

now that I have passed my tests lol...

 

I just picked up a compaq 6300 pro that came with a ati 7450,  I have read this whole forum post but I cannot determine which files I need in order to make this card work.

 

the card it self is working, (@1920x1080) just the graphics are very choppy and there are artifacts.

 

with that said I have tried downloading a bunch of the files that were listed here but I couldn't manage to get any of them to work.

 

when I tried the dsdt fix display and the ati inject, my system didn't like that at all and actually crashed. 

 

think any one could point me to the files or the posts that I need to make it work?

Link to comment
Share on other sites

now that I have passed my tests lol...

 

I just picked up a compaq 6300 pro that came with a ati 7450,  I have read this whole forum post but I cannot determine which files I need in order to make this card work.

 

the card it self is working, (@1920x1080) just the graphics are very choppy and there are artifacts.

 

with that said I have tried downloading a bunch of the files that were listed here but I couldn't manage to get any of them to work.

 

when I tried the dsdt fix display and the ati inject, my system didn't like that at all and actually crashed. 

 

think any one could point me to the files or the posts that I need to make it work?

Cancels DSDT injection,

injection test by Clover

Framebuffer = Caicos

Ati Inject = true

Link to comment
Share on other sites

So i have been working on this for the better part of the afternoon, trying different settings.

 

this doesnt work,

 

Cancels DSDT injection,
injection test by Clover
Framebuffer = Caicos
Ati Inject = true

 

i have been in chat and a user named Dreadkopp has been helping me try out different settings, things we have tried,

 

injectATI, FakeID: 0x67391002, FBConfig:Duckweed (booted normal choppy graphics, same problem)

injectati + fb= duckweed, no fakeid (booted normal choppy graphics, same problem)

injectATI, FakeID= 0x67791002 this booted but black screen (has ip) 

fakeid=0x67791002 + injectATI + FBConfig=Pithecia (black screen has ip)

 

also there doesnt appear to be a frame buffer by the name of caicos according to this  (https://hastebin.com/ewumubugob.go)

 

 

this is how Mac OS is reporting my card.

 

Type: GPU

  Bus: PCIe

  PCIe Lane Width: x16

  VRAM (Total): 7 MB

  Vendor: ATI (0x1002)

  Device ID: 0x677b

  Revision ID: 0x0000

  Displays:

Display:

  Resolution: 1920 x 1080

  Pixel Depth: 32-Bit Color (ARGB8888)

  Main Display: Yes

  Mirror: Off

  Online: Yes

  Automatically Adjust Brightness: No

Link to comment
Share on other sites

  • 3 weeks later...

Ive found 2 thing:

1.When ATIInject=Yes in clover i get Panic n it sys reboots
2.Every Version of OS X(or its AMD6000COntroller.kext) have diff versions/values/data of Framebuffers
 
AMD Radeon HD 7650M in not working on 10.13.1, can someone guide me !  
Link to comment
Share on other sites

  • Slice pinned this topic
 Share

×
×
  • Create New...