Jump to content

Having trouble with an R9-280 detecting


7 posts in this topic

Recommended Posts



My first post to the forum comes in the form of a question.  I am wokring on build [2] below in my signature, and my eyes are just now getting opened to the fact that there is ways to make things work without going over to the TM forum***.  Exciting!!


So... previously as I did previously in build [1] I just used TM's standard tools*** to try and setup build [2].  System would not even boot into setup, and after a day or so, I stumbled onto Clover, and thought, lets give it a shot.  It turns out that getting it to work was really not too hard - my board was found on rampagedev.com, so the collection of files needed was already there.  Easy.


Now, the problem I am having is my XFX R9-280 graphics card (dev id 0x679a1002) - system will not bootup with card installed.  It simply stalls on the Apple screen with the progress bar about half way.  If booting in with '-v', it scrolls through the startup, I see 3 lines there talking about it detecting and enabling my card, and then it stalls on the bluetooth.


I am told this card is supported out of the box, and my system (10.10.3) does have the AMD7000controller.kext file in it, but it just stalls on boot.  If I disable the previously mentioned kext, the system will boot but unacellerated (painful) and it just shows the graphics as "Display 7mb". 


I'm sure this has been done before -- anyone here care to shout out to an Insanelymac forum newbie?  Been 3 days and counting on trying to get this dumb card working (I need it for the mini DP that the card has - have a 27" Apple Cinema Display just dying to use!!). 


Thanks in advance,





*** A couple of places above I referenced the TM forum or tools that you typically find on it.  I am learning very quickly on this forum about the general concensus on that and please forgive my not knowing previous.  I'll be reloading system [1] once I get this one squared away.  Am only mentioning it here for the sake of clarity to how I got to this point today.  Thank you in advance for not being too hard on me for that!!! :grins:

Link to comment
Share on other sites

Good morning,


I just got your reply, and went to upload the config.plist (added txt to end so I could attach it to this reply) from here : EFI -> EFI -> Clover -> config.plist.


This config.plist was the one supplied by the haswell.dmg file I got off of rampagedev.com (I believe he's active on this forum?).  I then did only minor tweaking to it with Clover Configurator as per some instructions post installation (fix iMessage, etc)


Hope you can see something that might affect the system.


Thank you!




Link to comment
Share on other sites

It seems that I put a typo in my signature.  On the other forum when I selected the hardware, 280x was the closest card they had.  I actually have an R9 280, device ID 0x679a1002.  When I go to /S/L/E and search :


ledoktre$ grep 679a * -R
AppleKextExcludeList.kext/Contents/Info.plist:        <key>1136f0164186b3cfc7a679a32838009013a8a407</key>
AppleKextExcludeList.kext/Contents/Info.plist:        <key>1fc694654e6d2ce678a679a59f09c8d47d05535c</key>
AppleKextExcludeList.kext/Contents/Info.plist:        <key>d66e0d46679a695db45af9a62573471110efc57c</key>
AppleKextExcludeList.kext/Contents/Info.plist:        <key>fa16fd679ac37313292dfb655a656a5d006c282e</key>


Thats all it turns up.  There appears to be nothing in the AMD7000Controller.kext that I *thought* was in there.  I swear it was in there the other day, but I must have been smoking something when I checked the other day.   So if thats the case then, it leaves me with a couple of questions that I hope y'all might be able to help me with :


#1) If the problem why the card is not picking up is because of the fact the device ID is not present in any kext under /S/L/E, then why when I disable AMD7000Controller.kext does the system boot, just detecting the card as "Display 7MB" and not accelerated one iota?  As soon as I re-enable it, it goes back to not booting.


#2) Assuming this is the core issue, I assume with Clover I have to inject something someplace.  Where do I inject for the card (whats the best way to approach this) and what ID should I be using?  Im not sure where to begin finding a neighboring card.


Thanks again all,



Link to comment
Share on other sites

Trying this :




With ID 0x67981002 (280x, vs my 280).  They looked very similar, worth a shot!!!




Ok, with the primary graphics in bios set to Intel HD 4600, system will boot, and card appears to be detected as an AMD card now.  It does not show the ACD, nor does it turn on.  Could it be because ATI card requires to be primary over HD 4600?


The bad part is, when I switch the primary graphics to PCI slot 1 or 2 (the card showed as slot 2 when booted up- irregardless neither made a difference) it hangs during boot as it did before.  Tried ACD and a monitor on DVI port both - no difference.


Ive attached what the system see's when the ATI is not the primary display.  It is showing the new device id, so detecting should no longer be an issue.  What would then cause the hang during boot?


Any suggestions??


Link to comment
Share on other sites

I jumped on the chat here at InsanelyMac and people there had two things to say.  I needed to patch the FB (frame buffer?) to see any results or since the card was new, return it and get a different one (their suggestion was to get the real R9 280x, not the R9 280 I had).  Supposed to work OOTB.


What I did in the end was tried another video card I had on hand, an older Raedeon with regular DP not Mini DP, and it worked like a charm.  I bought a Mini DP to DP adapter from Amazon and called it good for now.  Later on I'll probably buy a new card, but I'll be sure to check out which id's are supported first.


Just wanted to write here in case it ends up helping anyone else.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...