Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
nerox

[Resolvido] Posso instalar o clover em cima do chameleon?

186 posts in this topic

Recommended Posts

Eae turma, tudo bem?

Queria saber se posso instalar o clover em cima do chameleon e se o mesmo não me traria problema nos arquivos contidos e já instalados no hackintosh.


Uso o mavericks 10.9.4
 

Share this post


Link to post
Share on other sites

Olá seja bem-vindo.

 

A resposta é direta, não, se fizer isso pode dar conflito.

A maneira mais segura de fazer isso, é apagar os arquivos "boot" e a pasta Extra (se usa Chameleon), dai sim pode instalar o Clover.

 

Vai instalar em Legacy ou UEFI, pois os dois são instalados em locais diferentes.

Share this post


Link to post
Share on other sites

Obrigado pela resposta allan, então, possuo 2 Hds:

1 - MAC OSX em GPT
2 - WIN 8.1 em MBR 

instalei o windows 8.1 em mbr pq o chameleon não tem boot em UEFI.


Você recomendaria instalar Legacy ou UEFI ?
 

Share this post


Link to post
Share on other sites

Sim, seria esses 2 arquivos.

 

E pra instalar em UEFI sua motherboard tem que ter suporte, pra sabermos coloque sua assinatura.

 

E pra ter o pleno desempenho do UEFI, vai ter que instalar o Windows 8.1 em GPT também.

Share this post


Link to post
Share on other sites

Pronto coloquei já, ela tem suporte para UEFI sim.

Vou fazer um backup e apagar os arquivos e depois tentar instalar o clover. Volto aqui para deixar um parecer. Obrigado desde já. 

Share this post


Link to post
Share on other sites

Grande allan, consegui instalar o clover até que foi tranquilo. Porem o áudio sumiu, baixei o clover configurator mas não entendi muito sobre ele, tem alguma maneira de eu ativar o appleHDA que usava com o chameleon? Lembrando que a kext está instalada.

Share this post


Link to post
Share on other sites

Bem pelo jeito acredito que usava alguma flag para o audio no boot.plist.

 

Se for isso, temos que inserir o layout do seu audio no config.plist.

 

Você usa DSDT?

Share this post


Link to post
Share on other sites

Então eu lembro que tive que deixar HDAEnabler=Yes e tive que muda o ID layout para 5 (de acordo com a kext)

Não uso DSDT.

Share this post


Link to post
Share on other sites

Então é isso que vai ter que inserir no config.plist.

 

Abra o config.plist com o Clover Config, e coloque assim:

Inject Audio > Layout ID = 4

Share this post


Link to post
Share on other sites

aqui você fala né?

140709022659506780.png

 

 

 

Acompanhando o mesmo raciocínio, nesta foto está injetando a placa gráfica do meu processador né? No caso tenho que desmarcar e marcar nvidia correto?

140709022950898818.png

Share this post


Link to post
Share on other sites

Isso mesmo, você pode colocar o numero 5.

Então, pode sim colocar nvidia, mas o que está sendo reconhecido no seu OS X, a nvidia ou Intel HD?

Share this post


Link to post
Share on other sites

De momento está reconhecendo o Intel HD, vou mudar para NVIDIA e ver no que dá espero não dar KP 

 

 

Uma notícia boa, o Som funcionou perfeitamente

 

 

Allan vc teria algum tutorial pra eu ver como injeto minha NVIDIA, tentei aqui e a tela ficou preta

Share this post


Link to post
Share on other sites

Nem mexi nelas allan, deixei do jeito que estava IGPEnabler=No e GraphicsEnabler=No, li que gtx serie 6 precisava deixar assim pra funcionar e funcionou .. será que se eu desmarcar o inject Intel deva funcionar ? 

Muito obrigado desde já, ficar sem som é complicado kkk

Share this post


Link to post
Share on other sites

Consegui allan, desmarquei o inject intel e o hack iniciou igual uma bala  :drool:  (aparece muito rápido os itens da mesa e janelas abertas) sinal que reconheceu.
Nossa muito feliz que deu certo, só tenho a te agradecer. Valeu mesmo e desculpa encher o saco rsrs... se não for muito incomodo agora é mais por estética, tem como aumentar a tela de boot pra full no clover? Eu consegui colocar 1920x1080 mas não ficou tela cheia

Share this post


Link to post
Share on other sites

Puxa cara que bom que funcionou, desculpa por não te dar atenção antes, pois estava fazendo uma faxina aqui em casa.

 

Faz assim, me manda seu config.plist pra eu dar uma olhada.

Share this post


Link to post
Share on other sites

Que isso meu jovem, não precisa se desculpar não. É a gente que enche muito seu o saco rsrs.. então não consegui postar aqui, mandei no send space:

https://www.sendspace.com/file/mxf4te

 

Vê o que vc consegue, se por acaso ver algo diferente me avise. Uma coisa que vi no clover configurator é uma opção de generate config, é confiável esse modo? (está um pouco diferente do config.plist que instalou)

Share this post


Link to post
Share on other sites

Vou dar uma olhada aqui, e já te mando.

 

E essa opção de gerar automaticamente um config.plist, eu não testei, por isso nem posso te dizer se é uma boa escolha.

Share this post


Link to post
Share on other sites

Está aqui: config.plist.zip

Está aplicado o patchAICPM, o que significa que não vai ter que aplica patch na kext AICPM, o Clover está fazendo esse trabalho agora.

 

 

Perguntas. Você usa SSDT? Tem problemas com o carregamento da kext AppleRTC?

 

Se tiver duvidas com relação as entradas e métodos usados no Clover, dá uma lida aqui sobre o que significa cada entrada do config.plist: Wiki Clover

Share this post


Link to post
Share on other sites

Puts allan, nem sei como te agradecer cara...esse aicpm pelo que li é muito complexo de configurar. Obrigado mesmo pela ajuda.
 


Está aqui: attachicon.gifconfig.plist.zip

Está aplicado o patchAICPM, o que significa que não vai ter que aplica patch na kext AICPM, o Clover está fazendo esse trabalho agora.

 

Acabei de olhar não tenho ela instalada pelo fato que estava dando problemas, agora posso instala-la sem me preocupar?
 

 

 

Perguntas. Você usa SSDT? Tem problemas com o carregamento da kext AppleRTC?

 

Se tiver duvidas com relação as entradas e métodos usados no Clover, dá uma lida aqui sobre o que significa cada entrada do config.plist: Wiki Clover

 

Não uso, pra falar a verdade nem sei se preciso, SSDT é um assunto que eu peno pra entender rsrs.

Creio que não tenho nenhum problema com a appleRTC, talvez apenas com hibernar em modo uefi.. tentei trocar o valor igual ao seu post lá, tentei 29, 21 e 57 e continuou na mesma.

Share this post


Link to post
Share on other sites

Mas se não tinha a AICPM estava usando o que? A NUllCPU? Se sim, delete a Null, e coloque a AICPM no lugar.

 

Para que um Hackintosh tenha o gerenciamento de energia de modo correto, é preciso um SSDT ou que o Bootloader faça isso, pois sem isso, pode ocasionar em aquecimento e alto/baixo consumo de energia, prejudicando o CPU.

 

E para checar se as kexts estão sendo carregadas, baixa o app Chameleon Wizard, dai na ultima aba, verá as kext que estão iniciando, digite uma referência no campo abaixo, por ex: rtc, dai se aparecer, é porque foi carregada.

 

E no seu caso, Hibernação vai ser a ultima coisa, já que tem outras para arrumar.

Share this post


Link to post
Share on other sites

Perdão allan, a AppleIntelCPUPowerManagement está instalada sim lembrando que encontrei ela e a AppleLPC no kextstat do terminal, não no chameleon wizard não achei o campo que vc disse, acho que funcionou no kextstat. Procurei pela null e não se encontrei na S/L/E acho que está certo nesta parte.

Sobre o SSDT achei isso no tópico do pimentel:


Passo-a-Passo

Criando a SSDT

Crie sua SSDT baseada no script do Pike R. Alpha

 

Rode no terminal esses comandos

 

curl -o ssdtPRGen.sh https://raw.github.com/Piker-Alpha/RevoBoot/clang/i386/libsaio/acpi/Tools/ssdtPRGen.sh
chmod +x ssdtPRGen.sh
./ssdtPRGen.sh

 

Após roda-lo você precisa colocar a Frequência Máxima e o Máximo TDP do seu CPU... veja essas infos sobre seu CPU aqui: http://ark.intel.com/
Esse é um exemplo de um i7 2600 que possui 3800Mhz(3,8Ghz) de frequencia maxima e 95 de TDP

 

sudo ./ssdtPRGen.sh 3800 95
Coloque a SSDT na pasta Extra e renomeie ssdt_pr para SSDT

Obs: Alguns CPUs já são auto-detectados pelo script, simplesmente o script já detecta a frequência máxima e o TDP, então se simplesmente após rodar o primeiro comando você for avisado para salvar a SSDT na pasta Extra(não pedindo para digitar sua max frequenc. e TDP como o guia manda), não se preocupe com isso, apenas confirme, pois o script já detectou tudo e criou sua SSDT e no momento já está pedindo para salvar o arquivo.

 

 

Está correto meu pensamento?

Share this post


Link to post
Share on other sites

Olá

 

Com certeza cara....

 

A única coisa que tu terá que fazer para usar SSDT(em breve vou atualizar esse guia para Clover, estou bem ocupado, mas vou fazer duas seções)

 

*Desabilitar no config.plist P e C States caso estejam habilitados no config.plist se não o SSDT não vai funcionar e terá KP

*Patchear AICPUPM, pelo que percebi a tua config.plist já tem a função habilitada;

*move a SSDT gerada com o scrip para a pasta patched, só não lembro o caminho direito agora, mas essa pasta ta dentro da pasta EFI no HDD ou na partição EFI

 

Só isso, pois o resto das configurações está no config.plsit. iMac 13,2 que notei como SMbios é o recomendável para i5 3ª gen....

 

Notei algumas coisas no config.plist

<key>ACPI</key>
    <dict>
        <key>SSDT</key>
        <dict>
            <key>DropOem</key>
            <true/>
            <key>Generate</key>
            <dict>
                <key>CStates</key>
                <true/>
                <key>PStates</key>
                <true/>
            </dict>
        </dict>
    </dict>

deveria ser assim

<key>ACPI</key>
    <dict>
        <key>SSDT</key>
        <dict>
            <key>DropOem</key>
            <true/>
            <key>Generate</key>
            <dict>
                <key>CStates</key>
                <false/>
                <key>PStates</key>
                <false/>
            </dict>
        </dict>
    </dict>

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×