Jump to content

Troubleshooting Installing Mac OsX on a new DELL XPS 15 9530 with touchscreen


Zooble
 Share

7 posts in this topic

Recommended Posts

Hello everybody,

 

Preambule : I'm a French old guy, practicing IT since 1981,  I 'm trying to use my best English, but you know that frogs are not so good in Sheakespeare Langage... and thank you all for all your help for others on this good site.

 

A few weeks ago, I bought a marvelous machine, a Dell XPS 15 with the new HQ screen (3200x1800 and touchable). I would like to use it for developpement in Android and perhaps for IOS.

 

I manage to install Ubuntu on it in Daul boot with Windows 8.1.

 

I did it quite well, but it took me 1 or 2 weeks to make it work well.

 

Now I'm trying to install OS X on it, but after a lot of difficulties, I finally make it.

 

But not completely. I've tried other way than MyHack to install Mavericks : Clover and T...(self censured).

 

With the 2nd one, I was able with a USB drive to boot and to install Mavericks on 2 different drives :

 

- One on the 1 To Hard drive on a HPS+ partition I made before 50 Go (the same drive wher Ubuntu and Windows 8.1 are installed with UEFI boot)

 

-Another one on the 32 Go SSD drive to be sure not to have any conflict with Windows (MBR or thinks like that / i think there is no MBR as it boot on UEFI)

 

Impossible to boot : I always have troubles.

 

I will explain the troubles, but first of all, I must say that I also had problem with the install USB drive : immediate reboot after trying to load the installer :

 

- I had to patch the mach_kernel with a perl script indicated by

 

http://www.insanelymac.com/forum/topic/293503-haswell-early-reboot-mavericks-locked-msrs-and-hp-envy-15-j063cl-i7-4700mq/

 

and I don't really know if it was correct (I only use the first script, and that's all).

 

- It was the only way to be able to make this installer works with also -x -f flags (installer was made with Mountain Lion to install Mavericks)

 

As indicated in this previous topics, immediatly after installing, I changed the mach_kernel of my drives with the one which allowed me to boot with the installer. But it has never worked.

 

Finally, coming on insanelymac, I manage to use your tool to try to make an install.

 

As explained on the MyHack topic, I made a USB drive with a .dmg file from Mountain Lion.

 

I the tried to boot with it and arrive a the level where we have to choice the drive to use.

 

I tried to use different flags, but nothing worked. I decided to try to change the mach_kernel with the one used on my other USB drive (made with Uni....) and to test it. Same things. And if I try to boot with my SSD partition I installed before, I get the same kind of result...

 

Here are the things I get :

 

Boot options :

 

nothing :

 

post-1319967-0-48442000-1395323848_thumb.jpg
 
-x
 
post-1319967-0-29245900-1395323868_thumb.jpg
 
-x -f :
 
post-1319967-0-75280400-1395323910_thumb.jpg
 
-x PciRoot=2
 
post-1319967-0-46523500-1395323902_thumb.jpg
 
-x PciRoot=1
 
post-1319967-0-42594700-1395323895_thumb.jpg
 
-x PciRoot=0
 
post-1319967-0-03797400-1395323879_thumb.jpg
 
-x GraphicsEnabler=No
 
post-1319967-0-74060900-1395323859_thumb.jpg

 

 

 

I don't really know what I am doing, and what I have to do first. Is ther anyone who can help me, orienting me where to begin. the only thing I undestand is that it seems ther is somme USB issues.

 

But how to solve this out, do I have to change the kernel, to boot with another flag.

Is it a good thing to have patched the mach_kernel ? ...

 

To finish my laptop :

 

---------------------------------------------------------------------------

DELL XPS 15 9530

motherboard : DELL - DDR3 SD-RAM 16 Go

Chipset : Haswell

Processor : i7-4702HQ @ 2.2 GHz

HDD 1 To

SSD 32 Go RAM

Mouse : external

3 USB 3.0 ports

1 USB 2.0 port

2 graphic Cards : Intel HD4600 + NVidia GeForce GT 750 M (dont know how it switches from one to the other !)

 

-------------------------------------------------------------------

 

Thanks for anyone  that can help.

 

Hoping that it will also help the future owners of this splendid machine...

 

P.S. Sorry if you can't see the pictures details, I thought it was possible to watch the original.

 

Bien le bonjour !

 

Zooble

post-1319967-0-48442000-1395323848_thumb.jpg

post-1319967-0-74060900-1395323859_thumb.jpg

post-1319967-0-29245900-1395323868_thumb.jpg

post-1319967-0-03797400-1395323879_thumb.jpg

post-1319967-0-42594700-1395323895_thumb.jpg

post-1319967-0-46523500-1395323902_thumb.jpg

post-1319967-0-75280400-1395323910_thumb.jpg

Link to comment
Share on other sites

Hi everybody,

 

As I had no answer, I've spent all the afternoon to follow the tutorial for creating a new install USB Drive with Chameleon (seems to give quite the same thing as "MyHack" ) :

 

http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

 

Great tool !

 

But always the same result --> Immediate reboot after trying to boot on this key.

 

Anyone has an idea of what I could do ?

 

Just to be able to enter the install programm and to use the tools of it : terminal...

 

Have a good day and a good week-end.

 

Zooble

Link to comment
Share on other sites

HI,

 

Finaly my DELL started correctly (with -x) on the hard drive !!

 

What was the solution ? 

 

to patch the mach_kernel file at the / directory, as explained in the different articles from RehabMan :

 

http://www.insanelymac.com/forum/topic/293503-haswell-early-reboot-mavericks-locked-msrs-and-hp-envy-15-j063cl-i7-4700mq/

http://racerrehabman.wordpress.com/2013/11/25/maverickshaswell-kernel-patch-for-early-reboot/

 

Remember to allow the hidden files to be visible in typing this in the Terminal :

 
defaults write com.apple.finder AppleShowAllFiles TRUE 
killall Finder 
 
then apply the patch as RebhabMan explains it (only the first one). In details :
 
# in Terminal, assuming your USB is called Installer
cp /Volumes/Installer/mach_kernel ~/Desktop/mach_kernel_backup
cp
/Volumes/Installer/mach_kernel ~/Desktop/mach_kernel
cd
~/Desktop

# now copy/paste one or more of the perl patches from above into Terminal
# for xpcm related panic/reboot 10.9.x kernel

perl -pi -e 's|\x74\x6c(\x48\x83\xc7\x28\x90\x8b\x05..\x5e\x00\x85\x47\xdc)\x74\x54(\x8b\x4f\xd8\x45\x85\xc0\x74\x08\x44\x39\xc1\x44\x89\xc1)\x75\x44(\x0f\x32\x89\xc0\x48\xc1\xe2\x20\x48\x09\xc2\x48\x89\x57\xf8\x48\x8b\x47\xe8\x48\x85\xc0\x74\x06\x48\xf7\xd0\x48\x21\xc2\x48\x0b\x57\xf0\x49\x89\xd1\x49\xc1\xe9\x20\x89\xd0\x8b\x4f\xd8\x4c\x89\xca)(\x0f\x30\x8b\x4f\xd8\x0f\x32\x89\xc0\x48\xc1\xe2\x20\x48\x09\xc2\x48\x89\x17\x48\x83\xc7\x30\xff\xce)\x75\x99(\x5d\xc3)\x90{7}|\x74\x73${1}\x74\x5b${2}\x75\x4b${3}\x66\x81\xf9\xe2\x00\x74\x02${4}\x75\x92${5}|g' mach_kernel

# patched mach_kernel is now at ~/Desktop/mach_kernel
sudo cp mach_kernel /Volumes/Installer/mach_kernel
 
 
When it's done, just control that the md5 is the correct one (in my case, it was ok on the USB drive, but not on the Hard drive, reason why it didn't work. After having controlled the md5 and copy the correct mach_kernel file, it started correctly).
 
md5 mach_kernel
 
at that time, for me, it works with    -  xcpm patched: aeb9203dc754afac23bf9696833032fe
 
post-1319967-0-39697800-1395690576_thumb.jpg

 

Now, as I'm a newbie, I will have a lot of work to configure correctly all the kext files...
 
Zooble.

post-1319967-0-39697800-1395690576_thumb.jpg

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 4 weeks later...

Hello,

 

sorry to be long to answer. I must admit that I gave up with all of this at the moment, because it seems to me too complicated.

 

I'm not able to answer to your question, as I don't know how to make the settings for that (I didn't see anything in the BIOS for that)

 

It seems to me so difficult to find a simple procedure to test what ktest files are needed or not, and I don't find anything very clear about this on the web...

 

(I think that, as I am able to start up with -x, it would be possible to check one by one the different kext files, but it impossible to do : too long)

 

So at the moment, I give up.

 

Thanks a lot for your answer shiecldk

Link to comment
Share on other sites

  • 2 months later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...