Jump to content
About Just Joined group Read more... ×
Dontview

Sleep issue since 10.9.2 and ssdtPRGen v12.0

3 posts in this topic

Recommended Posts

Hallo everyone,

since 10.9.2 my Hackintosh crashes, when I wake it from sleep.
In 10.9.1 everything was just fine. I just updated the OS and ssdtPRGen.

Anonymous UUID:       1CA4801E-F7E3-DXXXXXXXXXXXXXXXX

Tue Mar  4 14:21:58 2014
panic(cpu 3 caller 0xffffff80002dbe2e): Kernel trap at 0xffffff80002a3278, type 13=general protection, registers:
CR0: 0x000000008001003b, CR2: 0x00007fff55564ea8, CR3: 0x0000000012552004, CR4: 0x00000000001606e0
RAX: 0xffefff800aee4460, RBX: 0xffffff800aee2018, RCX: 0xffffff8018b44000, RDX: 0x0000000000000821
RSP: 0xffffff80f69bb9d0, RBP: 0xffffff80f69bba00, RSI: 0x0000000000004000, RDI: 0xffffff801a3d1000
R8:  0x00000000000051eb, R9:  0x0000000000000000, R10: 0x00007fff722313e0, R11: 0x0000000000000246
R12: 0x0000000000000000, R13: 0x0000000000004000, R14: 0x0000000000004000, R15: 0xffffff801a3d1000
RFL: 0x0000000000010206, RIP: 0xffffff80002a3278, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x00007fff55564ea8, Error code: 0x0000000000000000, Fault CPU: 0x3

Backtrace (CPU 3), Frame : Return Address
0xffffff80eec45df0 : 0xffffff8000222fa9 
0xffffff80eec45e70 : 0xffffff80002dbe2e 
0xffffff80eec46040 : 0xffffff80002f3326 
0xffffff80eec46060 : 0xffffff80002a3278 
0xffffff80f69bba00 : 0xffffff800026cddb 
0xffffff80f69bbb90 : 0xffffff80003d2773 
0xffffff80f69bbbf0 : 0xffffff800041502d 
0xffffff80f69bbcf0 : 0xffffff800056b02a 
0xffffff80f69bbd80 : 0xffffff80003fd9b1 
0xffffff80f69bbe00 : 0xffffff80003f3565 
0xffffff80f69bbe50 : 0xffffff80005efa7e 
0xffffff80f69bbef0 : 0xffffff80005ef88f 
0xffffff80f69bbf50 : 0xffffff800063e363 
0xffffff80f69bbfb0 : 0xffffff80002f3b26 

BSD process name corresponding to current thread: taskgated
Boot args: -v slide=0 

Mac OS version:
13C64

Kernel version:
Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64
Kernel UUID: 9FEA8EDC-B629-3ED2-XXXXXXXXXXXXXXX
System model name: iMac14,2 (Mac-27ADBB7B4CEE8E61)

System uptime in nanoseconds: 327056527299
last loaded kext at 53573100098: com.apple.filesystems.msdosfs	1.9 (addr 0xffffff7f817ed000, size 65536)
loaded kexts:
com.nvidia.CUDA	1.1.0
com.intel.driver.EnergyDriver	2.0
at.obdev.nke.LittleSnitch	4057
org.hwsensors.driver.GPUSensors	944
org.hwsensors.driver.LPCSensors	944
com.kext.HDAEnabler	1.0.0d1
com.insanelymac.driver.AppleIntelE1000e	2.4.14
org.hwsensors.driver.ACPISensors	944
org.netkas.driver.FakeSMC	944
org.hwsensors.driver.CPUSensors	944
org.hwsensors.driver.FakeSMCKeyStore	944
com.apple.filesystems.msdosfs	1.9
com.apple.driver.AudioAUUC	1.60
com.apple.iokit.IOUserEthernet	1.0.0d1
com.apple.iokit.IOBluetoothSerialManager	4.2.3f10
com.apple.driver.AppleUpstreamUserClient	3.5.13
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.driver.AppleMCCSControl	1.1.12
com.apple.driver.ApplePlatformEnabler	2.0.9d1
com.apple.driver.AGPM	100.14.15
com.apple.driver.X86PlatformShim	1.0.0
com.apple.driver.AppleHDAHardwareConfigDriver	2.5.3fc1
com.apple.driver.AppleHWAccess	1
com.apple.GeForce	8.2.4
com.apple.driver.AppleHDA	2.5.3fc1
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleLPC	1.7.0
com.apple.driver.Apple16X50ACPI	3.1
com.apple.driver.AppleIntelMCEReporter	104
com.apple.driver.AppleIntelFramebufferAzul	8.2.4
com.apple.nvidia.NVDAStartup	8.2.4
com.apple.filesystems.ntfs	3.11
com.apple.filesystems.autofs	3.0
com.apple.iokit.SCSITaskUserClient	3.6.6
com.apple.driver.AppleFileSystemDriver	3.0.1
com.apple.driver.XsanFilter	404
com.apple.BootCache	35
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
com.apple.iokit.IOAHCIBlockStorage	2.5.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.driver.AirPort.Atheros40	700.74.5
com.apple.driver.AppleUSBHub	666.4.0
com.apple.driver.AppleUSBXHCI	670.4.0
com.apple.driver.AppleACPIButtons	2.0
com.apple.driver.AppleUSBEHCI	660.4.0
com.apple.driver.AppleAHCIPort	3.0.0
com.apple.driver.AppleRTC	9.5
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleAPIC	1.7
com.apple.security.quarantine	3
com.apple.nke.applicationfirewall	153
com.apple.AppleIntelCPUPowerManagementInfo	1
com.apple.iokit.IOSurface	91
com.apple.iokit.IOBluetoothFamily	4.2.3f10
com.apple.driver.AppleSMBusController	1.0.11d1
com.apple.iokit.IOSMBusFamily	1.1
com.apple.iokit.IOAcceleratorFamily	98.14
com.apple.nvidia.driver.NVDAGK100Hal	8.2.4
com.apple.nvidia.driver.NVDAResman	8.2.4
com.apple.driver.DspFuncLib	2.5.3fc1
com.apple.vecLib.kext	1.0.0
com.apple.iokit.IOAudioFamily	1.9.5fc2
com.apple.kext.OSvKernDSPLib	1.14
com.apple.iokit.IONDRVSupport	2.4.1
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.driver.AppleHDAController	2.5.3fc1
com.apple.iokit.IOHDAFamily	2.5.3fc1
com.apple.driver.AppleSMBusPCI	1.0.12d1
com.apple.driver.Apple16X50Serial	3.1
com.apple.iokit.IOSerialFamily	10.0.7
com.apple.AppleGraphicsDeviceControl	3.4.35
com.apple.iokit.IOAcceleratorFamily2	98.14
com.apple.iokit.IOGraphicsFamily	2.4.1
com.apple.driver.X86PlatformPlugin	1.0.0
com.apple.driver.AppleSMC	3.1.8
com.apple.driver.IOPlatformPluginFamily	5.7.0d10
com.apple.kext.triggers	1.0
com.apple.iokit.IOSCSIBlockCommandsDevice	3.6.6
com.apple.iokit.IOUSBHIDDriver	660.4.0
com.apple.iokit.IOUSBMassStorageClass	3.6.0
com.apple.driver.AppleUSBComposite	656.4.1
com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.6.6
com.apple.iokit.IOBDStorageFamily	1.7
com.apple.iokit.IODVDStorageFamily	1.7.1
com.apple.iokit.IOCDStorageFamily	1.7.1
com.apple.iokit.IO80211Family	630.35
com.apple.iokit.IOAHCISerialATAPI	2.6.1
com.apple.iokit.IOSCSIArchitectureModelFamily	3.6.6
com.apple.iokit.IOUSBUserClient	660.4.2
com.apple.driver.AppleEFINVRAM	2.0
com.apple.iokit.IONetworkingFamily	3.2
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.iokit.IOUSBFamily	675.4.0
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOAHCIFamily	2.6.5
com.apple.security.TMSafetyNet	7
com.apple.security.sandbox	278.11
com.apple.kext.AppleMatch	1.0.0d1
com.apple.iokit.IOReportFamily	23
com.apple.driver.DiskImages	371.1
com.apple.iokit.IOStorageFamily	1.9
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleACPIPlatform	2.0
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.corecrypto	1.0
Model: iMac14,2, BootROM IM142.0118.B00, 4 processors, Intel Core i5, 3.19 GHz, 8 GB, SMC 2.15f2
Graphics: NVIDIA GeForce GTX 650, NVIDIA GeForce GTX 650, PCIe, 1024 MB
Memory Module: BANK1/DIMM1, 8 GB, DDR3, 1600 MHz, A-DATA Technology, unknown
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x3112), Atheros 9380: 4.0.74.0-P2P
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: HL-DT-ST DVDRAM GH22NS40
Serial ATA Device: WDC WD6400AAKS-00A7B0, 640,14 GB
Serial ATA Device: ST9500325AS, 500,11 GB
USB Device: Hub
USB Device: Hub
USB Device: Hub
USB Device: External USB 3.0
USB Device: Hub
USB Device: Hub
USB Device: USB2.0 Hub
USB Device: USB Receiver
USB Device: USB Keyboard
USB Device: Hub
Thunderbolt Bus: 

Share this post


Link to post
Share on other sites
Advertisement

Since you have made 2 changes and now you are seeing the crash try and narrow down what the cause is. I would roll back the SSDT and re-apply the previous one that you were using when no crashes were occurring. 

Do you still have crashes when using the old previous SSDT and 10.9.2 ? 

Share this post


Link to post
Share on other sites

Hey,

 

thanks for your quick response. 

I didn’t rollback the OS, but I did test sleep without and with the generated ssdt.aml.

 

It seems that this caused the issue in my case. Now I just use clover c and p state generator in order to get speed steps. With and Without ssdt I just get 800 mhz and the turbo states. So, it doesn’t really matter what to choose, or does it?

 

Hey,

 

finally iI found the solution for my issue. In fact, it has nothing to do with Pike’s SSDT or the update to 10.9.2.

 

It simply was the Efi partition. Somehow it was broken. 

From now on, I changed the settings so it won't mount to prevent similar problems.

I can just advice to repair this partition after any updates (OSX and Clover). 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By ankarastrix
      I have a problem, I select the "sleep" option from the menu, the mac goes to sleep but does not "wake up" (screen). I can't even change smbios from iMac17.1 to iMac18.1 + when I change the mac it boots, the progress bar and apple icon are visible and then the screen goes off.
      config.plist
    • By melamangiata
      Hello, these are my pc specs:
       
      i5-4460
      H97M-D3H Gigabyte
      HD 4600 as a gpu
      4gb DDR3
      SSD 256gb
       
      I attach my EFI folder, i removed only the mac serial.
       
      I installed Catalina 10.15.6 with OpenCore 0.6.0, every things is working except for the wakeup.
       
      I put the pc in stop form the apple icon, the monitors turns off, the pc turns "off".
      When i push a keyboards button the pc turns on also the monitors turns on, but the screen is still black. Force rebooting is required. Any advice?
       
      Thank you.
       
       
       
       
      EFI.zip
    • By amin321
      since the installation of macOS, the most observable problem is awaking from sleep failure, I almost tried every related thing like mapping USB ports, appropriate ig-platform-id and disabling dgpu , all of those does not help at all that report on panic gets triggered after force shutdown and reopening the system (as the system does not wake from sleep) dell g3 3590 intel core i7 9750h *iGPU : Intel UHD 630 *RAM : 16GB, 2x8GB, DDR4, 2666MHz *Storage : 256GB M.2 PCIe NVMe Solid Stat e Drive (Boot) + 1TB 5400 rpm 2.5" SATA Hard Drive (Storage) can anybody give me a tip on that
    • By jrbros1
      Hi there,
       
      So I have my Windows computer, used a USB with Clover setup to boot into Mojave OS that I installed on the SD card in the computer. The world was a great place and all was well!

      Then I did the steps to partition the pc system to now include the additional drive that I would put Clover on. Here's where I messed up: Instead of directly copying over the full Clover folder into the EFI folder of the new drive (which just had the Boot & Microsoft folders in it), I replaced the EFI's boot folder with Clover's boot folder. So the EFI folder now contains a Microsoft folder, a Clover folder, and Clover's Boot folder only.

      Now, I only can access the Clover boot up menu, the macOS, but no Windows at all. Even if I go into BIOS and pick Windows Boot Manager or Partition 1 for the start up, I get a black screen for both. I can still access the macOS as well as Shell, but I don't know what that does other than displaying all of the yellow text fly by..

      Is there a kind soul out there that can help me get Windows back to boot? Keep in mind I'm a bit of a newbie here so laying out the common-sense steps would be helpful!

      Thank you in advance!
    • By james2058
      Hello guys!
      I have a Asus Zenbook with the following characteristics:
      Model: ASUS Zenbook UX310UQ
      CPU: Intel Core i7-7500U CPU @ 2.70GHz
      IGPU: Intel HD Graphics 620
      RAM: 8GBx2 => 16GB RAM Bus 2133
      Wifi: Replaced with DW1560.
      Clover: Clover 5120
      OS: 10.15.6
      UEFI/LEGACY: UEFI
      Storage: SSD Crucial 500GB
      Everything works fine!

      I have the WiFi/Bluetooth chipset DW1560 (DCM20702A) and a Logitech K380 Keyboard and magic mouse. My Hackintosh is sleeping fine only problem is that it won't wake from sleep on key presses. I already tested this USB port with a normal keyboard and the result was that it wakes up my Hackintosh on key presses. And in system settings the Bluetooth wake option is enabled, too.
      Has someone an idea where the problem could be or which additional settings I have to verify?
      Thank you all
       
×