Jump to content

myHack - ASrock B85M-Pro4 - i5 4570 - Installer Problems


5 posts in this topic

Recommended Posts


I was running a myHack Installation 10.8.X on my old system before, then my MB died and i got a completely new system.

Now having some free time i tried to install osx86 again..


Current System:

ASRock B85M-Pro4

Intel Core i5 4570

16GB DDR3 1600 Ram

AMD Radeon HD 7970 (XFX R7970 DD Ghz Edition)


The Stick is stock myHack 3.3.1, no extra kext to /E/E, no dsdt.aml, no smbios.plist.




Im using latest myHack (3.3.1)  + Maveryick InstallESD.dmg from a original iMac, downloaded through the appstore. I used the System at Work so i dont have access to it all the time.


Well after several Problems i finally got the Installer Stick to boot.


First i had the Haswell Kernel Problem (http://www.insanelymac.com/forum/topic/293503-haswell-early-reboot-mavericks-locked-msrs-and-hp-envy-15-j063cl-i7-4700mq/) but got it booting past the instant reboot with the modified kernel


Then i ended up at a blank white Screen (after the Apple Boot Screen), i remembered this from my old System (AMD Radeon HD6850), removed all the AMD related kexts from the installer and now finally got into the Installer GUI.


But then, after selecting the Installer language the installer crashed with the Log file i have attached to this post.

The funny thing is, its looks like the errors from when i tried the stick first on a Dell Optiplex 7010 (i3, 3XXX) at work. I havent changed any BIOS Settings on this PC. I just wanted to see if the stick boots fine before taking it home... though it would be HW/Bios Settings related.


Well now i wonder maybe the install files are broken? or is it after all my system configuration?

The Installer Crashes but is fully responsive, i could attach a USB Stick, format it and save the log file on it.


Just wondering where i should start troubleshooting, my System or create a new myHack stick at work with a redownloaded Mavericks system? (maybe even try a different usb stick)


Thanks for any usefull replys!


Link to comment
Share on other sites

Well just wanted to copy the modified kernel on the USB stick from my Windows System and no luck.

I tried MacDrive and Paragon HFS+ but both only mount the stick as a Drive labeled EFI (200MB).

I partitioned the stick this time with GUID+HFS+, before i had it MBR. i guess this is the problem...


Any way to access the stick without a running OSX System?



Well i tried a linux live cd and could access the files, switched the kernel and removed the AMD kexts from /S/L/E but now the installer hangs again at:

BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 no such file or directory



well i will try to create a new stick again the next time i get the chance at work, format the stick MBR PartitionTable and will try to do exactly the same steps as before when it almost booted up fine.

Link to comment
Share on other sites

  • 2 weeks later...

replacing the mach_kernel is a last resort please use clover boot loader instead use KernelPm=true for haswell. use dart=0 to disable vt-d in your cpu. it would be a good idea to put updated fakesmc and update the bootloader in MyHack usb installer before install good luck

Link to comment
Share on other sites


  • Create New...