Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  

[WiP] - Dell Studio XPS 1640 - Triple boot MacOSX 10.9 Mavericks / Win 8.1 Pro / Linux

4 posts in this topic

Recommended Posts

Hi Everyone,


I decided to create this thread with the objective to create a full install guide for this awesome laptop I've been using for 4 years now and that's been put aside since I got my first iPad 1 year ago.


Last time I checked InsanelyMac, it was considered almost impossible to create a hackintosh out of the XPS 1640, but my recent readings tend to prove me the opposite.

I am sure I will have tons of questions that I'm sure I'll find an answer for here - which is why I opened a thread for this.


Without further ado, my config (extract from Everest):


Dell Studio XPS 1640 (2011 model)

  • Intel Core2Duo P8600 2,4 GHz
  • RAM: 4 Go
  • Video: ATI Mobility Radeon 4670
  • HD: 500Go 7200rpm
  • Full HD (1920x1080) 16" screen
  • Ethernet: Broadcom Netlink GigaEth
  • WiFi: Intel 5300 AGN
  • Bluetooth
  • Audio: Intel 8280
  • Multicard reader: Ricoh (MMS, SD)
  • Webcam
  • WinTV Nova (TV-Tuner) --> OK if this one doesn't work  :lol:


Finished backing up my data.


Downloaded Mavericks from the app store on a VM under Windows

Have my Win 8.1 USB

Downloaded Ubuntu 13.10


First, I'll try and use Clover bootloader, checking if the BIOS supports UEFI...

I'll start with: http://www.insanelymac.com/forum/topic/293574-beginners-guide-to-uefi-tripledual-boot-os-x-windows-and-linux-kali-on-an-single-true-gpt-ssd/?hl=%20triple%20%20boot%20%20kali


... to be continued...

Share this post

Link to post
Share on other sites

Here we go....  :no:


I decided to separate my project into 2 parts :

  1. install a fully working Mavericks on my laptop (Forgot to tell I'm currently using for the Mac stuff a VM with ML 10.8.2 installed on my desktop PC)
  2. Deal with the Multiboot part
    1. get the 3 OSs running together
    2. get the 3 OSs running together without needing an USB to boot (i.e installing a working bootloader on the HD)
    3. get the 3 OSs installed from the same USB stick.


First things first:


I don't think the Dell A15 Phoenix Firmware/BIOS (I just upgraded) supports UEFI, at least, there is no option about this in the BIOS settings.


So I tried this: http://www.insanelymac.com/forum/topic/293925-non-uefi-guide-to-installing-os-x-mavericks-with-clover/

(really like the look & feel of Clover for those asking why not using a non-UEFI bootloader like Chimera/Charmeleon instead)


But I'm stuck at the part where I need:

  • to edit the config.plist. I really don't know what to put in there for my Dell...
  • the SDST.aml file (cannot find that)

I followed the guide step by step, except for the above 2 issues

Installed clover bootloader into my USB key.

I configured the EFI using this DSDT.aml file from: http://www.osx86.net/files/file/1557-dsdt-for-dell-studio-xps-1640/

When I boot from my USB and start the OS X Mavericks install (in verbose) I get a "cannot install because your system is not supported" message.


Any thoughts?

Share this post

Link to post
Share on other sites


(edited my signature btw :))


Thank you mate... Now I can't wait to go home to test this !!!

I'll edit my message to report success (hopefully) ... or ask more questions :-)



Used your config.plist ; I didn't copy my DSDT.aml into the EFI partition for now.


Booting from Clover with injected kexts is now working and I get the "Welcome" screen (at - oh my God - the correct resolution!!!) but I'm still unable to use neither my touchpad nor my keyboard. Will try to load a voodoo kext and see what it gives. 



Used the kext from here:


Keyboard's now working but still no luck with the trackpad.


So I copied all kexts from here:


No more luck....


Actually I made a big mistake and left the old Elan ApplePS2Controller.kext instead of taking the one from the 2nd link just above... I now have both my trackpad and mouse working....


About to re-partition my hardrive and install Mavericks now, wish me luck...




1 hour later... Mavericks is WORKING!!!!!!!

  • No sound
  • No WiFi
  • No Bluetooth
  • Video on webcam OK (launched Facetime & PhotoBooth)

The system is SUPER fast (using a standard HDD)






Installed Clover to my laptop's HDD, was working fine but still I needed to hit space and then choose "boot without cache with kexts injected".


So I tried to continue and follow this guide:



I installed the kexts (same as the ones I had on my USB "EFI/Kexts/10.9/" directory) to S/L/E using KEXT Wizard

I also renamed my boot folder in my HDD EFI partition as suggested in the above guide.


Now when I boot from my HDD, I get an error at boot, Clover is not even loaded...

I tried to boot from the USB using the standard boot without cache with kexts injected but it freezes on an all grey screen until it displays some glinches...


I'm stuck now and trying to manually remove kexts from the HDD. and rename back my boot folder to "boot"... using the USB installer.


The problem was due the renamed boot folder - must have misunderstood the statement on the other guide.

I used the USB installer again (Terminal --> mounted the USB/EFI partition --> renamed to 'boot') and restarded.

NOW: Mavericks booting without even hitting a key!!


Will try to resolve my audio / WiFi issues now, if someone has ideas, please drop them here.



Still no luck with audio when everybody says it's working... :shock:

For me it is only able to play sound through one of my airplay compatible devices but not through the speakers ; no entry device detected either.

Sound now working!!! I just used Clover configurator to change my SMBIOS settings... to MacBookPro 5.5 (instead of 7.1)

  • For the Intel 5300 AGN WiFi Adapter, I think I'm gonna need to change my mini PCI-e card to another WLAN adaptor.
  • I also figured out my Ricoh internal card reader is not working.
  • Bluetooth still no working
  • When the laptop goes to sleep, God, it's waking up SOOOOO damn fast, but I'm loosing the trackpad (keyboard OK)
  • Inside Clover configurator, in the GUI tab, when I try to change the theme, nothing happens, I still get the same theme I installed when creating the EFI Clover partition on my HDD, whatever theme I chose eventhough I copied the themes in the EFI/Themes folder...

Can someone please help?


Try running the Clover installer on your HD again and make sure all themes are selected for install as well as the Clover Prefpane.  After this, open the prefpane in System Preferences and choose the desired theme there....






Re Non Functional Devices: run System Info App (needs internet connection to access its database) and determine which kexts are available for your hardware - post by Cassio.

Re Wifi: Cards based on Atheros AR5B91 & Broadcom BCM94321MC chipsets will work for all 3 OS.

Re Sleep Issue:  Try adding boot flag darkwake=0 to your config.plist (under boot tab if you open with Clover Configurator) or a different PS2Controller.kext.  I can't guarantee either will work - sleep issues are notoriously difficult to diagnose & fix.

Share this post

Link to post
Share on other sites

Please help me I have the same notebook as imothep77 but my resolution is 1600x900 so is a different panel.I get scrambled LVDS and I dont know why.You are the only one that can help me, I tried with clover config of other people that own STUDIO XPS 1645 OR STUDIO XPS 1647 and failed to get working resolution.Insted I get this.Please send me your clover folder and s/l/e folder archived to download if you succeded QE/CI and correct resolution with the 4670.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.