Jump to content

T61 Install to 10.9 using MyHack (Type-7659)


Chamillion
 Share

10 posts in this topic

Recommended Posts

**Get a copy of Mavericks and have a 8gb+ flash drive ready

 

Files Needed: T61_mavericks (7zip file)

 

--------------------------------------------------------------------

 

*Notes: step 11-12 is for a single boot setup for Mavericks. If you have another partition setup as a bootloader, install the boot file to it.

 

 1. Extract a InstallESD.dmg from a Mavericks Installer

 2. Use MyHack to create the 10.9 install onto a 8gb+ usb drive (MyHack drive)

 3. Install Chameleon 2.2 with the FileNVRam module in customization onto the MyHack drive from the apps folder

 4. Copy and replace the boot image from the Chameleon folder to the MyHack Install drive

 5. Copy the DSDT.aml, org.chameleon.Boot.plist, and smbios.plist to the /Extra folder of the MyHack drive

 6. Copy the kexts from the Extra/Extensions folder to the Extra/Extensions folder of the MyHack drive

 7. Reboot and use Disk Utility to prepare the selected disk. Install Mavericks and when it asks if you want to use your own Extra folder, select yes and point to the Extra folder of the MyHack drive

 8. Reboot with the flash drive still inserted, boot with -f -npci=0x2000 -PCIRootUID=1

 9. Complete walkthrough tour/setup and force shutdown (power button)

10. Once again with the flash drive inserted, boot with -x -npci=0x2000 -PCIRootUID=1

10. Install Chameleon and add FileNVRAM module, npci=0x2000, PCIRootUID=1, and ignore caches in customization

11. Open Finder preferences and select Hard Disks to be visible

12. Copy and replace the boot file from the chameleon folder to the Mavericks partition (you may have to open a desktop item to find it)

13. Run Disk Utility and repair permissions on the Mavericks partition

14. Copy (this) folder to the Desktop (T61_mavericks)

14. Run the Post Install script and reboot

16. Run the VoodooHDA pkg script in the apps folder to finalize installation

 

*Notes: If the installer glitches up before/during the install, reboot. This is a problem many are having with this OS version. Sometimes pressing the Enter key wakes it up, but it's unreliable.

 

*Notes: If at any time you get a blank window during setup, click a the apple logo or some other menu item

 

*Notes: If you lose WiFi, go to Network Preferences and in the Advanced menu's TCP/IP tab click "Renew DHCP Lease."

 

----------------------------------------

 

*Still working on graphics problem (X3100 drivers) but it is as stable as I could get it. You may have to take out the X3100 kexts from SLE? Not sure if they interfere with the GMA 950 kexts. I will update this guide as soon as better 64-bit X3100 drivers get released :(

 

Haven't worked on sleep/restart issue because without graphics it's kind of pointless. This install freezes a lot still without the graphic drivers.

----

 

Leave comments below if you want to be part of this

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 months later...
  • 6 years later...

Resurrecting dead topics from 6-7 years ago? myHack v3.3.1 does not run in or for High Sierra; only in Mavericks max. and for Mac OS X Lion to OS X Mavericks only. For Snow Leopard, use myHack v3.1.2.

 

But you'd be completely wasting your time if your T61 is fitted with GMA X3100 graphics. That's last supported in Lion 10.7.5 and in 32bit kernel mode. You could run ML with special MLPF hack that basically reverts ML back to DP1 fat-binary kernel & kexts + some Lion 10.7.5 files and therefore supports 32bit kernel mode. It's not bug-free though, far from it.

 

I'd put any X3100 laptop to rest today, it's not worth it at all in 2020. At best, fit this obsolete laptop with an SSD, max. RAM and run Win10 64bit on it.

 

if you have the nVidia model, you can run up to El Capitan if you have a Merom CPU, up to macOS High Sierra if you have a Penryn CPU (high-end T9300/T9500 recommended). Mojave and Catalina are also possible on models with Penryn CPUs but require tricks. These can be installed and run with Clover (or Enoch to a certain limit).

 

Edited by Hervé
Link to comment
Share on other sites

I went in my old archive & pulled out an old Macbook Pro that my memory reminded me just flat out died on me. Wouldn't even turn on...

 

After having this things put away for years I tried it & it worked...lol. I thing was one brought to me to be fixed. It came to me in BAD shape. The owner..... had stickers all over it. Chassis had bends & dents. & scraps. & it as a whole was not totally flat. I think someone may have stomped on it. She never explained exactly what happened. I told her it was a done deal & would cost her less or just as much to buy another one.

 

The keyboard/top cover won't even snap back one right.

 

Well.... it has 10.6.8 on it. (A1150) well it runs Myhack... long story in between. Myhack worked but ny not saying yes to MBR. Leave the USB as GPT. I used Madara-San (I added rehan or whatever his name is. They were fixes to the mouse. Got Mvericks installed.

 

It well surprisingly well aside from the video issue. Glitches. Playing YouTube you see it glitch as the video plays.

 

I haven't done much post installation yet it was getting too late. ...

 

Side note I already had MacOS on this t61. It had (on another data laptop hdd drive) 10.5.8 on it. On which I had QE running. I took files from that install.

 

Today I will look into some other things. I just got the wifi card in the mail so I will install that. AR8bh92 something like that. It should just work.

 

 

As for that old Macbook Pro A1150. I may looking into fixing it. Maybe getting the chassis replaced. I'm thinking by now should be cheap to get those parts. Also... before you go on with that Herve. With all this Corona quarantine stuff going on. This is just a project to remind me how to do it & to stay busy.

 

I get alot of stuff in bad shape & I at times will refurbish & sell them If I can at least come even. (I know... but right now it about keeping busy & staying sharp. Or improving knowledge of it while I have the time to do so)

 

Sent from my SM-N960U1 using Tapatalk

 

 

 

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...