Jump to content

Mavericks won't boot (Z77-D3H + i5 3570k + SSD + 670 GTX)


4 posts in this topic

Recommended Posts

Hey guys,


hows it going??


I'm new to creating topics, but I've read a few and often solved my previous hackintosh problems this way so thanks for that, and in advance for hopefully solving this issue!


I just bought a new SSD (Samsung 840 EVO 120GB), and decided to use it as a Mavericks drive for development/design, as it just so happened to coincide beautifully with the release of Mavericks!


Previously I have had a stable boot with Mountain Lion (up to 10.8.2/10.8.3) I believe... and I can still run this on a different hard-drive, so the only component that is different is the SSD, sleep has never worked properly but I believe this is due to having NullCPUManagement installed when it wasn't needed.


I followed a commonly found Mavericks install process (documented on a website not supported by this site), and I have working sound, graphics and everything else I believe (but for iMessage so far).. however I can currently only boot off the bootable USB and not the SSD itself.  I have tried using a DSDT, and a DSDT-free installation and installing NullCPUManagement when it shouldn't be required. I have the CMOS reset fix kext installed, and fakeSMC, and have tried GraphicsEnabled=No and Yes, and also PCIRoot, and -f -v -F bootflags.  However, even with verbose boot mode I get no kernal panic as such - my computer just reboots almost instantly should I try boot from SSD to Mavericks HOWEVER my computer will boot to my other OS X install (Mountain Lion), installed on a hard-drive, when booting from the SSD (so bootloader - Chimera 2.2 I believe it is - works for Mountain Lion, or to boot to another hard-drive atleast, but will not boot to Mavericks installed on the SSD).


There appears to be some error messages saying error:unable to handle, but my ML install had a few of these (different ones I believe) and worked.


I used the pause|break button to freeze and caught these errors with verbose boot:


- Unable to handle key MLB

- Unable to handle key ROM

- Unable to handle key SystemAudioVolume

- Unable to handle key boot-gamma


(please see attached image for the screenshot)


comp specs:

Gigabyte Z77-D3H,

Intel i5 3570k

8GB Corsair Vengeance 1600MHZ


Samsung 840 EVO 


kexts I have: fakeSMC, CMOS reset fix, Atheros for ethernet

profile/spec I am using: Mac Pro 3,1 (apparently this is the recommended one to use for Mavericks)


Can anyone offer any advice, anything I can try?

I personally think it is an SSD related problem, and I will try installing Chameleon/maybe switching from SATA III ports to SATA II ports to see if this is the problem.


As it stands I have left the install of Mavericks pretty much as it was so I don't mind wiping the drive, re-installing or anything like that.


Thanks a lot for any help




Link to comment
Share on other sites

As there was no replies took this upon myself to fix!


turns out the BIOS needs to be set to boot from the SSD directly, rather than the [uEFI] option for the SSD - so it can load the bootloader.


(my pc was defaulting to loading from my OS X ML hard drive and loading the bootloader from that)


Mavericks now up and running (-iMessage)!

Link to comment
Share on other sites

you may need the NullCPUPowermanagement.kext


to test your SSD still ok or not, you have a spare hard drive to install 10.9 on it, when everything done working good, you can use carbon copy clonner to copy to the SSD.


you may have something mess up to the installation to the SSD, I recommended you try Myhack to install 10.9.


when a system work good with 10.8 then it should work to 10.9.

Link to comment
Share on other sites


  • Create New...