Jump to content

[Solved] Wake from sleep broken with 10.8.5 (black screen + bios reset)


BiTRiP
 Share

5 posts in this topic

Recommended Posts

Hi Guys,

 

I have a GA-EX58-UD5 mobo which always worked perfect. Almost everything OOB, only have to patch AppleHDA but thats ok.

Unfortunately since I installed a (CLEAN) 10.8.5 my wake from sleep is not working anymore.

I get black screen, and only way to get out of it a hard shutdown. After that bios is reset. (while I have the RTC fix in my dsdt)

 

Maybe it has something to do with the new Nvidia drivers?

I have a GTX-470 using the vanilla NVDAGF100Hal.kext.

 

Almost everything is vanilla, I just added latest FakeSMC.kext, patched AppleHDA and edit AppleGraphicsPowerManagment.kext with my device id under MacPro5,1.

 

This is my org.Chameleon.Boot.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>1920x1200x32</key
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>UseKernelCache</key>
	<string>Yes</string>
	<key>Kernel Flags</key>
        <string>darkwake=0 npci=0x2000</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
        <key>GenerateCStates</key>
        <string>Yes</string>
        <key>GeneratePStates</key>
        <string>Yes</string>
</dict>
</plist>

Also I attached my DSDT.aml  (DSDT.aml.zip)

 

Hope someone can help me out.

 

Thanks,

BiTRiP

Link to comment
Share on other sites

 Share

×
×
  • Create New...