Jump to content

Can't boot after 10.8.5 updade


11 posts in this topic

Recommended Posts

I'm one of many shining examples of why you always should back up before updating firmware.

After a lot of struggling to get my 10.8 install working in March, I've had smooth sailing through all the updates in the App Store.
The 10.8.5 update froze my computer before I could shut down. A second try made it through the installation and my computer successfully shut down.
When I booted, I was given this error:

Error parsing plist file
Mach- 0 has bad magic number
Mach- 0 has bad magic number

I was able to boot back to the desktop using my USB Installer, and I got advice elsewhere to try installing the Combo Update, which I did.

After repairing permissions, installing the Combo Update, and repairing permissions again, I am now met with the screen below when I attempt to boot with my USB Installer or my Chameleon boot loader.
I have tried a variety of boot flags including -x, -f, -F, GraphicsEnabler=No in no particular combination with no luck.
My setup includes a Windows 7 partition in which I can still access my OS X files using MacDrive 8.
I'm running my OS X partition on a 3 TB HDD, and I believe this might have something to do with the "uptime in nanoseconds" error as apparently 3 TB is out of the threshold that OS X was designed to run off of or something like that.
It's also worth noting that although it says "Mac OS version Not yet set", my OS X partition appears as 10.8.5 in Disk Utility.

Here are my specs:
Intel i7 960 Processor (4x 3.20GHz/8MB L3 Cache)
20GB DDR3-1600
Video Card: GTX 660 2GB
Gigabyte GA-X58A-UD3R w/ 4x PCI-E 2.0 x16
Hard Drive (WINDOWS SIDE) (1 TB 7200 RPM)
Hard Drive (MOUNTAIN LION) (3 TB 7200 RPM)

I'd very much prefer to avoid a fresh install, not just because I'm too lazy to reinstall all of my programs, but because my original ML install was a pretty hectic 3 week ordeal that'll probably give me more problems than trying to fix this. Thank you so, so much in advance. It really means a lot for you guys to help a newbie out.


Link to comment
Share on other sites

I have the same problem, I have 3 Tb disk too.


I can boot with an external disk, but if i selected the 3Tb disk, it gives the error "error parsing boot file", but then I select another disk to boot, and it boot the 3Tb disk, I don't know whats happen.

Link to comment
Share on other sites

I have 2 internal disks,both with mountain Lion, one 500 Gb and one 3 Tb... I I use only internal drives the 3 Tb didn't show... but if I connect an external USB disk with mountain Lion, I can boot from the 3 Tb disk, and all works fine.

What bootloader do you use? Whats kexts do you have?


I have only fakesmc and I have DSDT.

Link to comment
Share on other sites

@ mirrors:


1. Go into BIOS and make sure nothing has changed there.


2. You said that your initial installation was "hectic".  I would take that to imply that you had to add and remove some kexts to get things working.  The 10.8.5 update over-wrote those kexts.  List what kexts you added and removed during the initial installation.


3. The 3 TB drive is probably not causing your problem.  The problem with those drives and many newer drives was a change to the sector size that affected the way Chameleon got installed.  If you have previously been booting the 3 TB drive, then the boot loader is fine and the drive is not the problem.


4. Despite the problem, in the future go with the combo updates rather than App Store updates.  Then, before booting, add and remove the kexts just like you did to get your initial installation working.

  • Like 1
Link to comment
Share on other sites

Thank you so much for your help rlf, I really appreciate the quick response.

1. I checked out my BIOS, everything appears to be in order.

2. My installation was hectic in that I'm a novice and I was even more so then, trying lots of different solutions from partially related help threads that other people had posted. I had obviously changed my BIOS setup, I had to do some sort of sudo command using the installer USB to fix my 3 TB drive problem, Chameleon Wizard's plist format wasn't compatible with my mess of a setup and I had to manually type out the boot flags in a different format for Chameleon to read it properly, there was an issue with not being able to log into the App Store, when I plugged into my USB 3.0 ports my computer froze, and yes there was a rearranging of kexts. Basically I'm not even entirely sure how I got OS X working because I'm a big failure, and I'm so mixed up that I don't know which kexts I've removed. 

3. I believe the command that I did previously may have changed the way my 3 TB behaves now, for good, so hopefully if it comes down to reinstalling I won't need to deal with it again.

4. Good to know. I think I'll do a Time Machine backup before every update from now on as well.

5. As you can tell, I've made a pretty big mess out of my setup, and I thank you for baring with my lack of knowledge. The error I'm receiving now isn't any error I've ever received before, so I'm hoping if I can narrow this down to the problem kexts then I should be back to smooth sailing and I can Time Machine it and never update again, ever.

6. Are you or anyone you know available for hire on Skype? I bad asking for help when I clearly have no knowledge to impart with the community, other than being a good case of how important it is to document your progress and back up often.

Thanks for your response, theconnatic!

I tried this to the best of my ability with my Windows partition as I can't boot my OS X side.

What I did:


1. Found a NullCPUPowerManagement.kext on Google
2. Copied the kext file to my OS X partition: /System/Library/Extensions
3. Used my USB installer to open Terminal
4. Typed:

cd /Volumes/Mountain\ Lion/System/Library/Extensions
chmod -R 755 NullCPUPowerManagement.kext
chown -R root:wheel NullCPUPowerManagement.kext
5. Repaired permissions, repaired disk for good measure in Disk Utility
6. Rebooted with flags: -f UseKernelCache=No

It failed to boot and after a time showed a small crossed out circle icon in the middle of my boot screen.
When I boot with -v 
-f UseKernelCache=No I get this:
It seems like the problem starts with "Kext com.apple.driver.AppleAHCIPort - library kext com.apple.iokit.IOAHCIFamily not found", but I could be wrong.

Link to comment
Share on other sites

Hey guys! Thanks for the response.

I tried installing the kext the same way I did above.
My screen with -v looks almost identical with very subtle differences. It seems like the problem is still starting on the same line.

Here's the new screen:


Thank you for your time!!!

Link to comment
Share on other sites


  • Create New...