Jump to content

ALC888 Mavericks DP7


guzferreira
 Share

8 posts in this topic

Recommended Posts

Hi, I just installed Mavericks and everything works perfectly except for the audio. I tried using my working kext+dsdt from ML, but it didn't work. Then I tried every kext and combination I could find and still no sound. Can anybody point me to a working kext (and possibily dsdt/hdaenabler setting?) Or at least to a successful patching tutorial?

 

MB: GA-EP43-DS3l

ALC888

Core2Quad Q9300

4Gb

 

Thanks. 

Link to comment
Share on other sites

Hi,try this one,work perfecktly on ALC888 chip running DP7 :thumbsup_anim:

Hi, thanks for that, but it didn't work. I don't understand how it works for everybody else.

At boot the only sound message I get is "Sound assertion in AppleHDAController at line 483", does this help to identify my problem?

Anyway I'll keep trying, and maybe try a fresh install.

Is there a way to do a fresh install directly at DP7? Or would I have to repeat all DP1 install, and updates 2-7?

Link to comment
Share on other sites

 

Please most times these kexts for your P43 MSI board.
They were from an old P45 MSI board with ML 10.8.2.
the chain, the sound went with me without any problems.
 
I have now only 2 newer MSI boards, see my signature

 

 

Thanks!

 

But that one's even older (1.7.4a1) than the only one that's only worked for me (2.1.1), so I guess it probably won't work too well in Mavericks. I'm now settled with VoodooHDA temporarily.

(What I meant before was that patching the AppleHDA in the system has always failed me, but this old one I obtained did work... until Mavericks, that is.)

Link to comment
Share on other sites

This post: http://www.insanelymac.com/forum/topic/291693-npci0x3000-breaks-audio/ made it work, but not work. 

 

Actually, after I removed npci and PCIRootUid from boot.plist I had different responses but only this one http://www.insanelymac.com/forum/topic/290361-alc-888-dp2-2/ made the analog I/O's work.

My problem now is that I need SPDIF to work with my Home Theater and I get silence on this one.


EDIT: Actually the only Output that's working with the kext i mentioned is front headphone output. So, yeah. I'm still not happy. haha. 

Link to comment
Share on other sites

 Share

×
×
  • Create New...