Jump to content
InsanelyMac Forum
fellreis

Primeiro hackintosh - KERNEL PANIC O que fazer?

Recommended Posts

Atualizei a kext da placa mae para tentar ativar a firewire e também atualizei o osx para 10.8.4

Ai veio a kernel panic. Mandei o -v e cheguei nisso.

O que eu faço????

 

ixvu.jpg

 

 

Share this post


Link to post
Share on other sites
Advertisement

Olá camarada.

O que falta para ti é coloca a kext NullCPUPowermanagement e FakeSMC na pasta Extensions que fica pasta Extra do USB.

NullCPUPM: http://www.mediafire.com/?uwvnvztwtna

FakeSMC: http://www.projectosx.com/forum/index.php?showforum=165

Por favor não crie dois tópicos para uma mesma finalidade. Escolha qual irá querer usar para tirar dúvidas.

Esse ou esse: http://www.insanelymac.com/forum/topic/291264-primeiro-hackintosh-minha-maquina-serve-meu-boot-nao-esta-dando-certo/?do=findComment&comment=1939331

Share this post


Link to post
Share on other sites

olá

 

apaga a sleepenabler.kext

 

a sleepenabler é especifica da versão e se atualizaste essa já não serve..

 

bom hack

Share this post


Link to post
Share on other sites

Valeu galera!!! Deu certo.

Agora nao consigo atualizar para a versao 10.8.4. Quando ele vai reiniciar e instalar a atualização fala que ocorreu um erro inesperado.

O que devo fazer?

Share this post


Link to post
Share on other sites

olá

 

olha meu conselho é este nunca atualizes um sistema preso por arames.. como vocês dizem por gambiarra...

 

se n sabes o k estás a fazer em uma versão do sistema e n está a funcionar a 100 % , n vale a pena subires para o patamar acima.. porque vais cair..

 

quando teu sistema estiver a funcionar sem problemas e souberes o k fizeste para isso acontecer.. se fizeres update.. não vais ter problemas.. caso contrário só vais agravar teus problemas..

 

bom hack

Share this post


Link to post
Share on other sites

Olá camarada

Antes de fazer autalizações deves deixar teu hack nos conformes.

Mas de onde está querendo fazer atualizações? Da AppStore ou de alguma imagem DMG baixada da internet?

Se for pela DMG esse erro já é esperado e não tem jeito.

Share this post


Link to post
Share on other sites

Pessoal. Estou com um novo problema.

Como havia instalado kexts demais sem saber o que estava fazendo resolvi formatar e começar novamente.

Quando joguei as kexts da minha placa mae Asus P6X58D-E e da minha placa de Video G-force - GTS 450

Recebi essa mensagem no verbose

 

com.apple.applefscompressionTypeDataless load succeeded

 

O que fazer?

Share this post


Link to post
Share on other sites

olá

 

k isso " joguei as kexts da minha placa mae Asus P6X58D-E e da minha placa de Video G-force - GTS 450 "

 

k kext ?

 

instala 1 por uma e tenta perceber para k serve o k estás a instalar .. se não estás a instalar lixo...

 

tás a seguir 1 guia noutro sitio e só vens aqui para resolver problemas ?

 

mac os x é para mac e desenvolvido exclusivamente para mac

 

hack mac os x é 99 % de leitura, googling e persistência e 1 % de sorte k teu hardware seja compativel

 

http://www.insanelymac.com/forum/topic/284026-pos-instalacao/

 

bom hack

Share this post


Link to post
Share on other sites

Olá camarada

 

Não existe kext para placa-mãe existe patch dela para patchear uma DSDT.

 

Não se "joga" kext se instala.

 

Me diga uma coisa, esta seguindo os guias que te damos? E que guia está seguindo para fazer a instalação?

 

E depois da mensagem teu hack inicia, chega ao desktop ou não?

Share this post


Link to post
Share on other sites

Pessoal, estou usando sim os guias de voces mas tambem serei sincero.

as vezes voces me mandam link dos links e acabo me perdendo.

Mas agora ja estou bem mais interado do assunto.

E fiz o seguinte.

Formatei a particao denovo e fiz o bootloader pelo charmeleon.

Usei tambem o Charmeleon wizard para finalizar o processo.

Instalei as dsdt da placa.

Meu hack esta funcionando quase perfeitamente.

Nao sei porque nao consigo fazer o meu login na app store.

E muitos app q instalo tais como meu driver da minha tablet (wacom bamboo), driver da minha Motu (placa de audio externa) e mais alguns outros falam q a instalacao deu erro. Mas acabam funcionando mesmo assim.

Agora o que mais esta acontecendo que nao sei solucionar e que do nada ele trava. o carrocel aparece e fica rodando e nao sai dele. Ai tenho q reiniciar a maquina.

E mais uma pergunta.

Tenho uma rede aqui com um hd externo de rede (modelo iomega ix2 2tb), Crio pastas nele mas so a maquina q criou consegue alterar ou adicionar aquivos dentro da pasta, nao consigo configurar as permissoes igual configuro normal no hd da maquina, quando crio uma pasta dentro do hd de rede aparece nas infos - voce possui acesso personalizado. Alguem sabe como consigo confirar essas permissoes no hd de rede?

Muito obrigado desde ja a todos acima que se dispuseram a me ajudar desde o inicio sem voces nao teria conseguido

Share this post


Link to post
Share on other sites

Olá camarada

Está bem. Já explicou e eu já entendi.

A Apps Store é baseada pelo número de sério de cada mac, então tu precisa criar uma SMBios que simula esses números.
Cria ela pelo Chameleon Wizard de acordo com teu hardware. Qualquer dúvida sobre isso pergunte.

Sobre o tablet não entendi direito, mas sobre a placa de áudio externo terás que ajustar para reconhecer.
Tens kext de áudio instalado? Recomendo VoodooHDA. Baixe pelo site oficial: http://www.projectosx.com/forum/index.php?showtopic=355

 

Faça o download para cada versão que no teu caso dever Lion. 2.7
E veja se reconehceu se não volte a perguntar.

 

O travamento vem da mal configuração do hack. Tente ler e compreender a pós instalação: http://www.insanelymac.com/forum/topic/284026-pos-instalacao/
Principalmente gerenciamento de energia. Esta tudo muito bem elaborado lá.

 

 

o carrocel aparece e fica rodando e nao sai dele. Ai tenho q reiniciar a maquina.

Não entendi.

Sobre a rede não sei te informar se tu ajustou pelo Windows tenta ajustar por ele novamente, pois tô sem ideia.

Share this post


Link to post
Share on other sites

Tentei mas tentei mas tentei aqui mas ele continua travando,

Ja instalei as kext de null power fake smc

No charmeleon wizard ja configurei mas nao sei o que tá acontecendo.

Ai agora descobri que ele nao desliga o.O

Ele fecha tudo e fica lá na tela cinza.

Para ajudar segue a config do meu hack

 

Intel i7-950

asus p6x58d-e

N-vidia Gts 450 1gb ddr 3

 

Só preciso entender isso ainda nao consegui enteder como funciona essa parte de energia.

Li todos os tutoriais acima mas nao consegui descobrir o erro.

Desde já agradecido

Share this post


Link to post
Share on other sites

Olá

Quanto tempo?

Trava como? Diga os sintomas.

Creio que para tu ter Gerenciamento de energia é só necessário colocar p e c states ativados no org.chameleom… coloca assim:

<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>

Ou ativa pelo Chameleon Wizard que é bem mais fácil.

Para o problema de não desligar tenta aplicar um patcher na DSDT chamado Shutdown.
Tu podes baixar o app DSDT Editor e aplicar por ele, no app tens os patches.

Share this post


Link to post
Share on other sites

Ele trava aleatoriamente.

Geralmente trava quando estou com programas pesados abertos, tais como photoshop ou logic.

Ai ele começa a girar aquele rodinha colorida e nao para mais. 

Se fosse a placa de video esquentando o video ficaria distorcido ou apagaria certo?

Se fosse a fonte, automaticamente o hack ia desligar ou reiniciar.

Mas acredito q é o processador.

 

O p e o c states ja estao ativados.

Tem mais alguma coisa na cpu no charmeleon wizard q devo ativar?

Share this post


Link to post
Share on other sites

Olá.

 

Entendo.

 

Baixa esse app para ver a temperatura e os multiplicadores do teu CPU: http://olarila.com/files/10.8/HWSensors/HWSensors.zip

Para ver temperatura instala IntelCPUMonitor com o kext wizard.

 

Abre o app e veja a temperatura e os multiplicadores. rode comando yes no terminal.

Quando rodar o comando yes o multiplicador ficará em um número alto no meu fica x35 e a temperatura também ficará alta.

encerre o comando e veja se o multiplicador voltou para o número normal que no meu é x16.

 

Se voltou tem Gerenciamento nativo.

Share this post


Link to post
Share on other sites

Cara o meu ficou com x28 e o normal é x12.

O que sera que tá fazendo ele travar entao?

Os nucleos ficam em 50º a 52º todos eles e o hd a 32º 

Share this post


Link to post
Share on other sites

Olá

 

Se voltou ao normal tens gerenciamento.

 

Roda kextstat no terminal e vê se a AppleLPC está carregada. Se não estiver aplica o patch LPC destinado a teu Chipset.

Aplica com o DSDT Editor que tem os patches inclusos nele.

 

Talvez deva resolver teu problema de trava.

 

Mas também desconfio de gráfica, pois é ela que é usada para trabalhos gráficos como tu usa.

Já tem QE/CI?

Share this post


Link to post
Share on other sites

Chefe pera ai que agora nao entendi nada que voce falou.

Rodei aqui no kextstat realmente a AppleLPc não esta na lista.

Agora como que vou fazer isso nao entendi essa parada ai de fazer no DSDT Editor

Não tem uma kext não? kkkk pra ser mais simples

 

E o que é QE/CI?


Sobre a minha placa de video vou lhe explicar.

Eu nao instalei nenhum driver ou kext dela pois no tutorial de pos instalação dizia que o chameleon 2.2 ja vinha com os pacotes da nvidia gts 450 inclusos.

Ela aparece normal aqui no meu sistema.

Share this post


Link to post
Share on other sites

Olá.

kkkkkk

Tens que criar uma DSDT que servirá para corrigir teu problema.

O DSDT Editor é um app que edita a DSDT.

Aqui tem um guia muito bom sobre DSDT: http://olarila.com/forum/viewtopic.php?f=7&t=646
Qualquer duvida adicional é só perguntar.

QE/CI é à aceleração de gráfica. É essencial para o hack.

 

Eu nao instalei nenhum driver ou kext dela pois no tutorial de pos instalação dizia que o chameleon 2.2 ja vinha com os pacotes da nvidia gts 450 inclusos

Já vem com os pacotes, mas pode não vir ativado, por isso tu terás que injetar propriedades nela para ser reconhecida.
Se desse uma lida mais cuidadosa saberia que deveria ativar no org.chameleon... a gráfica. Coloca assim no org.chameleon...:

<key>GraphicsEnabler</key>
<string>Yes</string>

Ou ativa o GraphicsEnabler pelo Chameleon Wizard.

Para saber se tem QE/CI é só notar se a barra de menu está translucida ou se o jogo de Xadrez roda sem travamento.

 

Qualquer duvida pergunte.

Share this post


Link to post
Share on other sites

olá

 

vamos ser objectivos...

 

se usas nullcpupowermanagement n tens gerenciamento de energia nativo.. como o nome da kext diz é para anular a kext applecpupowermanagement

 

se n tens dsdt .. ainda menos vais ter gerenciamento de energia nativo..

 

depois ainda n percebi muito bem teus problemas.. falas ai de umas placas especificas.. k se for preciso nem em windows trabalham como deve ser.. isto é hack mac os x.. ou trabalha nativo no sistema .. ou tem de ter drivers para..

 

por isso

 

posta problema a problema e quando resolveres 1 passas para outro

 

o k é QE/CI ?  google é teu amigo.. n tens a barra do google ? n sabes fazer uma pesquisa ?

 

ai teu problema é outro...

 

bom hack

Share this post


Link to post
Share on other sites

Pessoal.

Olha só...

Troquei a placa de video por outra do mesmo modelo e continuou travando.

Mas ai nesse meio tempo percebi uma coisa que talves possa ajudar.

Quando ele trava a cpu faz um barulho diferente.

Me parece q vem do processador.

É um baralho muitooooo baixo e continuo.

Isso pode ajudar ou é apenas coisa da minha cabeça?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By jcrcarmo
      Hello everyone,
        Greetings from Brazil!  I'm getting a kernel panic at the macOS High Sierra install process.  Any ideas on what could be happening?  Please refer to attached pictures.  Thank you very much for your time and help.  I really appreciate it.   Motherboard Gigabyte G41MT-S2P F3 CPU Intel Core 2 Duo 2.6 GHz 8 Gb of RAM Video Zotac GeForce 9500GT 1 Gb     jcrcarmo        
    • By PsychoKoopa
      I recently got an Asus X55U laptop with the following specs:
       
      AMD Brazos C-60 1Ghz CPU
      4GB DDR3
      120GB HDD
      AMD HD 6290 Graphics.
       
      I am trying to use the Sierra 10.12.5 raw file from the Olarila forum. I understand that I need to change the kernel on the installer USB to one that supports AMD processors, but I am not sure which kernel to use or how to replace it. If anyone can help me with this I would appreciate it.
       
      Thanks.
       
      EDIT: Also when I try to use the Sierra Zone distro with the included AMD kernel, I get Error loading kernel cache (0x9) when trying to boot into the installer.
       
      EDIT 2: Nevermind this post. I just read that your CPU needs SSE4.1 to run Sierra and the C-60 only had SSE4A. I'll try an older version and make a new post if necessary.
    • By pjhartin
      I've recently acquired a kernel that Bronya has been developing and I had wished to test it out on my system.
       
      I assumed the process of updating the kernel would follow the steps outlined here
       
      So I booted via USB into my macOS, deleted the existing kernel at 
      macOS/System/Library/Kernels and replaced with the new kernel file, then deleted the existing PrelinkedKernels file too. 
       
      Next I ran Kext Utility, and when it finished I rebooted.
      Upon booting into macOS again via clover on the drive, I ran Kext Utility again, just to be safe.
       
      Now, however, I no longer have any sound devices once booted and I am experiencing very long boot times, noting "kextd wait appleacpicpu" at the end of boot (see attached screenshot)
       
       
      Did I actually update the kernel correctly? Did I miss a step, or screw something up along the way?
       
      Thanks
    • By Jacopopiazza
      config pc:
       
      MOBO: GIGABYTE Z270 HD3P
      CPU: I7-770K
      RAM: 16GB 3000MHZ CORSAIR
      GPU: INTEL HD630
      SSD: WD 250GB
       
      I'm trying to install macos High Sierra 10.13 on this computer, but the installtion stuck on attemting system restart...MACH Reboot. 
      check in the photos.
       
      this happen after a panic(cpu 0 caller 0xffffff801ef8a611...
       
      here is the link for my efi folder.
       
      please help me
      EFI.zip

×