Jump to content

[SOLVED] Patriot RAM issue only in 32 GB config


9 posts in this topic

Recommended Posts

My build was a i5 2500k on a Gigabyte Z68MX-UD2H-B3, 8 GB RAM Corsair (9-9-9-24), GeForce 480 GTX.

It was very stable running Mountain Lion 10.8.4, but for 3d rendering I needed more RAM and a faster processor.


First, I bought 4x 8GB of Patriot RAM PV316G160C9K (9-9-9-24), maxing out my motherboard's capacity, and that was when all my troubles started...


The system immediately became unstable, and I thought proceeding with a clean-installation.

However, the installation process was always failing. At first, I thought the problem to be with the usb stick, so I tried different ones, and connecting them to different USB ports. Every time it was a failure, with the installer randomly reporting errors.

I decided to install back the previous Corsair RAM, and I went through the installation without any issue.


I then tried to replace again the RAM, and now I am writing from the 10.8.4 with the Patriot RAM installed, however I am getting weird app crashes: notes crashes, system preference crashes... and I might get a reboot anytime.


The weird thing is that I have executed the memtest utility from memtest.org and it did not report any error.

The RAM itself seems working very well under Windows, where I stress it with rendering occupying around 30 Gb or RAM for many hours and the system keeps being stable.


Is it reasonable that the RAM has somehow a compatibility issue with ML? Any clue to solve this eventually?


Thanks in advance.

Link to comment
Share on other sites

I agree with you that it is a waste spending time due to these problems, but I now live in Japan and I cannot have the RAM changed unless I can proof it is defective, which seems not...



The BIOS is the latest version, UEFI U1E.

Link to comment
Share on other sites

Hello, thank you for your reply.


Since updating to UEFI bios, I have not been using DSDT anymore.


However, today I performed several experiments. My RAM consists of two 2x8GB kits.

So I tried the first kit in the 1-3 slots, then 2-4 slots. Then repeated the experiment with the second kit.


In the 16 GB configuration, the system worked fine.


I then added another module, and again with 24 GB I didn't have any weird behavior of the system.


But then, adding the last 8 GB causes the system to be absolutely instable, with app crashing at launch and the system freezing soon after.

Link to comment
Share on other sites



maybe something in u bios ?


u are not OC the board ?


check again u defs in bios for the ram...


is a weird issue.. but seems no kit problem with the ram.. maybe a mobo issue or bios config.. check the voltage of the ram..


  1. 4 x 1.5V DDR3 DIMM sockets supporting up to 32 GB of system memory
    * Due to Windows 32-bit operating system limitation, when more than 4 GB of physical memory is installed, the actual memory size displayed will be less than 4 GB.
  2. Dual channel memory architecture
  3. Support for DDR3 2133/1866/1600/1333/1066 MHz memory modules
  4. Support for non-ECC memory modules
  5. Support for Extreme Memory Profile (XMP) memory modules

(Please refer "Memory Support List" for more information.)


only with + test .. maybe u can resolve it


good hack

Link to comment
Share on other sites

  • 2 weeks later...

I have been very busy with my work so for a while I simply left my hack as it was... but then, under an extensive use of performance-demanding applications under Windows (7 Ultimate, 64bit), I started experiencing crashes of applications and sometimes of the Operating System too. Maybe due to a different memory management, the problems were much more bearable that under OSX, yet I couldn't accept the random crashes of some applications crucial for my workflow.

So I recollected about the tests with the different RAM configurations I did for OSX, I simply removed one module of RAM... and voila! All the random crashes disappeared also under Windows.


So what I can conclude now is that the problem is not OSX-related, and not even with the RAM itself. I guess it is my motherboard to have somehow problems when I put all the modules on it. I mailed the support of Gigabyte, I hope the can reply to me.

I tried several configurations on the BIOS too, activating and dis-activating the XMP (which is supported by these RAM modules), but the problems disappear only physically removing at least one of the RAM modules.

Link to comment
Share on other sites

  • 4 months later...

The problem seems to be solved, although I am deeply unhappy with its solution.


The memory is sold as 9-9-9-24, but if you pair two kits there is no guarantee of such performances.

In order to install two identical memory kits and keep the system stable, I had to downgrade the timings to 11-11-11-30.


Needless to say, I do regret for buying Patriot RAM and I discourage everybody to go for this brand.

Link to comment
Share on other sites

I had the same issue with two "identical" 2x1 GB kits of Kingston DDR2 RAM in a Gigabyte P43/ICH10R motherboard. I bought the kits separately...about 1/2 a year apart I think, and they worked fine together at 1066MHz in an ASUS P45/ICH10R board. With all four sticks in the Gigabyte board, I could not get them to run at 1066MHz no matter what I did, 1066MHz would only work with 3 sticks, and that meant no dual channel operation...and 1GB less.. :)


I thought there might be a problem with one of the sticks but then they all worked fine in the ASUS board at 1066MHz, even though they were two kits bought separately. I always kept each pair installed in each channel, easy to do by looking at the serial number...but no..


Later I sold the motherboard with the RAM, AFAIK its still running happily with all four sticks at 800MHz, which is fine, just not what I paid for...and yes, they were on the compatibility list for the Gigabyte board.

Link to comment
Share on other sites


  • Create New...