Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ASUS G73 with 5870M: Resolution Troubles

4 posts in this topic

Recommended Posts

I have almost everything working, but I cannot get resolution changes to work with my video card. It messes up and I get like 4 duplicate desktops showing on my LVDS. I tried EDID overrides but to no avail. I am guessing this is a video driver issue, but I have no idea what to change in order to correct this. I tried different but similar framebuffers but they do not help at all.

Standard Nomascus but only using the first three connectors:

Personality: Nomascus
ConnectorInfo count in decimal: 4
Disk offset in decimal 591808

0000000 02 00 00 00 40 00 00 00 09 01 00 00 00 00 00 05
0000010 02 00 00 00 00 01 00 00 09 03 00 00 12 04 03 03
0000020 00 04 00 00 04 06 00 00 00 73 00 00 11 02 01 01
0000030 00 04 00 00 04 07 00 00 00 73 00 00 21 03 02 02

SubsystemVendorID: 0x1028 SubsystemID: 0x043a
IOBaseAddress: 0x3000
Filename: 13B96101.104
BIOS Bootup Message: 
BROADWAY XT B96101 GDDR5 64Mx16 4CH 400m/300e @0.9V UCODEv:128 

SubsystemVendorID: 0x1043 SubsystemID: 0x1c02
IOBaseAddress: 0x0000
Filename: BR35992.001 
BIOS Bootup Message: 
Asus G73 BROADWAY XT GDDR5 64Mx16 4CH ASID:A33G73.002$ UCODEv:1195 

PCI ID: 1002:68a0
Connector at index 0
Type [@offset 45122]: LVDS (7)
Encoder [@offset 45126]: INTERNAL_UNIPHY (0x1e)
i2cid [@offset 45196]: 0x94, OSX senseid: 0x5
Connector at index 1
Type [@offset 45132]: HDMI-A (11)
Encoder [@offset 45136]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 45219]: 0x91, OSX senseid: 0x2
Connector at index 2
Type [@offset 45142]: VGA (1)
Encoder [@offset 45146]: INTERNAL_KLDSCP_DAC2 (0x16)
i2cid [@offset 45246]: 0x97, OSX senseid: 0x8

My HDMI seems to work perfectly, do not ask me how as the type of connector is wrong, but it refuses to boot when I change to HDMI type. Any suggestions would be helpful.

Share this post

Link to post
Share on other sites

The ati is the primary and only card. Orangutan has the same problems as it is the same info on connector 0. I am running 10.8.4 and I have QE/CL just cannot change resolutions from 1600x900 or things go wonky. My device is in the ati5000controller so no need for injection.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By TheBloke
      Hi all
      I currently use an NVidia 760 with four displays: 1 x 4K; 2 x 1920x1200; 1 x 1920x1080.   This mostly works, but I am considering replacing it with an AMD GPU - likely a Radeon 7970 - for two reasons:
      I would like to add a fifth monitor, maybe even a sixth; I get small stutters and slowdowns with my NVidia, using both Native and NVidiaWeb drivers.  It is a lot better than it was with my NVidia 980Ti, but it's still not perfectly smooth as it should be, especially when I have a full screen video playing while also doing UI movements like Swipe Left A Space or Mission Control.  
      I have just been told that it should be possible to access all display outputs on an AMD 79XX GPU, possibly requiring a custom SSDT and/or radeonDeInit?  I've only ever had one AMD GPU and that was 8 years ago so I am not experienced with them.  My NVidia 980Ti has five outputs, but can only use four at once.  But I believe AMD's EyeFinity does allow it to use them all as separate displays.
      Before I buy the GPU, I'd be most grateful if anyone could confirm that it should be possible to run five or six simultaneous displays on a card such as the ASUS HD 7970 DirectCU II (6 x DP outputs) or XFX AMD Radeon HD 7970 (2 x mini-DP; 1 x HDMI; 2 x DVI).  With one display being 4K @ 60fps and the rest 1920x1200 or 1080P.
      I have Googled on this a while but haven't yet found anyone discussing connecting more than four monitors to an AMD Hack  I did see that the late-2013 Mac Pro (which uses 2 x AMD FirePro GPUs) states it can support "up to 6 Thunderbolt displays".  So I know the OS can do it, it's just a question of whether a particular GPU can, and in a Hack setup.
      Thanks very much
    • By Unklemac_PC
      Hi Insanlymac’ers.
      I have a super deal on a WX9100 Radeon Pro Vega, but I only have 12 hours to repond, or it’s gone.
      Is this card able to run in High Sierra and take advantage of all 16GB ram?
      Thanks in advance!
    • By alex_10
      I've been running High Sierra (Currently 10.13.3) on VMWare Player 12.5.9.
      I'm running it on a Dell XPS 15 9560 with the 4k screen.
      Currently I'm able to run OSX in either Native 4k resolution, or scaled to 1080p.
      I wanted to know if it was possible to add a 1440p scaled mode? Right now if I force 1440p resolution using VMWare tools, I simply get a smaller window with the virtual machine. So, as I understand, I need to add a HiDPI version of the resolution.
      Can anyone lend a helping hand?
      Thank you!
    • By macinsane
      What works? Everything. Sleep/Wake, NVMe, Airport, Spotlight, AMD-graphics

      ASUS Prime B250M-C µATX-board
      Intel Core i5 7500 (Kaby Lake)
      Gigabyte Radeon RX560 4GB
      Airport-compatible PCIe-Card for Wifi and Bluetooth (BCM943602CS)
      2 NVMe drives: Samsung P961 with 1 TB and 256 GB

      Installed mac OS: 10.13.2
      Clover: 4334
      *Update 10.13.3*
      Added new config.plist and ssdt for AMD injection (config_amd_ssdt_10133.zip). With this config and Intel IGPU activated you'll get Metal2 (macOS GPUFamily1 v3). What did I do? Had to fake Skylake graphics or to prevent apps like iMovie or FinalCut from crashing. With Kabylake kexts loaded and IGPU as secondary graphics card, the computer will hard reset whenever the Intel GPU is utilised. Only Skylake kexts and activated IGPU will give you working Metal2 for the RX560.  
      *Update 10.13.2*
      Since this update a new approach is advisable to get the RX560 up and running (works for 10.13.1 and GM as well). I've added a working SSDT and injector kext that gives you graphics and HDMI audio. Sleep works fine too if you add the DSDT I compiled.  
      Credits go to @Toledo @Mork vom Ork and @Mieze because their work made this possible.
      *Update* I've added NEW config.plist and DSDT. For proper graphics power management you have to activate onboard graphics in BIOS but make PCIE the primary display. Furthermore you have to inject ig-platform-id 0x59120003 and let Clover patch GFX0 to IGPU. This is the only way to avoid crashes of iMovie, FinalCut or slowdowns after video playback.

      This may be the smoothest Hackintosh of my life. It is easier than Sierra install due to native support for most of the used hardware in High Sierra. Not much to do, using an up-to-date Clover version like 4184. Make sure you have apfs.efi in /Clover/drivers64UEFI/ on your EFI partition and that you delete EmuVariableUEFi.efi (downside: iMessage doesn't work without it). Somehow Rehabman's SSDT in /Clover/ACPI/patched helps avoiding crashes in iTunes.

      Needed kexts (on your EFI into /Clover/kexts/Other): FakeSMC, IntelMausiEthernet for ethernet, USBInjectAll and XHCI-200-series-injector for USB, Lilu and AppleALC for audio, Whatevergreen for AMD graphics, IntelGraphicsFixup and AMD9xxxControllerPatcher.kext.
      DSDT and SSDT go into EFI/Clover/ACPI/patched.
    • By Carmelo Vazzana
      Hi everyone, I'm trying to install High Sierra, but it's more complicate than the first Build.  After Clover GUI I start the installation in Verbose mode and the sys get stuck most of the times at the line: "Please go to https://panic.apple.comto report this panic", I'm attaching the panic point photo.
      Thanks in advance.