Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
rednut

Nvidia Fermi card(GTX560Ti), Dual Monitors Power Management Issue

7 posts in this topic

Recommended Posts

Please, excuse my poor English.


 


 


My GTX560Ti works fine AGPM(AppleGraphicsPowerManagement) with ONE monitor.


GPU core frequencies, voltages work well according to g-state's changes.


 


But, with dual monitors, GPU's frequencies and voltages are no change.. 


My card always clocks up to its maximum performance even if it's not under load.


(core 880MHz, shader 1760MHz, memory 2100MHz, and voltages 1.00V)


 


As soon as I unplugged secondary monitor, it clocked down to 50MHz, within seconds.


 


 


I've done a lot of testing(changing system identifies, modification info.plist in AGPM, etc), my logs show that GPU switches g-states as it should, however the GPU clock never changes.


 


Of course, under Windows 8, GPU clocks and voltages change very well in dual monitors.


 


 


 


My question is:


 


Is it impossible that fermi card controls GPU power management in dual monitors?

Share this post


Link to post
Share on other sites

I have the same card, same problem. Manufacturer is EVGA, if that makes a difference. I'm going to try and have it load up another ROM and see if it makes a difference. although I don't see how it would.

*Edit: been trying to figure this out for a while, can't seem to find anybody else out there with a similar problem

Share this post


Link to post
Share on other sites

I have tried this with my nVidia EVGA 450 GTS GPU, also with dual-monitor: same issue here!

No clock/voltage down.

 

I'm running the latest nVidia drivers btw. I find out these drivers want to keep the nVidia GPU running on high all the time..

 

What nVidia drivers are you using?

Share this post


Link to post
Share on other sites

the problem is the same on windows too, but in windows its fixed by nvidia inspector with save energy

i have no idea how to fix it on os x, someone said "by design" (means, designed that way)

Share this post


Link to post
Share on other sites

Hi there,

I have the same issue, one monitor connected, and AGPM working perfectly. On dual monitors, GPU stuck at full speed in 3D.

My GPU is EVGA GTX 570 on w/c, BIOS 70.10.49.00.74

 

Really scheme AGPM on dual monitor not working like it should.

 

my AGPM kext:

 

<key>iMac10,1</key>

<dict>
<key>Vendor10deDevice1081</key>
<dict>
<key>Heuristic</key>
<dict>
<key>ID</key>
<integer>0</integer>
<key>IdleInterval</key>
<integer>250</integer>
<key>SensorOption</key>
<integer>1</integer>
<key>SensorSampleRate</key>
<integer>4</integer>
<key>TargetCount</key>
<integer>5</integer>
<key>Threshold_High</key>
<array>
<integer>45</integer>
<integer>80</integer>
<integer>100</integer>
</array>
<key>Threshold_Low</key>
<array>
<integer>80</integer>
<integer>90</integer>
<integer>98</integer>
</array>
</dict>
<key>LogControl</key>
<integer>1</integer>
<key>control-id</key>
<integer>18</integer>
</dict>

post-695598-0-42987400-1393771796_thumb.gif

Share this post


Link to post
Share on other sites

Same problem here with GTX 560.

I tried those utilities to "disable" screens :

 SwitchResX

https://github.com/Eun/DisableMonitor

 

but no luck.

Even though it's nice to have my videoproj disabled (so my mouse wont disappear on a screen that is powered off), OSX still "sees" the second screen and GPU frequencies won't step down...

 

This really sucks, both from apple side that makes a silly screen management and from NVIDIA for this driver limitation.

Only solution so far is to physically disconnect the second screen.

On windows it's OK as I can really disable the second monitor in system preferences....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×