Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Icchan-san

OSX on HP Pavilion Elite

96 posts in this topic

Recommended Posts

Step 1 Getting Ready

 

- Download and Burn the DVD image iAtkos v5i.

- Download and Extract the BIOS v5.17 MOD or BIOS v5.23 MOD make sure your Motherboard model is Asus IPIBL-LB. If your PC is similar but your motherboard is Asus IPIBL-LA you can try this BIOS 5.08 MOD, this is not a MOD bios but work perfect :dev: (Thx, igotjshoe)

- Download and Extract Afuwin

- Prepare your Partition or your Hard Disk to install Leopard

 

Step 2 Modding the Bios

 

Here some pics:

 

 

pic002.jpgpic003.jpg

 

 

To flash the ROM Bios you have to open Afuwin make sure you are the administrator, here is the info with pics

 

This is what you have to do in Afuwin, make sure your not running weird programs:

IMPORTANT: Make a Backup of your BIOS

afuwin.jpg

 

Be careful about the BIOS Flashing, if you dont wanna flash the BIOS just try cpus=1 in darwin

 

Step 3 Installing Leopard

 

Click Here for Screenshots!

 

- Restart your computer and go to the BIOS

- Go to Advanced Tab, set your SATA1 Controller Mode to AHCI Mode

- Now go to the Power Tab and Enable the processor's XD Features, Saving and Exit.

- Boot into the DVD by pressing ESC key at the BIOS Prompt and the installer should load now.

- Select your Language

- Use Disk Utility from the Utilities menu. In Disk Utility, Select your Partition, and format you should choose Mac OS Extended (Journaled). After partitioning, quit Disk Utility to return to the Leopard Installer. Important: Partitioning the disk erases the entire disk, so make sure you back up your important files first.

 

Step 4 - Customize (Updated 09/01/09)

 

iAtkos V5i Main System

Bootloader:

- PC Efi v9

X86 Patches:

- Decrypters:

-- AppleDecrypt

- SMBIOS Drivers:

-- Apple SMBIOS Enablers:

--- SMBIOS-EFI

- Disabler.kext

- OHR

- PS/2 (For these with PS2 Keyboard/Mouse)

- Remove Thermal Kexts

Drivers:

- VGA

-- NVinject

-- nVidia:

--- EFI String for nVidia:

---- 8600 GT 512MB

System:

- SATA/IDE:

-- Intel AHCI SATA

 

- Leopard will now install. This can take a while, so be patient.

- It will ask you to Reboot and dats it.

 

Step 5 Dual Boot

 

Theres alot of forums about this, google is your friend.

 

PPost Installation (Updated 09/01/09)

 

You'll need to install the driver for the Wireless

Wireless: HERE (Ralink RT73)

 

Fixing Audio and Sleep for OSX 10.5.6 (Updated 09/01/09)

 

Audio: HERE (ALC888S)

Sleep Issue: HERE

Video: HERE (8400-8800)

 

How to fix unknown processor string in "About this Mac"

 

go to System/Library/CoreServices/Resorces/English.lproj

 

You will find a file "AppleSystemInfo.string" open it using TextMate and find "UnknownCPUKind" = "Unknown";

replace unknown with the type of your processor for example, Intel® Core™2 Quad. make sure you change only letters only not the special characters like =, " or ;. Save it, it will ask for your permission, enter your password and you are all set, no need to reboot.

 

How to change "About this Mac Graphic"

 

To use these you need to backup the current MacOSX.tif in /System/Library/CoreServices/loginwindow.app/Contents/Resources and then delete MacOSX.tif

 

Then rename the file you download to MacOSX.tif and copy it to /System/Library/CoreServices/loginwindow.app/Contents/Resources

 

Then fix permissions.

 

Logout and login then view About This Mac.

 

And Check HERE for lots of icons biggrin.gif

 

TIPS:

About Leopard Fails Sleep when idle, some apps like Paragon NTFS or MacFuse can affect the OS, try deactivating them and thats it, this Issue even affect the MacBook Pro.

 

Heres a Preview:

 

Update: After Mod you can install any version, even retail version biggrin.gif

 

Picture1-1.jpg

 

P.D: Sowwy about my English and Good Luck :graduated:

Share this post


Link to post
Share on other sites
Advertisement
Guest tsh9

Hi,I tried to install Leopard on my HP Pavilion Elite m9250f by following your instructions but unfortunately, it was not successful.- I've downloaded and burned the DVD image of Leo4all v3- I've set the HD to AHCI Mode.- Booted into the DVD by pressing ESC key at the BIOS Prompt but the installer does not load.- My system reboots over and over ...I did not flash the BIOS ... I don't really want to mess with that.Could you please tell, what I can do I'm noob !Thanks!

Share this post


Link to post
Share on other sites

Without flashing the BIOS you can try with JaS 10.5.4, without any flags after installation u have to type in darwin cpus=1 to boot and dats it baby, enjoy LeopardPD: About Afuwin, u can backup ur BIOS, for fully funcionality try MOD, u can always go back to ur original BIOS using Afuwin if u make ur backup :thumbsup_anim:

Share this post


Link to post
Share on other sites
Guest tsh9

Thanks, I will try that this week-end !Thanks again ...

Share this post


Link to post
Share on other sites
Guest tsh9

Hi Icchan-san,I've finally decided to flash my bios ...I've been able to install leopard but when it reboots after the installation my monitor goes black.Could you tell me in the customize screen in the installation process what options did you checked?Thanks for you're help !

Share this post


Link to post
Share on other sites

Hey there tsh9, go to your BIOS, in Advanced Tab, set your SATA1 Controller Mode to AHCI Mode, then go to Power Tab and Enable the processor's XD Features. Save and Exit. Boot into the DVD, at this point check the Step 3, in the customize screen, I check:

  • Kernel: Vanilla Kernel 9.2.2
  • AppleSMBIOS: DDR800
  • Audio: ALC888 (just work for 2.1 and need patch for HDA, look in this forum for toruga's thread)
  • Graphics Drivers: NVinject - Nvidia 8600 GT 512mb (you have to download another one after installation, http://scottdangel.com/blog/?p=15)
  • Network Drivers: Dont Check anything and download the one in the tutorial
  • ACPIPlatform: Stock version 1.2.1

If you MOD your BIOS dont need to use any flag to boot after this Installation, and as I said in the tutorial you can even try Retail Version, good luck and enjoy Leo :PHere is a little motivation... http://i455.photobucket.com/albums/qq271/i...ma/Picture3.png

Share this post


Link to post
Share on other sites
Guest tsh9

Hi Icchan-san,I was able to install Leopard and everything works... If you were right next to me I would have kissed U !You mentioned that after the Mod I can install any version of Leopard, even retail version. Can I also update Leopard throught "Mac OSX software update"Thanks man !

Share this post


Link to post
Share on other sites

Yeah, just with the retail version, with other u have to download the package and do a couple stuff... but its not a big deal :PI'm glad it works for u ^.^ enjoy.

Share this post


Link to post
Share on other sites
Guest Guest: bpoecell_*

I flashed my bios and now I get a Default bios settings have been loaded due to bios update or checksum issue. every time i set the hd to ACHI it gives me that and i can't install. any suggestions?

Share this post


Link to post
Share on other sites
Guest Guest: bpoecell_*

Also I can't install Windows anymore, when I try it only shows two gigabytes of space and doesn't see either of my 320 gig hard drives.

Share this post


Link to post
Share on other sites

Hi bpoecell, do u have this computer? or one similar? Can u tell me your PC SpectsAbout Windows, did u try setting your BIOS to RAID again?

Share this post


Link to post
Share on other sites
Guest tsh9

Hi icchan-san,I was wondering what "combo update" did you use to go from 10.5.2 to 10.5.5.Thanks again, you have been a great help for a noob like me.

Share this post


Link to post
Share on other sites
Guest Guest: bpoecell_*

It's an HP Pavillion Elite m9300t with the Asus IPIBL-LB motherboard. I'm back into windows now, but bios is still messed up. When you flashed you bios, did you flash the main bios image, or all blocks?

Share this post


Link to post
Share on other sites
Hi icchan-san,I was wondering what "combo update" did you use to go from 10.5.2 to 10.5.5.Thanks again, you have been a great help for a noob like me.
Hi tsh9, you need this one Desktop Combo Update 10.5.5 Theres tutorials in this forum about updating, just follow the steps and cross your fingers ^.^

Share this post


Link to post
Share on other sites
It's an HP Pavillion Elite m9300t with the Asus IPIBL-LB motherboard. I'm back into windows now, but bios is still messed up. When you flashed you bios, did you flash the main bios image, or all blocks?
Ok check the Post again... hope it helps

Share this post


Link to post
Share on other sites
Guest Guest: bpoecell_*

Thanks Icchan-san :thumbsup_anim: . That other page out flashing the bios was kind of vague, I'm sure I did something wrong.

Share this post


Link to post
Share on other sites
Guest Guest: bpoecell_*

It works beautifully now! Which wireless driver did you install from the three that download in that package?

Share this post


Link to post
Share on other sites
It works beautifully now! Which wireless driver did you install from the three that download in that package?
Great News! you have to use the latest one, 10.5.x. enjoy

Share this post


Link to post
Share on other sites

Alright, first off I would just like to thank you deeply for your helpful forum. After like 8 failed attempts using the new iDeneb v1.3 I read through your helpful post and VOILA! It works like a charm. I just got done playing quake 4 on my new mac pro with my 8500gt card working beautifully. However I still have two issues, one being kindve huge to me. The wifi, I have used the driver the provided and it didnt work in 10.5.5 which is what iDeneb installs into. I've even tried a few other custom ralink installs and still nothing. Is there something I'm missing? Is there something I'm supposed to do to turn it on?Also, I have a TV tuner card with a nice remote and I was wondering if maybe there was a way to use it in OS X? Probably not, but it would hella sweet to be able to use my remote and maybe the TV tuner card for my cable so I can record shows. I have an m9252p so I'm sure the hardware is different then yours, but still thanks SOOOOOO much with what patches I should install, the modded BIOS (which I used) and the AHCI hint in the bios. On one last note, does sleep work on yours? I only installed the vanilla kernel but sleep doesnt work really on my system.Thanks!-Bryce

Share this post


Link to post
Share on other sites

Hi brycedemise, this tuto its kinda old XD but yeh everything works in mine, shut down, restart, sleep, read the post installation part to get the wireless driver :DWell I dont know whats yours, maybe you have another one, can you tell me your wireless chipset?I will update this post today

Share this post


Link to post
Share on other sites

Alright well I just bought a USB wifi card that works great in leopard so I'm good to go.I was gonna ask, where did you get your icons from? Also, do you think you would post your TIFF file for the hackintosh logo? Cuz it's pretty rad.Thanks!-Bryce

Share this post


Link to post
Share on other sites
Guest graphicsgirl

Hi Icchan-san,Thanks so much for this wonderful tutorial. I was up an running in os X in less than 30 minutes!I am wondering if you could reupload the audio and sleep drivers because when I click on the link, I get this message from rapidshare:This file is neither allocated to a Premium Account, or a Collector's Account, and can therefore only be downloaded 10 times.This limit is reached.To download this file, the uploader either needs to transfer this file into his/her Collector's Account, or upload the file again. The file can later be moved to a Collector's Account. The uploader just needs to click the delete link of the file to get further information.Thanks so much!

Share this post


Link to post
Share on other sites
Hi Icchan-san,Thanks so much for this wonderful tutorial. I was up an running in os X in less than 30 minutes!I am wondering if you could reupload the audio and sleep drivers because when I click on the link, I get this message from rapidshare:This file is neither allocated to a Premium Account, or a Collector's Account, and can therefore only be downloaded 10 times.This limit is reached.To download this file, the uploader either needs to transfer this file into his/her Collector's Account, or upload the file again. The file can later be moved to a Collector's Account. The uploader just needs to click the delete link of the file to get further information.Thanks so much!
Oh sowwy about that, I have the audio one here, but you´ll have to wait like 4 hours for the sleep one, I have to upload the files somewhere else.Here for audio

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hi,   I still have (and always had) a weird problem with the nvidia card, and I don't know if it is a power unit issue or a driver issue. Do you have such a problem, too:   Sometimes the screen goes black, for example if I scroll a specific webpage. It turns then on again, and off again. Then it may disappear and everyathing works fine again. Or not. Usually a reboot will let this problem disappear. There is no obvious heavy cpu/power usage while this happens.   Do you know this problem? Does it sound like a driver problem?   I use a gt1050 2gb and a 4k monitor connected thru DP.
    • Hello! In my signature system the program does not show the life of the hard drives but only that of the ssd.   High Sierra 10.13.4
    • hello   try this one   DSDT.aml.zip   for graphics and backlight are needed ssdt files   good hack
    • Non ti ho messo io quelle impostazioni I sul config.. Poi aggiorna i kext.. 
    • So, i am thinking about pubblishing the stable release of tinu 2.0, just with a few minor chenges from the last pre-release, and to focus my work on the next one, i have just chenged a couple of UI things for the stable release and add a warning message if you try to use a time machine disk as a target drive to create the macOS install media, for the release that will come after the stable 2.0 release (and maybe also after a bug fix release for the 2.0 if needed) i am trying to use the system apis to manage the tasks which needs special priviladges to be executed, instead of the "sudo" based system which i am using now, this will make the application more secure and reliable, and also you will have to do the authentication only one time, when creating an install media, and using this system maybe i can also pubblish the application on the app store (obviusly just a limited version for mac users, but a version with all the features unlocked will be always available outside the app store and will have all the hackintosh-friendly features as well). But to do that i need to re-write a large amount of code into the app, because all the tasks which needs special permitions needs to be re-implemented differently, so that's why i do not want to use this in the 2.0 release, so because i am going to finish with tinu 2.0 tell me every complain or problem you are having with the latest pre-release or the latest release of tinu, so i can work on that before releaseing the stable 2.0 version


×