Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

ASROCK 4core1333 glan/m realtek 8168 problems

6 posts in this topic

Recommended Posts

Hi guys n gals,


I have installed iAtkos ML2 and lion 10.7 succesfully on my comp. (asrock 4core1333 glan/m q6600 4g ram 6870) and it is stable, except for ethernet. Ethernet is acting weird. The situation is as follows. Up to and including 10.7.4, everything works 100% perfect (except sleep). Since 10.7.5, the ethernet wont work properly, and after a reboot it may or may not be working. It gets weirder. Because when it stops working, it disappears. Like, when going into windows or linux, the ethernet adapter is gone. Like it was never there. I then have to disable ethernet in bios, reboot into an os, shutdown, count till 10, cross my fingers, boot into bios, enable ethernet, and it 9/10 times works again. I have tried many kexts, and lnx2mac is most stable (no KPs). Official realtek drivers seems to work every time, but it ALWAYS gives Kernel panic either during boot, or after 5 seconds of using a web browser. So I decided to try mountain lion. To get mountain lion to actually boot, the secret was to go into the bios and enable "no no execute memory protection" (yes that is right, a double negative for some retarded reason) and than i used USBBusFix=Yes and PciRoot=1 and the sun was shining again. Mountain lion seems slightly different, because the ethernet seems to work after a few reboots automatically again without having to go into the bios 83 times and wasting a lot of time in the process. Other than that, same {censored} different day.



Does anyone know how to get realtek 8168 (81xx) with dev id 816810ec to work in a stable fashion in 10.7.5+ ?


PS: Sorry if I made you read that entire paragraph when it was really quite a simple question



Share this post

Link to post
Share on other sites

Ok I have tried everything, all BIOSes, all different settings, wake on lan on/off etc... It always breaks now in every version of OS X using lnx2mac. But I cant use official realtek, because than it gets a KP after opening web browser. Can anyone recommend me a PCI or USB ethernet card that works perfectly, pref. without any kext? TIA

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      This is a dedicated thread about the intel 8255X based ethernet cards which, although being old (but also very cheap and easy to find used online), they still works in the latest macOS releases today i tested mine with the 64 bit compiled AppleIntel8255X kext and works like a charm! stable and withou any issues with mine 100 mbit managed ethernet switch and also without suffering of problems like connection dieing under heavy load or sleep/wake issues, so just to report that i have create this dedicated thread about and also i leave the kext as an attachment, in this post, this may be usefoul to have cheap working ethernet for hackintosh machines running the latest macOS or just to reuse old hardware some one can have laying around.
    • By ITzTravelInTime
      I have started this thread to discuss about old and very cheap ethernet cards working in the latest macOS releases, cards who just uses old ethernet controllers or are new and cheap cards with old ethernet controllers, this thread is just to discuss about such cards and also to have a list in the first post with reported working cards with drivers linked.
      To contribute you have to report which card of this kind is working for you and which driver or method you followed to get it wo work and also which issues you have, and then it will be added in the list.
      I start reporting cards which worked for me, yours will be added in the future:
      intel 8255X based cards:
                just works using the AppleIntel8255X kext (look in the attachments) and seems to be stable with no issues
      And also there are some cards i am curious to see if can work with mac, so i leave this part at the end of the post, do you know if it's possible to get realtek pci (not pci express) ethernet cards working in the latest mac os? i have a few of them and i have difficulties fining drivers for mac, having a driver for the latest mac wil help me in creating also a youtube video with the cheapest hackintosh compatible ethernet cards
    • By Typhoon_Master
      I am currently using El Capitan with an Asus Maximus II Formula, but the mainboard has a weird bug that the system freezes when im using the built in ethernet ports. (not only in macos, also in linux and windows)
      ... so i was using a USB Dongle wich worked fine, but the performance (USB2) was not the best.
      Now i want to add a ethernet-card to the system.
      Is there a cheap, and simple to install (maybe native?) PCIe Ethernet Networkcard that can be recommended?
      thank you
    • By Discount_Mac
      I have done a semi-successful install of macOS Sierra 10.12.6 on my Dell OptiPlex 3010. When I mean semi-successful, I mean I have some issues left, one of them is Networking.
      Networking, meaning Ethernet, does not seem to work on this machine after installing Mac OS. I've tried installing kext files, reinstalling Sierra, and so on but nothing seems to work, I have an Ethernet cable plugged and it's lights flashing and whatever but the connection does not show up in Sierra.
      My PC Specs are:
      Dell OptiPlex 3010 MT
      Intel Core i3-3240 @ 3.40GHz
      AMD Radeon HD 7470
      4GB of RAM
      Realtek RTL8111E
      So, Any Help?
    • By Mieze
      A New Driver for Realtek RTL8111

      Due to the lack of an OS X driver that makes use of the advanced features of the Realtek RTL81111/8168 series I started a new project with the aim to create a state of the art driver that gets the most out of those NICs which can be found on virtually any cheap board on the market today. Based on Realtek's Linux driver (version 8.035.0) I have written a driver that is optimized for performance while making efficient use of system resources and keeping the CPU usage down under heavy load.

      Key Features of the Driver
      Supports Realtek RTL8111/8168 B/C/D/E/F/G found on recent boards. Support for multisegment packets relieving the network stack of unnecessary copy operations when assembling packets for transmission. No-copy receive and transmit. Only small packets are copied on reception because creating a copy is more efficient than allocating a new buffer. TCP, UDP and IPv4 checksum offload (receive and transmit). TCP segmentation offload under IPv4. Support for TCP/IPv6 and UDP/IPv6 checksum offload. Fully optimized for Mountain Lion (64bit architecture) but should work with Lion too. As of now there is no support for Snow Leopard but it can be added if someone will create the necessary patches. Supports Wake on LAN. Support for Energy Efficient Ethernet (EEE) which can be disabled by setting enableEEE to NO in the drivers Info.plist without rebuild. The default is YES. The driver is published under GPLv2. Limitations
      As checksum offload doesn't work with jumbo frames they are currently unsupported and will definitely never be. No support for 32bit kernels. Installation
      Before you install the driver you have to remove any installed driver for RTL8111/8168.
      Goto /S/L/E and delete the old driver (Lnx2mac, AppleRealtekRTL8169, etc.). Recreate the kernel cache. Open System Preferences and delete the corresponding network interface, e. g. en0. If you forget this step you might experience strange problems with certain Apple domains, iTunes and iCloud later. Reboot. Install the new driver and recreate the kernel cache. I recommend to use Kext Wizard or a similar utility for the installation. Reboot Open System Preferences again, select Network and check if the new network interface has been created automatically or create it manually now. Configure the interface. Troubleshooting
      Make sure you have followed the installation instructions especially when you have issues with certain domains while the others are working fine. Use the debug version to collect log data when trying to track down problems. The kernel log messages can be found in /var/log/system.log. For Sierra and above use "log show --predicate "processID == 0" --debug" in order to retrieve kernel logs. Include the log data when asking for support or giving feedback. I'm an engineer, not a clairvoyant. Check your BIOS settings. You might want to disable Network Boot and the UEFI Network Stack as these can interfere with the driver. Double check that you have removed any other Realtek kext from your system because they could prevent the driver from working properly. Verify your bootloader configuration, in particular the kernel flags. Avoid using npci=0x2000 or npci=0x3000.  In Terminal run netstat -s in order to display network statistics. Carefully examine the data for any unusual activity like a high number of packets with bad IP header checksums, etc. In case auto-configuration of the link layer connection doesn't work it might be necessary to select the medium manually in System Preferences under Network for the interface. Use Wireshark to create a packet dump in order to collect diagnostic information. Keep in mind that there are many manufacturers of network equipment. Although Ethernet is an IEEE standard different implementations may show different behavior causing incompatibilities. In case you are having trouble try a different switch or a different cable. FAQ
      How can I retrieve the kernel logs?In Terminal type "grep kernel /var/log/system.log". ​I want to disable Energy Efficient Ethernet (EEE) but I don't know how?​Take a look at the driver's Info.plist file. There you will find an option named <key>enableEEE</key>. Change its value from <true/> to <false/>. Don't forget to recreate the kernel cache after changing the value.​ WoL from S5 doesn't work with this driver but under Windows it's working. Is this a driver bug?No it isn't, the driver is working as it should because OS X doesn't support WoL from S5. Current status
      The driver has been successfully tested under 10.8.x and 10.9 with the B, C, D, E, F and G versions of the RTL8111/8168 and is known to work stable on these devices. Changelog
      Version 2.2.2 (2018-01-21) Force ASPM state to disabled/enabled according to the config parameter setting. Requires 10.12 or newer. Version 2.2.1 (2016-03-12): Updated underlying linux sources from Realtek to 8.041.00. Added support for RTL8111H. Implemented Apple’s polled receive driver model (RXPOLL). Requires 10.11 or newer. Support for older versions of OS X has been dropped. Version 2.0.0 (2015-06-21): ​Uses Apple's private driver interface introduced with 10.8. Supports packet scheduling with QFQ. Please note that 2.0.0 is identical to 2.0.0d2. Only the version number has changed. Version 1.2.3 (2014-08-23):Reworked TSO4 and added support for TSO6. Version 1.2.2 (2014-08-44): ​Added an option to disable Active State Power Management (ASPM, default disabled) as ASPM seems to result in unstable operation of some chipsets. ​Resolved a problem with Link Aggregation after reboot. Added a workaround for the multicast filter bug of chipset 17 (RTL8111F) which prevented Bonjour from working properly​ ​Version 1.2.0 (2014-04-24): Updated underlying linux sources from Realtek to 8.037.00. Improved interrupt mitigate to use a less aggressive value for 10/100 MBit connections. ​Version 1.1.3 (2013-11-29): Improved transmit queue handling made it possible to reduce CPU load during packet transmission. Improved deadlock detection logic in order to avoid false positives due to lost interrupts. Version 1.1.2 (2013-08-03): Improved SMB performance in certain configurations. Faster browsing of large shares. ​Version 1.1.0 (2013-06-08): Support for TCP/IPv6 and UDP/IPv6 checksum offload added (can be disabled in Info.plist). Maximum size of the scatter-gather-list has been increased from 24 to 40 segments to resolve performance issues with TSO4 when offloading large packets which are highly fragmented. TSO4 can be disabled in Info.plist without rebuild. Statistics gathering has been improved to deliver more detailed information (resource shortages, transmitter resets, transmitter interrupt count). The interrupt mitigate settings has been changed to improve performance with SMB and to reduce CPU load. Configuration option added to allow for user defined interrupt mitigate settings without rebuild. Version 1.0.4 (2013-05-04):Moved setLinkStatus(kIONetworkLinkValid) from start() to enable(). Cleaned up getDescCommand(). Version 1.0.3 (2013-04-25):​The issue after a reboot from Windows has been eliminated. Version 1.0.2 (2013-04-22):​Added support for rx checksum offload of TCP and UDP over IPv6. Version 1.0.1 (2013-03-31): Improved behavior when rx checksum offload isn't working properly. Adds the chipset's model name to IORegistry so that it will show up in System Profiler. Known Issues
      There are still performance problems with regard to SMB in certain configurations. My tests indicate that Apple's Broadcom driver shows the same behavior with those configurations. Obviously it's a more general problem that is not limited to my driver. WoL does not work in certain configurations. Old systems with 3 and 4 series chipsets exhibit performance issues in recent versions of macOS because there is no optimized power management for these systems in macOS anymore as Apple dropped support for the underlying hardware a long time ago. In case you are affected, please upgrade your hardware or find an alternative solution because I have no plans for a workaround. Sorry, but I don't think that it's worth the effort. Getting the driver
      The source code can be found here: https://github.com/M...driver_for_OS_X There is also a pre-build binary for Mavericks and Yosemite: http://www.insanelym...n-and-wireless/  
      Building from Source
      I'm using XCode 4.6.3 for development. You can get a free copy of XCode after becoming a member of the Apple developer program. The free membership is sufficient in order to get access to development tools and documentation.