Jump to content
InsanelyMac Forum
Sign in to follow this  
Ak-RakRak

SL 10.6.8 - Fsck fails - have "single user" r/o filesystem access

Recommended Posts

Hi,

 

I have a Hackintosh running Snow Leopard (only just upgraded to 10.6.8) that has decided to go belly up when I decided to reinstall voodooHDA. I suspect that I repaired permissions just prior to running voodoohda setup without rebooting first. I tried voodooHDA as I had just updated Final Cut Pro X via software updates and had lost sound except for some crackling. The system will boot to single-user mode command line, but trying to make the disk writeable with fsck -fy only results in a kernel panic with fsck as the relevant thread. I can ls the files on the drive but am unable to copy them to a newly formatted 1Tb external USB disk because I cannot make the system writeable. Naturally, voodooHDA-uninstall runs but can't do anything to a readonly disk.

 

I have also tried to run diskutil from single user mode using launchctl load ...etc. and starting diskarbitration but that failed with a panic.

 

Has anyone any ideas on how to get the system to boot successfully once again? It has been extremely stable until now, no doubt a factor in my complacency in not having an image available to rebuild it and my original USB stick installer is not playing nice. I do have the Snow Leopard upgrade disk though and could rebuild the original USB boot installer if needed (athough it will need a 50 mile round trip). Is there a possibility of doing an OS in-place reinstall without a reformat?

 

A look at the Fsck_hfs log and the security.log seem to show system install issues as the last entries.

 

System specs;

 

GIGABYTE GA-EP45-UD3P Intel P45 ATX Intel Motherboard

Intel Core 2 Quad 3.0GHz LGA 775 95W Quad-Core Processor

Axle GeForce 9800 GTX+ 512MB 256-bit GDDR3 PCI Express 2.0 x16

Patriot Extreme Performance (2 x 2GB) DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory x 2 (8GB all up)

Western Digital Caviar Green WD10EADS 1TB SATA 3.0Gb/s 3.5" Internal Hard Drive

Asus CD/DVD Burner Black SATA Model

PCI Copper Gigabit Network Adapter

 

This runs through a KVM that controls the Hackintosh and the PC through a Viewsonic monitor and Logitech mouse and Microsoft PS/2 keyboard. I sometimes use the Apple keyboard directly connected to the Hackintosh when i need access to the special keys.

 

Whoops! On rereading the above I seem to have forgotten my manners.

 

I would appreciate any help anyone can give me on the above, please. But please be nice - I'm new here! If anyone can help please let me know what further information you need.

 

Best wishes to all for the New Year.

Share this post


Link to post
Share on other sites
Advertisement

... Well, I'm catching up on my Unix.

 

I thought maybe the 10.6.8 update might have put AppleHDA.kext back in Extensions but I've looked at my Extensions folder and have VoodooHDA.kext in there, no AppleHDA.kext, so my hopes of fixing the prob by deleting AppleHDA are dashed. Strangely, I tried a find / *.kext but must have slipped with the wildcard and the system started returning all the files on the volume, the listing failed eventually (after listing many, many files) with an error 2 and showing find as the referring thread. Isn't error 2 an addressing error?

 

I'm beginning to wonder if I have a hardware failure somewhere, next step will be to run memtest, I guess. Have arranged to rebuild a USB bootable next week and am thinking of running Applejack from that, then perhaps DiskWarrior. Those after cloning the HDD to another drive and working on the clone.

 

Any ideas anyone?? Am I missing something obvious?

Share this post


Link to post
Share on other sites

Ok, memtest86+ on an Ubuntu 12.04 LiveCD overnight showed no problems with RAM, so I guess I can rule RAM out of the possible hardware probs. Now I'll have to wait until I can recreate my USB boot disk before I go any further.

 

Would it encourage assistance if I uploaded the -v panic screen??

Share this post


Link to post
Share on other sites

All better now. Made a new bootable USB stick, with Applejack and Carbon Copy Cloner. Copied original HDD to an image file on the spare HDD. Ran Diskutil from USB stick. Repaired permissions and bingo. GUI back, fsck_hfs runs without a hitch. Permissions did not seem to show much except the usual Java stuff.

 

It was interesting to note that having saved an image of the drive and fixed the original drive, I cloned the "fixed" drive but the clone would not boot and KP's with fsck error. Once the permissions were repaired it would boot.

 

I checked the Extensions folder to ensure AppleHDA.kext hadn't appeared somehow, but Voodoohda.kext was the only HDA kext there. Reactivated azalia in the BIOS and voila, sound had returned.

 

Hopefully, this saga may help someone else .....

Share this post


Link to post
Share on other sites

Thanks, but I did have a flash boot USB stick, it just wouldn't work. No doubt this was because my system was so stable for so long something corrupted on the stick over the year or so - cosmic rays perhaps :worried_anim: . The lesson is more appropriately, MAINTAIN a Hackintosh-bootable image on a stick or other partition, ie. check it now and again and have it periodically refreshed.

 

I still am not any the wiser what happened. It would seem that the GUI just would not start due to a permissions issue that was stopping fsck so the OS chucked a wobbly. Anyway, all better now and I am back to learning the ins and outs of Final Cut Pro X and have refreshed my limited knowledge of the Unix (OS X flavor) command line.

Share this post


Link to post
Share on other sites

Stick a bootable copy on a DVD.

Or stick your bootable install DVD into your drive, let it boot, and choose utilities instead of install when you get to that point. You can repair your permission and your operating system on the harddrive, then.

 

And unless you scratch the DVD or something, it will never go bad.

 

When you go into Single Mode:

 

type /sbin/fsck -fy and let it run (twice if it comes up with fixing errors)

then type /sbin/mount/-uw / and you will have read/write acces to your harddrive.

 

With applejack, run that in Single Mode instead of fsck or after it. just type in applejack auto reboot and let it run. May go as long as 15 minutes or so. but it will fix your permissions and os.

Share this post


Link to post
Share on other sites

thanks Alaskantraveler (hey, I have Aussie friends who did just that recently - Fairbanks, Petersburg, Juneau, some glacier or other, hopping around by mail plane).

 

Yup, I'll make up a bootable DVD - as you say, I should have done that originally. I knew I could get r/w access to the HDD with mount -uw from the command line on the original HDD but didn't know what damage I might be doing if the filesystem was corrupted, since running fsck caused a KP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By MikixIT
      Salve a tutti, sono nuovo
      Ho un problema per installare il mio primo hackintosh 
      le mie spec sono: i7 720qm , gt730 2 gb ddr3, 8 gb di ram e una motherboard che non si capisce modello sia(perchè? perchè è un preassemblato a cui ho modificato i componenti mi lascio anche uno screen di cpuid se può essere utile comunque è legacy,comunque la motherboard è intel. )
       
      Comunque ho creato un boot usb con clever per installare Sierra e tutto va okay fin quiando vado in kernel panic, ho provato diverse boot flags ma non riesco ad arrivare all'installer di Cupertino
      CHIEDO AIUTO,grazie ancora aspetto risposte
    • By MikixIT
      Hi guys
      i need help for this kernel panic its the first hackintosh for me
      I posted photo error
      my spec: i7 720qm,gt 730 2 gb ddr3 msi,8 gb ram
      its a desktop
       
      Pls help me

    • By Tom Snow
      Hello everyone, ever since installing the security update at the end of January, I've been having two issues.
       
      The first is the kernel panic that happens every time I try to boot. After much research, here and elsewhere, I learned that the issue is Lilu.kext which I did not update prior to installing the security update. So now I have the latest version downloaded to a USB drive, but I cannot copy it to the hackintosh...
       
      Every time I try to boot into Recovery, the system just locks up. So I tried replacing the file via the UEFI shell and again from Kali, and in both cases I couldn't because both OS's see the Mac's file system as "read-only." I did some research on how to fix Recovery and found that I need to put FakeSMC.kext in the /EFI/CLOVER/Kexts/Other directory on the Recovery HD, which I cannot do for the same reason I can't replace the Lilu file (the HD is read-only to all other OS's).
       
      I tried booting off my old Snow Leopard CD, and that doesn't work either; every time I try it just quits mid-boot, resets the computer and reboots into Clover.
       
      Can anyone give me any suggestions? I'm out of ideas at this point.
    • By superdooper71
      Hi all,
      I am trying to build a system with the following Components, but I am running into trouble ; )

      ASRock Z270M Pro4 Micro ATX Intel Motherboard
      Intel Core i7-7700K Kaby Lake Socket 1151 CPU w/Intel HD Graphics 630
      Crucial Ballistix Sport 32GB (2x16GB) 288-Pin DDR4 2400MT/s (PC4-19200) Desktop Memory
      Gigabyte Nvidia GeForce GTX 1060 3GB GDDR5 Graphics Card
      Uptown Cube Case mATX
      Cooler Master CPU cooling
      Tecnoware 650W Power Supply
      Kingston 120GB M.2 Solid State Drive (System only)
      Kingston SSDnow 256GB SATA3 SSD
      Seagate Barracuda 2TB Hard Drive

      Mac OSX Sierra 10.12.6

      I have issues getting my 10.12.6 Sierra USB drive complete the installation.
      The system load the USB it starts and then freeze almost at the end.

      I booted in verbose mode and iget stuck on "appleacpicpu"

      I enclose the EFI folder completed with the config.plist I am using. Please can someone help me as I am struggling fromxmas and my little selfmade pressy turned as a nightmare : )

      Cheers
      Franco
    • By sistoelemento
      KP appears randomly!
      This issue gets solved when i replace the kexts in s/l/e with the untouched ones from another OSX installation. But again reaches KP when rebooted.

      The KP message shows IOGraphicsFamily as the suspected kext.

      What i did to get rid of the error temporarily (getting reverted on reboot)

      >Booted in safemode
      >Used kexwizard to replace kexts(list of kexts attached) in s/l/e as they are recently modified. Found out this by sorting the s/l/e directory according to date modified!
      >Replaced with original kexts from another 10.12.6 system > reboot > Now the system boots perfectly.

      But when i restart - the KP appears again.


      OSX: 10.12.6
      Intel HD 530 
      Core i3 Skylake 3.7Ghz
      Dell Optiplex 3046

      See my Clover config attached

      config (1).plist.zip
×